aboutsummaryrefslogtreecommitdiffstats
path: root/science/py-obspy
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2021-05-11 04:06:35 +0800
committerThierry Thomas <thierry@FreeBSD.org>2021-05-11 04:13:20 +0800
commit1d44af58980136b882d146f21d8776943a14c5eb (patch)
treef3a678f8aea7c2044c105d15a6ff7c7afec40762 /science/py-obspy
parentaea041f3a2b531c0265897f6aec59936a96a9f35 (diff)
downloadfreebsd-ports-gnome-1d44af58980136b882d146f21d8776943a14c5eb.tar.gz
freebsd-ports-gnome-1d44af58980136b882d146f21d8776943a14c5eb.tar.zst
freebsd-ports-gnome-1d44af58980136b882d146f21d8776943a14c5eb.zip
math/py-matplotlib: chase minimum Python version in dependent ports
Since the previous update changed USES=python from 3.6+ to 3.7+, all dependent ports must have USES=python:3.7+ as well, otherwise it breaks the @py36 flavor. PR: 255347 Reported by: sunpoet
Diffstat (limited to 'science/py-obspy')
-rw-r--r--science/py-obspy/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/science/py-obspy/Makefile b/science/py-obspy/Makefile
index 1e2b24e6360b..6b77bdbc952f 100644
--- a/science/py-obspy/Makefile
+++ b/science/py-obspy/Makefile
@@ -21,7 +21,7 @@ BUILD_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}sqlalchemy10>=0:databases/py-sqlalchemy10@${PY_FLAVOR}
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= fortran python:3.6+ shebangfix zip
+USES= fortran python:3.7+ shebangfix zip
SHEBANG_FILES= obspy/taup/tests/data/TauP_test_data/gendata.sh
USE_LDCONFIG= yes
LDFLAGS+= -shared