aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2016-08-27 23:55:30 +0800
committerpawel <pawel@FreeBSD.org>2016-08-27 23:55:30 +0800
commit16e55dd3bca667b22b23d27e9a77a2a9ed671c9a (patch)
tree43590a6333861367c977eab3b1c401467d4c9a61 /science
parentb32705f34a436eedcd3a7f6ba64dcf168a22f070 (diff)
downloadfreebsd-ports-gnome-16e55dd3bca667b22b23d27e9a77a2a9ed671c9a.tar.gz
freebsd-ports-gnome-16e55dd3bca667b22b23d27e9a77a2a9ed671c9a.tar.zst
freebsd-ports-gnome-16e55dd3bca667b22b23d27e9a77a2a9ed671c9a.zip
- Update to 4.10.2 [1]
- Add patches to fix build on head [1] - Change MASTER_SITES to new directory structure [1] - Take maintainership [1] - Register proxy dependencies found by stage-qa for QT4 option - Use options helpers PR: 212186 [1] Submitted by: Danilo G. Baio [1]
Diffstat (limited to 'science')
-rw-r--r--science/silo/Makefile21
-rw-r--r--science/silo/distinfo5
-rw-r--r--science/silo/files/patch-src_hdf5__drv_H5FDsilo.c39
-rw-r--r--science/silo/files/patch-src_silo_silo.c39
-rw-r--r--science/silo/files/patch-src_silo_silo__json.c15
5 files changed, 104 insertions, 15 deletions
diff --git a/science/silo/Makefile b/science/silo/Makefile
index 7d82de61c331..c8712805b775 100644
--- a/science/silo/Makefile
+++ b/science/silo/Makefile
@@ -2,13 +2,12 @@
# $FreeBSD$
PORTNAME= silo
-PORTVERSION= 4.10
+PORTVERSION= 4.10.2
DISTVERSIONSUFFIX= -bsd
-PORTREVISION= 3
CATEGORIES= science
-MASTER_SITES= https://wci.llnl.gov/codes/${PORTNAME}/silo-${PORTVERSION}/
+MASTER_SITES= http://wci.llnl.gov/content/assets/docs/simulation/computer-codes/${PORTNAME}/silo-${PORTVERSION}/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= dbaio@bsd.com.br
COMMENT= Mesh and field I/O library and scientific database
LICENSE= BSD3CLAUSE
@@ -35,18 +34,14 @@ HDF5_PLIST_SUB_OFF= SUFX_HDF5=""
PYTHON_CONFIGURE_ENABLE= pythonmodule
PYTHON_USES= python:2
-QT4_USE= XORG=xext,xi,xmu,xt \
- QT4=gui,linguisttools_build,moc_build,uic_build
+QT4_USE= XORG=ice,sm,x11,xext,xi,xmu,xt \
+ QT4=corelib,gui,linguisttools_build,moc_build,uic_build
QT4_CONFIGURE_ON= --with-Qt-dir=${QT_PREFIX} \
--with-Qt-lib="QtGui -lQtCore"
QT4_CONFIGURE_ENABLE= silex
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MQT4}
-QT_NONSTANDARD= yes
-DESKTOP_ENTRIES="Silex" "Silex browser for Silo files" "" "silex" "" true
-.endif
+QT4_VARS= QT_NONSTANDARD=yes
+QT4_DESKTOP_ENTRIES= "Silex" "Silex browser for Silo files" \
+ "" "silex" "" true
post-extract:
@${CHMOD} -R a+rX ${WRKSRC}
diff --git a/science/silo/distinfo b/science/silo/distinfo
index 20ccf8986d89..65ee1162a92f 100644
--- a/science/silo/distinfo
+++ b/science/silo/distinfo
@@ -1,2 +1,3 @@
-SHA256 (silo-4.10-bsd.tar.gz) = e801f2c86de8e42059c09b2a274285ad8d30da1fff4134e359fadf70fd07aca0
-SIZE (silo-4.10-bsd.tar.gz) = 13067090
+TIMESTAMP = 1472243085
+SHA256 (silo-4.10.2-bsd.tar.gz) = 4b901dfc1eb4656e83419a6fde15a2f6c6a31df84edfad7f1dc296e01b20140e
+SIZE (silo-4.10.2-bsd.tar.gz) = 13067837
diff --git a/science/silo/files/patch-src_hdf5__drv_H5FDsilo.c b/science/silo/files/patch-src_hdf5__drv_H5FDsilo.c
new file mode 100644
index 000000000000..5957219a342f
--- /dev/null
+++ b/science/silo/files/patch-src_hdf5__drv_H5FDsilo.c
@@ -0,0 +1,39 @@
+--- src/hdf5_drv/H5FDsilo.c.orig 2014-10-14 00:22:32 UTC
++++ src/hdf5_drv/H5FDsilo.c
+@@ -160,27 +160,15 @@ product endorsement purposes.
+ * xxx64 versions if available.
+ */
+ #if !defined(HDfstat) || !defined(HDstat)
+- #if H5_SIZEOF_OFF_T!=8 && H5_SIZEOF_OFF64_T==8 && defined(H5_HAVE_STAT64)
+- #ifndef HDfstat
+- #define HDfstat(F,B) fstat64(F,B)
+- #endif /* HDfstat */
+- #ifndef HDstat
+- #define HDstat(S,B) stat64(S,B)
+- #endif /* HDstat */
+- typedef struct stat64 h5_stat_t;
+- typedef off64_t h5_stat_size_t;
+- #define H5_SIZEOF_H5_STAT_SIZE_T H5_SIZEOF_OFF64_T
+- #else /* H5_SIZEOF_OFF_T!=8 && ... */
+- #ifndef HDfstat
+- #define HDfstat(F,B) fstat(F,B)
+- #endif /* HDfstat */
+- #ifndef HDstat
+- #define HDstat(S,B) stat(S,B)
+- #endif /* HDstat */
+- typedef struct stat h5_stat_t;
+- typedef off_t h5_stat_size_t;
+- #define H5_SIZEOF_H5_STAT_SIZE_T H5_SIZEOF_OFF_T
+- #endif /* H5_SIZEOF_OFF_T!=8 && ... */
++ #ifndef HDfstat
++ #define HDfstat(F,B) fstat(F,B)
++ #endif /* HDfstat */
++ #ifndef HDstat
++ #define HDstat(S,B) stat(S,B)
++ #endif /* HDstat */
++ typedef struct stat h5_stat_t;
++ typedef off_t h5_stat_size_t;
++ #define H5_SIZEOF_H5_STAT_SIZE_T H5_SIZEOF_OFF_T
+ #endif /* !defined(HDfstat) || !defined(HDstat) */
+ #ifndef HDlseek
+ #ifdef H5_HAVE_LSEEK64
diff --git a/science/silo/files/patch-src_silo_silo.c b/science/silo/files/patch-src_silo_silo.c
new file mode 100644
index 000000000000..3dc31c5c2579
--- /dev/null
+++ b/science/silo/files/patch-src_silo_silo.c
@@ -0,0 +1,39 @@
+--- src/silo/silo.c.orig 2014-10-14 00:22:33 UTC
++++ src/silo/silo.c
+@@ -226,12 +226,8 @@ typedef struct db_silo_stat_t {
+ #ifndef SIZEOF_OFF64_T
+ #error missing definition for SIZEOF_OFF64_T in silo_private.h
+ #else
+-#if SIZEOF_OFF64_T > 4
+- struct stat64 s;
+-#else
+ struct stat s;
+ #endif
+-#endif
+ #ifdef _WIN32
+ DWORD fileindexlo;
+ DWORD fileindexhi;
+@@ -2283,11 +2279,7 @@ db_silo_stat_one_file(const char *name,
+ errno = 0;
+ memset(&(statbuf->s), 0, sizeof(statbuf->s));
+
+-#if SIZEOF_OFF64_T > 4
+- retval = stat64(name, &(statbuf->s));
+-#else
+ retval = stat(name, &(statbuf->s));
+-#endif /* #if SIZEOF_OFF64_T > 4 */
+
+ #ifdef _WIN32
+ if (retval == 0)
+@@ -4225,11 +4217,7 @@ DBOpenReal(const char *name, int type, i
+ /********************************/
+ /* System level error occured. */
+ /********************************/
+-#if SIZEOF_OFF64_T > 4
+- printf("stat64() failed with error: ");
+-#else
+ printf("stat() failed with error: ");
+-#endif
+ switch (errno)
+ {
+ case EACCES: printf("EACCES\n"); break;
diff --git a/science/silo/files/patch-src_silo_silo__json.c b/science/silo/files/patch-src_silo_silo__json.c
new file mode 100644
index 000000000000..39fbe59bbae4
--- /dev/null
+++ b/science/silo/files/patch-src_silo_silo__json.c
@@ -0,0 +1,15 @@
+--- src/silo/silo_json.c.orig 2014-10-14 00:22:33 UTC
++++ src/silo/silo_json.c
+@@ -441,12 +441,8 @@ json_object_from_binary_file(char const
+ #ifndef SIZEOF_OFF64_T
+ #error missing definition for SIZEOF_OFF64_T in silo_private.h
+ #else
+-#if SIZEOF_OFF64_T > 4
+- struct stat64 s;
+-#else
+ struct stat s;
+ #endif
+-#endif
+
+ errno = 0;
+ memset(&s, 0, sizeof(s));