aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-08-26 01:00:46 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-08-26 01:00:46 +0800
commit2ee3e035f1992c0c8d13048545bd345cd22089f0 (patch)
treeb8ac7ced6febf6ba4fc4d9df2dcc3b1c28748b2b /science
parentc725a6ecf6bf3ab4066984f8654939fa1f85365d (diff)
downloadfreebsd-ports-gnome-2ee3e035f1992c0c8d13048545bd345cd22089f0.tar.gz
freebsd-ports-gnome-2ee3e035f1992c0c8d13048545bd345cd22089f0.tar.zst
freebsd-ports-gnome-2ee3e035f1992c0c8d13048545bd345cd22089f0.zip
- Update to 1.1.0
- Switch to USES=ssl PR: 211263 Submitted by: mp39590@gmail.com (maintainer)
Diffstat (limited to 'science')
-rw-r--r--science/orthanc/Makefile14
-rw-r--r--science/orthanc/distinfo5
-rw-r--r--science/orthanc/files/patch-OrthancServer_FromDcmtkBridge.cpp11
-rw-r--r--science/orthanc/files/patch-Resources_CMake_DcmtkConfiguration.cmake22
-rw-r--r--science/orthanc/pkg-plist1
5 files changed, 22 insertions, 31 deletions
diff --git a/science/orthanc/Makefile b/science/orthanc/Makefile
index 078be3f79733..c2ef110d07d0 100644
--- a/science/orthanc/Makefile
+++ b/science/orthanc/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= orthanc
-PORTVERSION= 1.0.0
-PORTREVISION= 1
+PORTVERSION= 1.1.0
CATEGORIES= science graphics net www
MASTER_SITES= http://orthanc-server.com/downloads/get.php?path=/orthanc/:main \
http://www.montefiore.ulg.ac.be/~jodogne/Orthanc/ThirdPartyDownloads/:mongoose
@@ -18,9 +17,6 @@ COMMENT= RESTful DICOM server for healthcare and medical research
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_powerpc64= Does not build
-
-BUILD_DEPENDS= gtest-config:devel/googletest
LIB_DEPENDS= libcurl.so:ftp/curl \
libjsoncpp.so:devel/jsoncpp \
libuuid.so:misc/e2fsprogs-libuuid \
@@ -34,18 +30,22 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libcharls.so:devel/dcmtk \
libdcmjpls.so:devel/dcmtk \
libsqlite3.so:databases/sqlite3 \
+ libpng16.so:graphics/png \
+ libgtest.so:devel/googletest \
libpugixml.so:textproc/pugixml
+BROKEN_powerpc64= Does not build
+
CMAKE_ARGS= -DDCMTK_LIBRARIES="dcmdsig;charls;dcmjpls" \
-DDCMTK_DIR="${LOCALBASE}" \
-DDCMTK_DICTIONARY_DIR="${LOCALBASE}/share/dcmtk" \
-DUSE_SYSTEM_MONGOOSE=OFF \
-DUNIT_TESTS_WITH_HTTP_CONNEXIONS=OFF
-USES= cmake:outsource dos2unix lua:51 python:build
+USES= cmake:outsource dos2unix jpeg lua:51 python:build ssl
+CFLAGS+= -I${LOCALBASE}/include
DOS2UNIX_FILES= CMakeLists.txt
USE_LDCONFIG= yes
-USE_OPENSSL= yes
USE_RC_SUBR= orthanc
WRKSRC= ${WRKDIR}/Orthanc-${PORTVERSION}
USERS= orthanc
diff --git a/science/orthanc/distinfo b/science/orthanc/distinfo
index 1b4bdf80eb72..e116013147bb 100644
--- a/science/orthanc/distinfo
+++ b/science/orthanc/distinfo
@@ -1,4 +1,5 @@
-SHA256 (orthanc/Orthanc-1.0.0.tar.gz) = 3fc37a0fc91e597cc4004934b14726595b5e97b7e328e03dedb4454096bd1bbb
-SIZE (orthanc/Orthanc-1.0.0.tar.gz) = 1164342
+TIMESTAMP = 1469014978
+SHA256 (orthanc/Orthanc-1.1.0.tar.gz) = e8e7ce79dc327b8d0cd4917a520d867260eb58a34a2eea5e24a56db3540edbd4
+SIZE (orthanc/Orthanc-1.1.0.tar.gz) = 1152366
SHA256 (orthanc/mongoose-3.8.tgz) = 6afc2c377614a01a24b78560a62d1316b29372afe08eae3715b56c877be71c6e
SIZE (orthanc/mongoose-3.8.tgz) = 1577314
diff --git a/science/orthanc/files/patch-OrthancServer_FromDcmtkBridge.cpp b/science/orthanc/files/patch-OrthancServer_FromDcmtkBridge.cpp
new file mode 100644
index 000000000000..aeb0942a3991
--- /dev/null
+++ b/science/orthanc/files/patch-OrthancServer_FromDcmtkBridge.cpp
@@ -0,0 +1,11 @@
+--- OrthancServer/FromDcmtkBridge.cpp.orig 2016-07-20 11:36:11 UTC
++++ OrthancServer/FromDcmtkBridge.cpp
+@@ -197,7 +197,7 @@ namespace Orthanc
+ LoadEmbeddedDictionary(*locker, EmbeddedResources::DICTIONARY_DICOM);
+ LoadEmbeddedDictionary(*locker, EmbeddedResources::DICTIONARY_PRIVATE);
+
+-#elif defined(__linux__) || defined(__FreeBSD_kernel__)
++#elif defined(__linux__) || defined(__FreeBSD__)
+ std::string path = DCMTK_DICTIONARY_DIR;
+
+ const char* env = std::getenv(DCM_DICT_ENVIRONMENT_VARIABLE);
diff --git a/science/orthanc/files/patch-Resources_CMake_DcmtkConfiguration.cmake b/science/orthanc/files/patch-Resources_CMake_DcmtkConfiguration.cmake
deleted file mode 100644
index ddc0bcd7c684..000000000000
--- a/science/orthanc/files/patch-Resources_CMake_DcmtkConfiguration.cmake
+++ /dev/null
@@ -1,22 +0,0 @@
-Fix the build with CMake 3.5.0.
-
-FindDCMTK.cmake was rewritten upstream, and is incompatible with the uses in
-this file: we need to set DCMTK_DIR in the port's Makefile, and it does not
-match the directory used for searching for the headers below.
---- Resources/CMake/DcmtkConfiguration.cmake.orig 2015-12-15 16:49:02 UTC
-+++ Resources/CMake/DcmtkConfiguration.cmake
-@@ -186,10 +186,10 @@ else()
- -DHAVE_CONFIG_H=1
- )
-
-- if (EXISTS "${DCMTK_DIR}/config/cfunix.h")
-- set(DCMTK_CONFIGURATION_FILE "${DCMTK_DIR}/config/cfunix.h")
-- elseif (EXISTS "${DCMTK_DIR}/config/osconfig.h") # This is for Arch Linux
-- set(DCMTK_CONFIGURATION_FILE "${DCMTK_DIR}/config/osconfig.h")
-+ if (EXISTS "${DCMTK_config_INCLUDE_DIR}/cfunix.h")
-+ set(DCMTK_CONFIGURATION_FILE "${DCMTK_config_INCLUDE_DIR}/cfunix.h")
-+ elseif (EXISTS "${DCMTK_config_INCLUDE_DIR}/osconfig.h") # This is for Arch Linux
-+ set(DCMTK_CONFIGURATION_FILE "${DCMTK_config_INCLUDE_DIR}/osconfig.h")
- else()
- message(FATAL_ERROR "Please install libdcmtk*-dev")
- endif()
diff --git a/science/orthanc/pkg-plist b/science/orthanc/pkg-plist
index 35d3e965efb0..ddcea532f3b0 100644
--- a/science/orthanc/pkg-plist
+++ b/science/orthanc/pkg-plist
@@ -15,4 +15,5 @@ include/orthanc/OrthancCppDatabasePlugin.h
%%DATADIR%%/plugins/libServeFolders.so.%%PORTVERSION%%
%%DATADIR%%/plugins/libModalityWorklists.so
%%DATADIR%%/plugins/libModalityWorklists.so.%%PORTVERSION%%
+bin/OrthancRecoverCompressedFile
sbin/Orthanc