aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2013-12-28 04:26:21 +0800
committertijl <tijl@FreeBSD.org>2013-12-28 04:26:21 +0800
commit37855234824108cef834623d7974b555de3bf906 (patch)
tree5e5fe4cc738333685f7b7ef4df7a5ae3883599e1 /science
parent16671c85dce42fd4ed08a52f83441cb02c952ca0 (diff)
downloadfreebsd-ports-gnome-37855234824108cef834623d7974b555de3bf906.tar.gz
freebsd-ports-gnome-37855234824108cef834623d7974b555de3bf906.tar.zst
freebsd-ports-gnome-37855234824108cef834623d7974b555de3bf906.zip
- USES=fortran gmake.
- Set MAKE_ARGS instead of MAKE_FLAGS. - Replace some += with =. - Staging.
Diffstat (limited to 'science')
-rw-r--r--science/isaac-cfd/Makefile34
1 files changed, 16 insertions, 18 deletions
diff --git a/science/isaac-cfd/Makefile b/science/isaac-cfd/Makefile
index 37e4eccc5724..bc493e005b6f 100644
--- a/science/isaac-cfd/Makefile
+++ b/science/isaac-cfd/Makefile
@@ -14,22 +14,26 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Integrated Solution Algorithm for Arbitrary Configuration
NO_WRKSUBDIR= yes
-USE_GMAKE= yes
MAKEFILE= makefile
-MAKE_FLAGS+= CPPFLAGS=-I.
-USE_FORTRAN= yes
+MAKE_ARGS= CPPFLAGS=-I.
+USES= fortran gmake
-PLIST_FILES+= bin/isaac
+PLIST_FILES= bin/isaac
PORTDOCS= man.4_2.ps.gz
PORTEXAMPLES= *
OPTIONS_DEFINE= DOCS EXAMPLES OPTIMIZED_FFLAGS
OPTIMIZED_FFLAGS_DESC= Use extra compiler (fortran) optimizations
-DOCS_DISTFILES+= man.4_2.ps.gz
-EXAMPLES_DISTFILES+= example_cases${EXTRACT_SUFX}
+DOCS_DISTFILES= man.4_2.ps.gz
+EXAMPLES_DISTFILES= example_cases${EXTRACT_SUFX}
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MOPTIMIZED_FFLAGS}
+FFLAGS+= -O2 -ffast-math
+.endif
-NO_STAGE= yes
pre-configure:
@${REINPLACE_CMD} -e 's+%%FC%%+${FC}+g ; s+%%FFLAGS%%+${FFLAGS}+;' \
${WRKSRC}/makefile
@@ -37,22 +41,16 @@ pre-configure:
${REINPLACE_CMD} -e 's|SRC= $$(HOME)/ISAAC/src|SRC= ${WRKSRC}|; \
s|$$(FFLAGS)|${FFLAGS} -I.|' {} \;
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MOPTIMIZED_FFLAGS}
-FFLAGS+= -O2 -ffast-math
-.endif
-
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/isaac ${PREFIX}/bin/isaac
+ ${INSTALL_PROGRAM} ${WRKSRC}/isaac ${STAGEDIR}${PREFIX}/bin/isaac
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${CP} ${DISTDIR}/${DIST_SUBDIR}/${PORTDOCS} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${CP} ${DISTDIR}/${DIST_SUBDIR}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${TAR} -xzf ${DISTDIR}/${DIST_SUBDIR}/example_cases${EXTRACT_SUFX} \
- -C ${EXAMPLESDIR}/
+ -C ${STAGEDIR}${EXAMPLESDIR}
.endif
.include <bsd.port.mk>