aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorlwhsu <lwhsu@FreeBSD.org>2013-03-03 06:32:48 +0800
committerlwhsu <lwhsu@FreeBSD.org>2013-03-03 06:32:48 +0800
commit5421797ae6616faade53ae8d4f272d1f900b6fab (patch)
tree189a0a82202d8273b3544d953ccfd229c1eb7faf /science
parent224a7fe880cb070c2e8577c99a8e06dc806416ff (diff)
downloadfreebsd-ports-gnome-5421797ae6616faade53ae8d4f272d1f900b6fab.tar.gz
freebsd-ports-gnome-5421797ae6616faade53ae8d4f272d1f900b6fab.tar.zst
freebsd-ports-gnome-5421797ae6616faade53ae8d4f272d1f900b6fab.zip
- Update *_DEPENDS on x11-toolkits/py-tkinter after _tkinter.so relocation
Diffstat (limited to 'science')
-rw-r--r--science/mayavi/Makefile13
-rw-r--r--science/py-paida/Makefile9
2 files changed, 7 insertions, 15 deletions
diff --git a/science/mayavi/Makefile b/science/mayavi/Makefile
index cef332f2dec3..2f739c1faa63 100644
--- a/science/mayavi/Makefile
+++ b/science/mayavi/Makefile
@@ -1,14 +1,9 @@
-# ex:ts=8
-# Ports collection makefile for: mayavi
-# Date created: Mar 9, 2002
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= mayavi
PORTVERSION= 1.5
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= science python
MASTER_SITES= SF
DISTNAME= MayaVi-${PORTVERSION}
@@ -16,9 +11,9 @@ DISTNAME= MayaVi-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A scientific data visualizer
-BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinter
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/vtk.pth:${PORTSDIR}/math/vtk-python \
- ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
+ ${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinter
USE_PYTHON= yes
USE_PYDISTUTILS= yes
diff --git a/science/py-paida/Makefile b/science/py-paida/Makefile
index 8ac41f1fd687..5f4ba9dd7cc0 100644
--- a/science/py-paida/Makefile
+++ b/science/py-paida/Makefile
@@ -1,12 +1,9 @@
-# New ports collection makefile for: paida
-# Date created: 2005-07-17
-# Whom: Vsevolod Stakhov <vsevolod@highsecure.ru>
-#
+# Created by: Vsevolod Stakhov <vsevolod@highsecure.ru>
# $FreeBSD$
-#
PORTNAME= paida
PORTVERSION= 3.2.1.2.10
+PORTREVISION= 1
CATEGORIES= science python
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-3.2.1_2.10.1
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,7 +13,7 @@ MAINTAINER= wenheping@gmail.com
COMMENT= Pure Python scientific analysis package
.if !defined(NO_GUI)
-BUILD_DEPENDS+= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
+BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinter
.endif
USE_PYTHON= yes