aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-12-22 11:44:01 +0800
committerlinimon <linimon@FreeBSD.org>2018-12-22 11:44:01 +0800
commit952356e30fc74fb56fba2bc9c27d94e18382138b (patch)
treea9d2e3ad294d881e6d8f9e04246dd862f3203352 /science
parentd2f6423d4e4d1c00b5318d76c5506d0f343e33c0 (diff)
downloadfreebsd-ports-gnome-952356e30fc74fb56fba2bc9c27d94e18382138b.tar.gz
freebsd-ports-gnome-952356e30fc74fb56fba2bc9c27d94e18382138b.tar.zst
freebsd-ports-gnome-952356e30fc74fb56fba2bc9c27d94e18382138b.zip
This port needs USES=compiler:c++11-lang to build on GCC-based
architectures. While here, add USES=gl gnome and pet portlint. PR: 234208 Submitted by: Piotr Kubaj
Diffstat (limited to 'science')
-rw-r--r--science/gchemutils/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/science/gchemutils/Makefile b/science/gchemutils/Makefile
index 0d66bc488c06..6fa66a51b432 100644
--- a/science/gchemutils/Makefile
+++ b/science/gchemutils/Makefile
@@ -24,11 +24,12 @@ RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/bodr.pc:science/bodr \
PORTSCOUT= limitw:1,even
+USES= compiler:c++11-lang desktop-file-utils gettext gl gmake gnome \
+ libtool:keepla localbase:ldflags pathfix pkgconfig \
+ shared-mime-info tar:xz
USE_XORG= x11
USE_GNOME= cairo gnomedocutils gtk30 intlhack libgsf libxml2
USE_GL= gl
-USES= desktop-file-utils gettext gmake libtool:keepla localbase:ldflags \
- pathfix pkgconfig shared-mime-info tar:xz
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-omf-dir=${PREFIX}/share/omf
@@ -47,7 +48,7 @@ OPTIONS_SUB= yes
GNUMERIC_DESC= Build gnumeric plugin
XUL_DESC= Build browser plugin (requires libxul)
-XUL_BROKEN= No gecko type specified (firefox, seamonkey, thunderbird)
+XUL_BROKEN= No gecko type specified (firefox, seamonkey, thunderbird)
XUL_USES= gecko
XUL_CONFIGURE_ON=--enable-mozilla-plugin \
--with-mozilla-libdir=${PREFIX}/lib/xulrunner