aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-11-15 14:40:50 +0800
committeryuri <yuri@FreeBSD.org>2018-11-15 14:40:50 +0800
commit9806c32dbe910d917b3690120d8e7ee15066f87a (patch)
tree7456c4745d313c9d59f54beb5ecad1a144e0eed2 /science
parent30633794731861c42379b3b47a42d574c1c38b8f (diff)
downloadfreebsd-ports-gnome-9806c32dbe910d917b3690120d8e7ee15066f87a.tar.gz
freebsd-ports-gnome-9806c32dbe910d917b3690120d8e7ee15066f87a.tar.zst
freebsd-ports-gnome-9806c32dbe910d917b3690120d8e7ee15066f87a.zip
New port: science/simbody: Multibody dynamics library for (bio)mechanical systems simulation
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/simbody/Makefile48
-rw-r--r--science/simbody/distinfo7
-rw-r--r--science/simbody/pkg-descr6
-rw-r--r--science/simbody/pkg-plist225
5 files changed, 287 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index a16f2c3ebb67..52daf0aeeaf1 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -279,6 +279,7 @@
SUBDIR += sigrok-firmware-fx2lafw
SUBDIR += sigrok-firmware-utils
SUBDIR += silo
+ SUBDIR += simbody
SUBDIR += simint
SUBDIR += simlib
SUBDIR += simsmith
diff --git a/science/simbody/Makefile b/science/simbody/Makefile
new file mode 100644
index 000000000000..f0b131ac9a57
--- /dev/null
+++ b/science/simbody/Makefile
@@ -0,0 +1,48 @@
+# $FreeBSD$
+
+PORTNAME= simbody
+DISTVERSIONPREFIX= Simbody-
+DISTVERSION= 3.6.1
+CATEGORIES= science biology
+
+PATCH_SITES= https://github.com/${PORTNAME}/${PORTNAME}/commit/
+PATCHFILES= 1b306f66bcd15e9bf6b27882e2daa6375ac4cd2e.patch:-p1 \
+ eaff90b304291ab9ffdf60d7abfb48e23e102ecb.patch:-p1
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Multibody dynamics library for (bio)mechanical systems simulation
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+LIB_DEPENDS= libopenblas.so:math/openblas
+
+USES= blaslapack:openblas cmake:outsource compiler:c++11-lang fortran # fortran only for openblas
+USE_GITHUB= yes
+USE_LDCONFIG= yes
+
+CMAKE_OFF= BUILD_TESTING BUILD_EXAMPLES
+CMAKE_ARGS= -DBLAS_LIBRARIES:STRING=${LOCALBASE}/lib/libopenblas.so -DLAPACK_LIBRARIES:STRING=${LOCALBASE}/lib/libopenblas.so
+
+OPTIONS_DEFINE= DOCS VISUALIZER
+OPTIONS_DEFAULT= VISUALIZER
+OPTIONS_SUB= yes
+
+DOCS_CMAKE_BOOL= INSTALL_DOCS
+
+VISUALIZER_CMAKE_BOOL= BUILD_VISUALIZER
+VISUALIZER_USES= gl
+VISUALIZER_USE= GL=gl,glu,glut XORG=xi,xmu
+
+PORTDOCS= *
+
+post-install-DOCS-on: # https://github.com/simbody/simbody/issues/652
+ @${RMDIR} ${STAGEDIR}${DOCSDIR}/api
+
+do-test: # one test is known to fail: https://github.com/simbody/simbody/issues/653
+ @cd ${BUILD_WRKSRC} && \
+ ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -DBUILD_TESTING=ON ${CMAKE_SOURCE_PATH} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} test
+
+.include <bsd.port.mk>
diff --git a/science/simbody/distinfo b/science/simbody/distinfo
new file mode 100644
index 000000000000..54173024bcc0
--- /dev/null
+++ b/science/simbody/distinfo
@@ -0,0 +1,7 @@
+TIMESTAMP = 1542263337
+SHA256 (simbody-simbody-Simbody-3.6.1_GH0.tar.gz) = 7716d6ea20b950e71e8535faa4353ac89716c03fd7a445dd802eb6a630796639
+SIZE (simbody-simbody-Simbody-3.6.1_GH0.tar.gz) = 47178543
+SHA256 (1b306f66bcd15e9bf6b27882e2daa6375ac4cd2e.patch) = 42468083313fc489c763ad2562c7a4baeeca02b7c81f35a94dad3368e4c7c4b8
+SIZE (1b306f66bcd15e9bf6b27882e2daa6375ac4cd2e.patch) = 1473
+SHA256 (eaff90b304291ab9ffdf60d7abfb48e23e102ecb.patch) = 8098b7efa4509a70d1561cad84d3d84549a58a4ac83f3af7d0a94e3cdd7ec4c4
+SIZE (eaff90b304291ab9ffdf60d7abfb48e23e102ecb.patch) = 1350
diff --git a/science/simbody/pkg-descr b/science/simbody/pkg-descr
new file mode 100644
index 000000000000..42180d7f6300
--- /dev/null
+++ b/science/simbody/pkg-descr
@@ -0,0 +1,6 @@
+Simbody is useful for internal coordinate and coarse grained molecule modeling,
+large scale mechanical models like skeletons, and anything else that can be
+modeled as bodies interconnected by joints, acted upon by forces, and restricted
+by constraints.
+
+WWW: https://simtk.org/projects/simbody
diff --git a/science/simbody/pkg-plist b/science/simbody/pkg-plist
new file mode 100644
index 000000000000..9fb3f212533d
--- /dev/null
+++ b/science/simbody/pkg-plist
@@ -0,0 +1,225 @@
+include/simbody/SimTKcommon.h
+include/simbody/SimTKcommon/Constants.h
+include/simbody/SimTKcommon/Mechanics.h
+include/simbody/SimTKcommon/Orientation.h
+include/simbody/SimTKcommon/Scalar.h
+include/simbody/SimTKcommon/Simmatrix.h
+include/simbody/SimTKcommon/SmallMatrix.h
+include/simbody/SimTKcommon/TemplatizedLapack.h
+include/simbody/SimTKcommon/Testing.h
+include/simbody/SimTKcommon/basics.h
+include/simbody/SimTKcommon/internal/Array.h
+include/simbody/SimTKcommon/internal/BigMatrix.h
+include/simbody/SimTKcommon/internal/CloneOnWritePtr.h
+include/simbody/SimTKcommon/internal/ClonePtr.h
+include/simbody/SimTKcommon/internal/CompositeNumericalTypes.h
+include/simbody/SimTKcommon/internal/CoordinateAxis.h
+include/simbody/SimTKcommon/internal/DecorationGenerator.h
+include/simbody/SimTKcommon/internal/DecorativeGeometry.h
+include/simbody/SimTKcommon/internal/Event.h
+include/simbody/SimTKcommon/internal/EventHandler.h
+include/simbody/SimTKcommon/internal/EventReporter.h
+include/simbody/SimTKcommon/internal/Exception.h
+include/simbody/SimTKcommon/internal/ExceptionMacros.h
+include/simbody/SimTKcommon/internal/Fortran.h
+include/simbody/SimTKcommon/internal/Function.h
+include/simbody/SimTKcommon/internal/IteratorRange.h
+include/simbody/SimTKcommon/internal/MassProperties.h
+include/simbody/SimTKcommon/internal/Mat.h
+include/simbody/SimTKcommon/internal/MatrixBase.h
+include/simbody/SimTKcommon/internal/MatrixCharacteristics.h
+include/simbody/SimTKcommon/internal/MatrixHelper.h
+include/simbody/SimTKcommon/internal/MatrixView_.h
+include/simbody/SimTKcommon/internal/Matrix_.h
+include/simbody/SimTKcommon/internal/Measure.h
+include/simbody/SimTKcommon/internal/MeasureImplementation.h
+include/simbody/SimTKcommon/internal/NTraits.h
+include/simbody/SimTKcommon/internal/Parallel2DExecutor.h
+include/simbody/SimTKcommon/internal/ParallelExecutor.h
+include/simbody/SimTKcommon/internal/ParallelWorkQueue.h
+include/simbody/SimTKcommon/internal/Pathname.h
+include/simbody/SimTKcommon/internal/Plugin.h
+include/simbody/SimTKcommon/internal/PolygonalMesh.h
+include/simbody/SimTKcommon/internal/PolynomialRootFinder.h
+include/simbody/SimTKcommon/internal/PrivateImplementation.h
+include/simbody/SimTKcommon/internal/PrivateImplementation_Defs.h
+include/simbody/SimTKcommon/internal/Quaternion.h
+include/simbody/SimTKcommon/internal/Random.h
+include/simbody/SimTKcommon/internal/ReferencePtr.h
+include/simbody/SimTKcommon/internal/ReinitOnCopy.h
+include/simbody/SimTKcommon/internal/ResetOnCopy.h
+include/simbody/SimTKcommon/internal/ResultType.h
+include/simbody/SimTKcommon/internal/Rotation.h
+include/simbody/SimTKcommon/internal/Row.h
+include/simbody/SimTKcommon/internal/RowVectorBase.h
+include/simbody/SimTKcommon/internal/RowVectorView_.h
+include/simbody/SimTKcommon/internal/RowVector_.h
+include/simbody/SimTKcommon/internal/Serialize.h
+include/simbody/SimTKcommon/internal/SmallDefsThatNeedBig.h
+include/simbody/SimTKcommon/internal/SmallMatrixMixed.h
+include/simbody/SimTKcommon/internal/SpatialAlgebra.h
+include/simbody/SimTKcommon/internal/StableArray.h
+include/simbody/SimTKcommon/internal/Stage.h
+include/simbody/SimTKcommon/internal/State.h
+include/simbody/SimTKcommon/internal/StateImpl.h
+include/simbody/SimTKcommon/internal/String.h
+include/simbody/SimTKcommon/internal/Study.h
+include/simbody/SimTKcommon/internal/StudyGuts.h
+include/simbody/SimTKcommon/internal/Subsystem.h
+include/simbody/SimTKcommon/internal/SubsystemGuts.h
+include/simbody/SimTKcommon/internal/SymMat.h
+include/simbody/SimTKcommon/internal/System.h
+include/simbody/SimTKcommon/internal/SystemGuts.h
+include/simbody/SimTKcommon/internal/Timing.h
+include/simbody/SimTKcommon/internal/Transform.h
+include/simbody/SimTKcommon/internal/UnitVec.h
+include/simbody/SimTKcommon/internal/Value.h
+include/simbody/SimTKcommon/internal/Vec.h
+include/simbody/SimTKcommon/internal/VectorBase.h
+include/simbody/SimTKcommon/internal/VectorIterator.h
+include/simbody/SimTKcommon/internal/VectorMath.h
+include/simbody/SimTKcommon/internal/VectorView_.h
+include/simbody/SimTKcommon/internal/Vector_.h
+include/simbody/SimTKcommon/internal/Xml.h
+include/simbody/SimTKcommon/internal/common.h
+include/simbody/SimTKcommon/internal/conjugate.h
+include/simbody/SimTKcommon/internal/negator.h
+include/simbody/SimTKlapack.h
+include/simbody/SimTKmath.h
+include/simbody/SimTKsimbody.h
+include/simbody/SimTKsimbody_aux.h
+include/simbody/Simbody.h
+include/simbody/simbody/internal/Assembler.h
+include/simbody/simbody/internal/AssemblyCondition.h
+include/simbody/simbody/internal/AssemblyCondition_Markers.h
+include/simbody/simbody/internal/AssemblyCondition_OrientationSensors.h
+include/simbody/simbody/internal/AssemblyCondition_QValue.h
+include/simbody/simbody/internal/Body.h
+include/simbody/simbody/internal/CablePath.h
+include/simbody/simbody/internal/CableSpring.h
+include/simbody/simbody/internal/CableTrackerSubsystem.h
+include/simbody/simbody/internal/CompliantContactSubsystem.h
+include/simbody/simbody/internal/ConditionalConstraint.h
+include/simbody/simbody/internal/Constraint.h
+include/simbody/simbody/internal/Constraint_Ball.h
+include/simbody/simbody/internal/Constraint_BuiltIns.h
+include/simbody/simbody/internal/Constraint_LineOnLineContact.h
+include/simbody/simbody/internal/Constraint_PointInPlane.h
+include/simbody/simbody/internal/Constraint_PointOnPlaneContact.h
+include/simbody/simbody/internal/Constraint_Rod.h
+include/simbody/simbody/internal/Constraint_SphereOnPlaneContact.h
+include/simbody/simbody/internal/Constraint_SphereOnSphereContact.h
+include/simbody/simbody/internal/Constraint_Weld.h
+include/simbody/simbody/internal/ContactSurface.h
+include/simbody/simbody/internal/ContactTrackerSubsystem.h
+include/simbody/simbody/internal/DecorationSubsystem.h
+include/simbody/simbody/internal/ElasticFoundationForce.h
+include/simbody/simbody/internal/Force.h
+include/simbody/simbody/internal/ForceSubsystem.h
+include/simbody/simbody/internal/ForceSubsystemGuts.h
+include/simbody/simbody/internal/Force_BuiltIns.h
+include/simbody/simbody/internal/Force_Custom.h
+include/simbody/simbody/internal/Force_DiscreteForces.h
+include/simbody/simbody/internal/Force_Gravity.h
+include/simbody/simbody/internal/Force_LinearBushing.h
+include/simbody/simbody/internal/Force_MobilityConstantForce.h
+include/simbody/simbody/internal/Force_MobilityDiscreteForce.h
+include/simbody/simbody/internal/Force_MobilityLinearDamper.h
+include/simbody/simbody/internal/Force_MobilityLinearSpring.h
+include/simbody/simbody/internal/Force_MobilityLinearStop.h
+include/simbody/simbody/internal/Force_Thermostat.h
+include/simbody/simbody/internal/GeneralContactSubsystem.h
+include/simbody/simbody/internal/GeneralForceSubsystem.h
+include/simbody/simbody/internal/HuntCrossleyContact.h
+include/simbody/simbody/internal/HuntCrossleyForce.h
+include/simbody/simbody/internal/ImpulseSolver.h
+include/simbody/simbody/internal/LocalEnergyMinimizer.h
+include/simbody/simbody/internal/MobilizedBody.h
+include/simbody/simbody/internal/MobilizedBody_Ball.h
+include/simbody/simbody/internal/MobilizedBody_BendStretch.h
+include/simbody/simbody/internal/MobilizedBody_BuiltIns.h
+include/simbody/simbody/internal/MobilizedBody_Bushing.h
+include/simbody/simbody/internal/MobilizedBody_Custom.h
+include/simbody/simbody/internal/MobilizedBody_Cylinder.h
+include/simbody/simbody/internal/MobilizedBody_Ellipsoid.h
+include/simbody/simbody/internal/MobilizedBody_Free.h
+include/simbody/simbody/internal/MobilizedBody_FreeLine.h
+include/simbody/simbody/internal/MobilizedBody_FunctionBased.h
+include/simbody/simbody/internal/MobilizedBody_Gimbal.h
+include/simbody/simbody/internal/MobilizedBody_Ground.h
+include/simbody/simbody/internal/MobilizedBody_LineOrientation.h
+include/simbody/simbody/internal/MobilizedBody_Pin.h
+include/simbody/simbody/internal/MobilizedBody_Planar.h
+include/simbody/simbody/internal/MobilizedBody_Screw.h
+include/simbody/simbody/internal/MobilizedBody_Slider.h
+include/simbody/simbody/internal/MobilizedBody_SphericalCoords.h
+include/simbody/simbody/internal/MobilizedBody_Translation.h
+include/simbody/simbody/internal/MobilizedBody_Universal.h
+include/simbody/simbody/internal/MobilizedBody_Weld.h
+include/simbody/simbody/internal/Motion.h
+include/simbody/simbody/internal/MultibodySystem.h
+include/simbody/simbody/internal/ObservedPointFitter.h
+include/simbody/simbody/internal/PGSImpulseSolver.h
+include/simbody/simbody/internal/PLUSImpulseSolver.h
+include/simbody/simbody/internal/SemiExplicitEulerTimeStepper.h
+include/simbody/simbody/internal/SimbodyMatterSubsystem.h
+include/simbody/simbody/internal/SimbodyMatterSubtree.h
+include/simbody/simbody/internal/TextDataEventReporter.h
+include/simbody/simbody/internal/Visualizer.h
+include/simbody/simbody/internal/Visualizer_InputListener.h
+include/simbody/simbody/internal/Visualizer_Reporter.h
+include/simbody/simbody/internal/common.h
+include/simbody/simmath/CPodesIntegrator.h
+include/simbody/simmath/Differentiator.h
+include/simbody/simmath/ExplicitEulerIntegrator.h
+include/simbody/simmath/Integrator.h
+include/simbody/simmath/LinearAlgebra.h
+include/simbody/simmath/MultibodyGraphMaker.h
+include/simbody/simmath/Optimizer.h
+include/simbody/simmath/RungeKutta2Integrator.h
+include/simbody/simmath/RungeKutta3Integrator.h
+include/simbody/simmath/RungeKuttaFeldbergIntegrator.h
+include/simbody/simmath/RungeKuttaMersonIntegrator.h
+include/simbody/simmath/SemiExplicitEuler2Integrator.h
+include/simbody/simmath/SemiExplicitEulerIntegrator.h
+include/simbody/simmath/TimeStepper.h
+include/simbody/simmath/VerletIntegrator.h
+include/simbody/simmath/internal/BicubicSurface.h
+include/simbody/simmath/internal/CollisionDetectionAlgorithm.h
+include/simbody/simmath/internal/Contact.h
+include/simbody/simmath/internal/ContactGeometry.h
+include/simbody/simmath/internal/ContactTracker.h
+include/simbody/simmath/internal/GCVSPLUtil.h
+include/simbody/simmath/internal/Geo.h
+include/simbody/simmath/internal/Geo_BicubicBezierPatch.h
+include/simbody/simmath/internal/Geo_BicubicHermitePatch.h
+include/simbody/simmath/internal/Geo_Box.h
+include/simbody/simmath/internal/Geo_CubicBezierCurve.h
+include/simbody/simmath/internal/Geo_CubicHermiteCurve.h
+include/simbody/simmath/internal/Geo_LineSeg.h
+include/simbody/simmath/internal/Geo_Point.h
+include/simbody/simmath/internal/Geo_Sphere.h
+include/simbody/simmath/internal/Geo_Triangle.h
+include/simbody/simmath/internal/Geodesic.h
+include/simbody/simmath/internal/GeodesicIntegrator.h
+include/simbody/simmath/internal/OBBTree.h
+include/simbody/simmath/internal/OptimizerRep.h
+include/simbody/simmath/internal/OrientedBoundingBox.h
+include/simbody/simmath/internal/ParticleConSurfaceSystem.h
+include/simbody/simmath/internal/SimTKcpodes.h
+include/simbody/simmath/internal/Spline.h
+include/simbody/simmath/internal/SplineFitter.h
+include/simbody/simmath/internal/common.h
+lib/cmake/simbody/SampleCMakeLists.txt
+lib/cmake/simbody/SimbodyConfig.cmake
+lib/cmake/simbody/SimbodyConfigVersion.cmake
+lib/cmake/simbody/SimbodyTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/simbody/SimbodyTargets.cmake
+lib/libSimTKcommon.so
+lib/libSimTKcommon.so.3.6
+lib/libSimTKmath.so
+lib/libSimTKmath.so.3.6
+lib/libSimTKsimbody.so
+lib/libSimTKsimbody.so.3.6
+libdata/pkgconfig/simbody.pc
+%%VISUALIZER%%libexec/simbody/simbody-visualizer