aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorbf <bf@FreeBSD.org>2011-10-17 18:08:33 +0800
committerbf <bf@FreeBSD.org>2011-10-17 18:08:33 +0800
commitc5df546f91d4ce945b2de2e01f71d31243158164 (patch)
tree28381e3e9e9a82d3a2b45f40fb8df8fd26cc5894 /science
parent86b4e4efcff2f1578c68c8821ff20594cc982a82 (diff)
downloadfreebsd-ports-gnome-c5df546f91d4ce945b2de2e01f71d31243158164.tar.gz
freebsd-ports-gnome-c5df546f91d4ce945b2de2e01f71d31243158164.tar.zst
freebsd-ports-gnome-c5df546f91d4ce945b2de2e01f71d31243158164.zip
- update fftw3* to 3.3 [1], and adjust dependent ports
- make use of optimizations by default, where possible (quad flavor to follow shortly, and mpi at a later date) Suggestions and patches from: ache, C. Burns, wen
Diffstat (limited to 'science')
-rw-r--r--science/gnudatalanguage/Makefile6
-rw-r--r--science/gromacs/Makefile5
-rw-r--r--science/gwyddion/Makefile4
-rw-r--r--science/py-scipy/Makefile4
4 files changed, 10 insertions, 9 deletions
diff --git a/science/gnudatalanguage/Makefile b/science/gnudatalanguage/Makefile
index fedf4cad9c58..6a6e857dae7c 100644
--- a/science/gnudatalanguage/Makefile
+++ b/science/gnudatalanguage/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnudatalanguage
DISTVERSION= 0.9.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= science lang
MASTER_SITES= SF/${PORTNAME}/gdl/${DISTVERSION}
.if defined(BUILD_PYTHON_MODULE)
@@ -105,8 +105,8 @@ BROKEN= Does not build with ancient binutils
WITH_FFTW3= yes
.endif
.if defined(WITH_FFTW3)
-LIB_DEPENDS+= fftw3.5:${PORTSDIR}/math/fftw3 \
- fftw3f.5:${PORTSDIR}/math/fftw3-float
+LIB_DEPENDS+= fftw3:${PORTSDIR}/math/fftw3 \
+ fftw3f:${PORTSDIR}/math/fftw3-float
CONFIGURE_ARGS+=--with-fftw=${LOCALBASE}
.endif
diff --git a/science/gromacs/Makefile b/science/gromacs/Makefile
index 082a3db57a72..b8c8c6fcb601 100644
--- a/science/gromacs/Makefile
+++ b/science/gromacs/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gromacs
PORTVERSION= 4.5.5
+PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= ftp://ftp.gromacs.org/pub/gromacs/
@@ -48,9 +49,9 @@ IGNORE= cannot build with MPICH and OpenMPI support. Run 'make config' again an
.if !defined(WITHOUT_FFTW3)
CONFIGURE_ARGS+= --with-fft=fftw3
. if defined(WITH_FLOAT)
-LIB_DEPENDS+= fftw3f.5:${PORTSDIR}/math/fftw3-float
+LIB_DEPENDS+= fftw3f:${PORTSDIR}/math/fftw3-float
. else
-LIB_DEPENDS+= fftw3.5:${PORTSDIR}/math/fftw3
+LIB_DEPENDS+= fftw3:${PORTSDIR}/math/fftw3
. endif
.else
. if defined(WITH_FFTW2)
diff --git a/science/gwyddion/Makefile b/science/gwyddion/Makefile
index 1e06debdb169..78129ea21c7b 100644
--- a/science/gwyddion/Makefile
+++ b/science/gwyddion/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gwyddion
PORTVERSION= 2.16
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= science graphics
MASTER_SITES= SF
@@ -18,7 +18,7 @@ MAINTAINER= yeti@gwyddion.net
COMMENT= A gtk2 based SPM data visualization and analysis tool
LIB_DEPENDS= gtkglext-x11-1.0.0:${PORTSDIR}/x11-toolkits/gtkglext \
- fftw3.5:${PORTSDIR}/math/fftw3
+ fftw3:${PORTSDIR}/math/fftw3
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/science/py-scipy/Makefile b/science/py-scipy/Makefile
index 32894da17ba1..06ed638f07cb 100644
--- a/science/py-scipy/Makefile
+++ b/science/py-scipy/Makefile
@@ -7,7 +7,7 @@
PORTNAME= scipy
PORTVERSION= 0.8.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science python
MASTER_SITES= SF
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -17,7 +17,7 @@ COMMENT= Scientific tools for Python
BUILD_DEPENDS+= ${PYNUMPY} \
${LOCALBASE}/lib/libdjbfft.a:${PORTSDIR}/math/djbfft
-LIB_DEPENDS= fftw3.5:${PORTSDIR}/math/fftw3
+LIB_DEPENDS= fftw3:${PORTSDIR}/math/fftw3
LATEST_LINK= py-${PORTNAME}
OPTIONSFILE= ${PORT_DBDIR}/py-numpy/options