aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2003-08-31 11:12:26 +0800
committerdinoex <dinoex@FreeBSD.org>2003-08-31 11:12:26 +0800
commit01c0fffcf90fc1de4adf3aa96246ee80f45bb6d6 (patch)
tree2acf0a033e684dfedc9cebf546500e3ec48e8120 /science
parent612e583d9ba521eaf6f4fd67c7c5c982fffe75c3 (diff)
downloadfreebsd-ports-gnome-01c0fffcf90fc1de4adf3aa96246ee80f45bb6d6.tar.gz
freebsd-ports-gnome-01c0fffcf90fc1de4adf3aa96246ee80f45bb6d6.tar.zst
freebsd-ports-gnome-01c0fffcf90fc1de4adf3aa96246ee80f45bb6d6.zip
- don't clobber any given LDFLAGS
resolve conflitcs with bsd.openssl.mk
Diffstat (limited to 'science')
-rw-r--r--science/hdf5-18/Makefile2
-rw-r--r--science/hdf5/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/science/hdf5-18/Makefile b/science/hdf5-18/Makefile
index 3f4c5df6ef3e..8522d22cd6d7 100644
--- a/science/hdf5-18/Makefile
+++ b/science/hdf5-18/Makefile
@@ -20,7 +20,7 @@ USE_OPENSSL= yes
USE_LIBTOOL= yes
LIBTOOLFILES= configure c++/configure
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" LDFLAGS="${PTHREAD_LIBS}"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} ${PTHREAD_CFLAGS}"
CONFIGURE_ARGS= --enable-cxx --enable-production \
--enable-threadsafe --disable-debug \
--with-ssl --with-pthread
diff --git a/science/hdf5/Makefile b/science/hdf5/Makefile
index 3f4c5df6ef3e..8522d22cd6d7 100644
--- a/science/hdf5/Makefile
+++ b/science/hdf5/Makefile
@@ -20,7 +20,7 @@ USE_OPENSSL= yes
USE_LIBTOOL= yes
LIBTOOLFILES= configure c++/configure
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" LDFLAGS="${PTHREAD_LIBS}"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} ${PTHREAD_CFLAGS}"
CONFIGURE_ARGS= --enable-cxx --enable-production \
--enable-threadsafe --disable-debug \
--with-ssl --with-pthread