aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-01-04 03:58:19 +0800
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-01-04 03:58:19 +0800
commit07febaa62bbae11fbe6fd9ceb24ee448c4e78f91 (patch)
tree8efdcb8fb804488b19b141ba854e4eb497b9f301 /science
parentf013c58ddaf69754b4eec58298a4fa6caa704f15 (diff)
downloadfreebsd-ports-gnome-07febaa62bbae11fbe6fd9ceb24ee448c4e78f91.tar.gz
freebsd-ports-gnome-07febaa62bbae11fbe6fd9ceb24ee448c4e78f91.tar.zst
freebsd-ports-gnome-07febaa62bbae11fbe6fd9ceb24ee448c4e78f91.zip
Add py-spaghetti 1.4.2
SPAtial GrapHs: nETworks, Topology, & Inference Spaghetti is an open-source Python library for the analysis of network-based spatial data. Originating from the network module in PySAL (Python Spatial Analysis Library), it is under active development for the inclusion of newly proposed methods for building graph-theoretic networks and the analysis of network events. WWW: https://pysal.org/spaghetti/ WWW: https://github.com/pysal/spaghetti
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/py-spaghetti/Makefile29
-rw-r--r--science/py-spaghetti/distinfo3
-rw-r--r--science/py-spaghetti/pkg-descr10
4 files changed, 43 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 72696549f813..dea6cee3c484 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -291,6 +291,7 @@
SUBDIR += py-scoria
SUBDIR += py-segregation
SUBDIR += py-segyio
+ SUBDIR += py-spaghetti
SUBDIR += py-spglib
SUBDIR += py-tensorflow
SUBDIR += py-veusz
diff --git a/science/py-spaghetti/Makefile b/science/py-spaghetti/Makefile
new file mode 100644
index 000000000000..7ec1d2d03974
--- /dev/null
+++ b/science/py-spaghetti/Makefile
@@ -0,0 +1,29 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= spaghetti
+PORTVERSION= 1.4.2
+CATEGORIES= science python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Analysis of Network-constrained Spatial Data
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-runner>=0:devel/py-pytest-runner@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}esda>=0:science/py-esda@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}numpy>=1.3,1:math/py-numpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pandas>=0,1:math/py-pandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}rtree>=0:devel/py-rtree@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=0.11:science/py-scipy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}watermark>=0:devel/py-watermark@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/science/py-spaghetti/distinfo b/science/py-spaghetti/distinfo
new file mode 100644
index 000000000000..0593ee98cb78
--- /dev/null
+++ b/science/py-spaghetti/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1609598765
+SHA256 (spaghetti-1.4.2.tar.gz) = 6bf91f0aff504bce46aca33e72c955cbf7b5176ffadd99745c040b711ebfbcd2
+SIZE (spaghetti-1.4.2.tar.gz) = 43356
diff --git a/science/py-spaghetti/pkg-descr b/science/py-spaghetti/pkg-descr
new file mode 100644
index 000000000000..6c5fe41869a8
--- /dev/null
+++ b/science/py-spaghetti/pkg-descr
@@ -0,0 +1,10 @@
+SPAtial GrapHs: nETworks, Topology, & Inference
+
+Spaghetti is an open-source Python library for the analysis of network-based
+spatial data. Originating from the network module in PySAL (Python Spatial
+Analysis Library), it is under active development for the inclusion of newly
+proposed methods for building graph-theoretic networks and the analysis of
+network events.
+
+WWW: https://pysal.org/spaghetti/
+WWW: https://github.com/pysal/spaghetti