aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2017-11-17 02:27:47 +0800
committeryuri <yuri@FreeBSD.org>2017-11-17 02:27:47 +0800
commit0b9026a5bc69f7975bc902389b2e949d05b03b13 (patch)
tree2922b6c3eaa1f916c8a2f68cafa840d0136e658b /science
parentc60498e6118c97be750a448e43cf4e41f1c2e616 (diff)
downloadfreebsd-ports-gnome-0b9026a5bc69f7975bc902389b2e949d05b03b13.tar.gz
freebsd-ports-gnome-0b9026a5bc69f7975bc902389b2e949d05b03b13.tar.zst
freebsd-ports-gnome-0b9026a5bc69f7975bc902389b2e949d05b03b13.zip
New port: science/py-scoria: Lightweight molecule manipulation codebase
Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D13119
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/py-scoria/Makefile21
-rw-r--r--science/py-scoria/distinfo3
-rw-r--r--science/py-scoria/pkg-descr4
4 files changed, 29 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index c0241955e315..dc49b761e53a 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -171,6 +171,7 @@
SUBDIR += py-scikit-sparse
SUBDIR += py-scimath
SUBDIR += py-scipy
+ SUBDIR += py-scoria
SUBDIR += py-tensorflow
SUBDIR += py-ws2300
SUBDIR += pybrain
diff --git a/science/py-scoria/Makefile b/science/py-scoria/Makefile
new file mode 100644
index 000000000000..e1cb4de53f73
--- /dev/null
+++ b/science/py-scoria/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= scoria
+DISTVERSION= 1.0.3
+CATEGORIES= science python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Lightweight molecule manipulation codebase
+
+LICENSE= APACHE20
+
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy
+
+USES= python
+USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/science/py-scoria/distinfo b/science/py-scoria/distinfo
new file mode 100644
index 000000000000..d340295d2ee0
--- /dev/null
+++ b/science/py-scoria/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1510818178
+SHA256 (scoria-1.0.3.tar.gz) = 27ec909d8a9289175bc968d5cff81a84e5ade759625005160b5ad750abbdda3a
+SIZE (scoria-1.0.3.tar.gz) = 9149900
diff --git a/science/py-scoria/pkg-descr b/science/py-scoria/pkg-descr
new file mode 100644
index 000000000000..8c9608d47c5e
--- /dev/null
+++ b/science/py-scoria/pkg-descr
@@ -0,0 +1,4 @@
+The scoria library is a lightweight python code base designed for
+importing, manipulating, and exporting molecular models.
+
+WWW: https://git.durrantlab.com/jdurrant/scoria