aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2016-09-30 04:01:40 +0800
committerpawel <pawel@FreeBSD.org>2016-09-30 04:01:40 +0800
commit1bb202389254d73df07a0950888e460090589a03 (patch)
treed0664c03d6eb5bb99ea64f65278be790c8e3a85c /science
parent43c5035afdba16e7d41237a22fe62984db357c91 (diff)
downloadfreebsd-ports-gnome-1bb202389254d73df07a0950888e460090589a03.tar.gz
freebsd-ports-gnome-1bb202389254d73df07a0950888e460090589a03.tar.zst
freebsd-ports-gnome-1bb202389254d73df07a0950888e460090589a03.zip
- Update to version 1.7.1 [1]
- Enable multithreaded support with devel/libatomic_ops [1] - Remove not supported TCL option [1] - Add LICENSE_FILE - Convert to options helpers https://www.mbdyn.org/userfiles/downloads/CHANGELOG-1.5.txt https://www.mbdyn.org/userfiles/downloads/CHANGELOG-1.6.txt https://www.mbdyn.org/userfiles/downloads/CHANGELOG-1.7.txt PR: 212464 [1] Submitted by: pfg [1]
Diffstat (limited to 'science')
-rw-r--r--science/mbdyn/Makefile93
-rw-r--r--science/mbdyn/distinfo5
-rw-r--r--science/mbdyn/files/patch-include__ac__mpi.h4
-rw-r--r--science/mbdyn/files/patch-mbdyn__base__invsolver.cc10
-rw-r--r--science/mbdyn/files/patch-mbdyn__base__solver.cc14
-rw-r--r--science/mbdyn/files/patch-mbdyn__mbdyn.h8
-rw-r--r--science/mbdyn/pkg-plist7
7 files changed, 64 insertions, 77 deletions
diff --git a/science/mbdyn/Makefile b/science/mbdyn/Makefile
index a58f475fe280..9fd96a37fa28 100644
--- a/science/mbdyn/Makefile
+++ b/science/mbdyn/Makefile
@@ -2,33 +2,30 @@
# $FreeBSD$
PORTNAME= mbdyn
-PORTVERSION= 1.4.3
-PORTREVISION= 1
+PORTVERSION= 1.7.1
CATEGORIES= science
-MASTER_SITES= http://www.aero.polimi.it/~masarati/Download/mbdyn/
+MASTER_SITES= https://www.mbdyn.org/userfiles/downloads/
MAINTAINER= ports@FreeBSD.org
COMMENT= MultiBody Dynamics analysis system
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libarpack.so:math/arpack \
+LIB_DEPENDS= libltdl.so:devel/libltdl \
+ libarpack.so:math/arpack \
libumfpack.so:math/suitesparse
+BROKEN_powerpc= Does not compile on powerpc
+
GNU_CONFIGURE= yes
-USES= fortran gmake libtool
+USES= compiler:c++11-lib fortran gmake libtool localbase
USE_LDCONFIG= yes
CPPFLAGS+= -fpermissive -I${LOCALBASE}/include/suitesparse
-LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS+= --program-prefix=''
INSTALL_TARGET= install-strip
-OPTIONS_DEFINE= MPI METIS CHACO GINAC TCL
-MPI_DESC= Enable mpich-support
-METIS_DESC= Enable metis-support
-CHACO_DESC= Enable chaco-support
-GINAC_DESC= Enable GiNaC-support (not implemented yet)
-TCL_DESC= Enable tcl-support (not implemented yet)
+OPTIONS_DEFINE= MPI METIS CHACO GINAC
OPTIONS_RADIO= BLAS
OPTIONS_RADIO_BLAS= REFERENCE GOTOBLAS ATLAS
OPTIONS_DEFAULT= REFERENCE
@@ -45,54 +42,36 @@ GOTOBLAS_DESC= GotoBLAS2
GOTOBLAS_USES= blaslapack:gotoblas
GOTOBLAS_CONFIGURE_ON= --with-blas=goto --with-goto=goto2
-.include <bsd.port.pre.mk>
+MPI_DESC= Enable mpich-support (Requires Metis or Chaco, broken)
+MPI_IGNORE= you enabled MPI support, which is broken
+MPI_BUILD_DEPENDS_OFF= libatomic_ops>0:devel/libatomic_ops
+MPI_LIB_DEPENDS= libmpich.so:net/mpich2
+MPI_CONFIGURE_ON= --with-mpi=yes --enable-schur
+MPI_CONFIGURE_OFF= --with-mpi=no --enable-multithread
+
+METIS_DESC= Enable metis-support
+METIS_LIB_DEPENDS= libmetis.so:math/metis4
+METIS_CONFIGURE_ON= --with-metis=yes
+METIS_CPPFLAGS= -I${LOCALBASE}/include/metis
+METIS_CONFIGURE_OFF= --with-metis=no
+
+CHACO_DESC= Enable chaco-support
+CHACO_BUILD_DEPENDS= ${LOCALBASE}/lib/libchaco.a:math/chaco
+CHACO_CONFIGURE_ON= --with-chaco=yes
+CHACO_CONFIGURE_OFF= --with-chaco=no
+
+GINAC_DESC= Enable GiNaC-support (not implemented yet)
+GINAC_IGNORE= you enabled GiNaC-support, which is broken
+GINAC_LIB_DEPENDS= libmetis.so:math/metis4 \
+ libginac.so:math/GiNaC
+GINAC_CONFIGURE_ON= --with-ginac=yes
+GINAC_CONFIGURE_OFF= --with-ginac=no
+GINAC_CPPFLAGS= -I${LOCALBASE}/include/metis
-.if ${ARCH} == "powerpc"
-BROKEN= Does not compile on powerpc
-.endif
+.include <bsd.port.pre.mk>
-.if ${PORT_OPTIONS:MMPI}
-LIB_DEPENDS+= libmpich.so:net/mpich2
-CONFIGURE_ARGS+= --with-mpi=yes --enable-schur
-CPPFLAGS+= -I${LOCALBASE}/include
-. if ! ${PORT_OPTIONS:MMETIS}
+.if ${PORT_OPTIONS:MMPI} && ! ${PORT_OPTIONS:MMETIS}
WITH_CHACO= yes
-. endif
-.else
-CONFIGURE_ARGS+= --with-mpi=no
-.endif
-
-.if ${PORT_OPTIONS:MMETIS}
-LIB_DEPENDS+= libmetis.so:math/metis4
-CONFIGURE_ARGS+= --with-metis=yes
-CPPFLAGS+= -I${LOCALBASE}/include/metis
-.else
-CONFIGURE_ARGS+= --with-metis=no
-.endif
-
-.if ${PORT_OPTIONS:MCHACO}
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libchaco.a:math/chaco
-CONFIGURE_ARGS+= --with-chaco=yes
-.else
-CONFIGURE_ARGS+= --with-chaco=no
-.endif
-
-.if ${PORT_OPTIONS:MGINAC}
-LIB_DEPENDS+= libmetis.so:math/metis4 \
- libginac.so:math/GiNaC
-CONFIGURE_ARGS+= --with-ginac=yes
-CPPFLAGS+= -I${LOCALBASE}/include/metis
-.else
-CONFIGURE_ARGS+= --with-ginac=no
-.endif
-
-.if ${PORT_OPTIONS:MTCL}
-IGNORE= you enabled Tcl-support, which is not implemented yet
-LIB_DEPENDS+= libtcl84.so:lang/tcl84
-CONFIGURE_ARGS+= --with-tcl=yes
-CPPFLAGS+= -I${LOCALBASE}/include/tcl8.4
-.else
-CONFIGURE_ARGS+= --with-tcl=no
.endif
pre-configure:
diff --git a/science/mbdyn/distinfo b/science/mbdyn/distinfo
index 45022b70c93c..0906a63e1405 100644
--- a/science/mbdyn/distinfo
+++ b/science/mbdyn/distinfo
@@ -1,2 +1,3 @@
-SHA256 (mbdyn-1.4.3.tar.gz) = 24c37a2802b2842ec6cbfc7ffeb20af4ca49e12102d75a6966e93fd99d26d117
-SIZE (mbdyn-1.4.3.tar.gz) = 2320156
+TIMESTAMP = 1473272629
+SHA256 (mbdyn-1.7.1.tar.gz) = 2c1f21a6459c58103778cb5d771fc49f972baaa57866329ecd1e90dcf04b4ccf
+SIZE (mbdyn-1.7.1.tar.gz) = 2834562
diff --git a/science/mbdyn/files/patch-include__ac__mpi.h b/science/mbdyn/files/patch-include__ac__mpi.h
index 51168fcf5544..c8a3f0ea276c 100644
--- a/science/mbdyn/files/patch-include__ac__mpi.h
+++ b/science/mbdyn/files/patch-include__ac__mpi.h
@@ -1,5 +1,5 @@
---- ./include/ac/mpi.h.orig 2009-01-04 19:04:54.000000000 +0100
-+++ ./include/ac/mpi.h 2010-10-31 22:31:57.000000000 +0100
+--- include/ac/mpi.h.orig 2015-10-30 05:05:33 UTC
++++ include/ac/mpi.h
@@ -35,7 +35,7 @@
#ifdef HAVE_MPI___H
#include <mpi++.h>
diff --git a/science/mbdyn/files/patch-mbdyn__base__invsolver.cc b/science/mbdyn/files/patch-mbdyn__base__invsolver.cc
index b64ea8f7fbf3..654d1aa20952 100644
--- a/science/mbdyn/files/patch-mbdyn__base__invsolver.cc
+++ b/science/mbdyn/files/patch-mbdyn__base__invsolver.cc
@@ -1,12 +1,12 @@
---- ./mbdyn/base/invsolver.cc.orig 2009-04-10 13:25:00.000000000 +0200
-+++ ./mbdyn/base/invsolver.cc 2010-10-31 23:14:49.000000000 +0100
-@@ -200,8 +200,8 @@
- }
+--- mbdyn/base/invsolver.cc.orig 2016-04-24 19:10:43 UTC
++++ mbdyn/base/invsolver.cc
+@@ -114,8 +114,8 @@ InverseSolver::Prepare(void)
+ pRTSolver->Setup();
}
-#ifdef USE_SCHUR
int mpi_finalize = 0;
+#ifdef USE_SCHUR
- int MyRank = 0;
if (bParallel) {
+ DEBUGLCOUT(MYDEBUG_MEM, "creating parallel SchurDataManager"
diff --git a/science/mbdyn/files/patch-mbdyn__base__solver.cc b/science/mbdyn/files/patch-mbdyn__base__solver.cc
index b90b902255b6..f0111db3cb60 100644
--- a/science/mbdyn/files/patch-mbdyn__base__solver.cc
+++ b/science/mbdyn/files/patch-mbdyn__base__solver.cc
@@ -1,6 +1,6 @@
---- mbdyn/base/solver.cc.orig 2011-06-20 14:55:12.000000000 -0400
-+++ mbdyn/base/solver.cc 2011-08-26 05:08:45.000000000 -0400
-@@ -111,10 +111,17 @@
+--- mbdyn/base/solver.cc.orig 2016-04-24 19:10:43 UTC
++++ mbdyn/base/solver.cc
+@@ -109,10 +109,17 @@ enum {
};
volatile sig_atomic_t mbdyn_keep_going = MBDYN_KEEP_GOING;
@@ -18,7 +18,7 @@
extern "C" void
mbdyn_really_exit_handler(int signum)
-@@ -202,7 +209,11 @@
+@@ -200,7 +207,11 @@ extern "C" void
mbdyn_signal_init(int pre)
{
#ifdef HAVE_SIGNAL
@@ -30,13 +30,13 @@
if (pre) {
hdl = mbdyn_really_exit_handler;
-@@ -464,8 +475,8 @@
- }
+@@ -406,8 +417,8 @@ Solver::Prepare(void)
+ pRTSolver->Setup();
}
-#ifdef USE_SCHUR
int mpi_finalize = 0;
+#ifdef USE_SCHUR
- int MyRank = 0;
if (bParallel) {
+ DEBUGLCOUT(MYDEBUG_MEM, "creating parallel SchurDataManager"
diff --git a/science/mbdyn/files/patch-mbdyn__mbdyn.h b/science/mbdyn/files/patch-mbdyn__mbdyn.h
index 873e75856d04..2690e9070f7b 100644
--- a/science/mbdyn/files/patch-mbdyn__mbdyn.h
+++ b/science/mbdyn/files/patch-mbdyn__mbdyn.h
@@ -1,6 +1,6 @@
---- mbdyn/mbdyn.h.orig Thu Feb 10 11:51:26 2005
-+++ mbdyn/mbdyn.h Thu Feb 10 11:51:34 2005
-@@ -49,6 +49,7 @@
+--- mbdyn/mbdyn.h.orig 2015-10-30 05:05:37 UTC
++++ mbdyn/mbdyn.h
+@@ -50,6 +50,7 @@ typedef long int Lint;
typedef double Real;
/* signal types */
@@ -8,7 +8,7 @@
#ifdef HAVE_SIGNAL
#ifndef HAVE___SIGHANDLER_T
#ifndef HAVE_SIGHANDLER_T
-@@ -58,6 +59,7 @@
+@@ -59,6 +60,7 @@ typedef sighandler_t __sighandler_t;
#endif /* HAVE_SIGHANDLER_T */
#endif /* !HAVE___SIGHANDLER_T */
#endif /* HAVE_SIGNAL */
diff --git a/science/mbdyn/pkg-plist b/science/mbdyn/pkg-plist
index 5823e2976db5..504f4ff98c3c 100644
--- a/science/mbdyn/pkg-plist
+++ b/science/mbdyn/pkg-plist
@@ -32,11 +32,18 @@ lib/libmbc.a
lib/libmbc.so
lib/libmbc.so.0
lib/libmbc.so.0.0.0
+man/man1/femgen.1.gz
man/man1/mbdyn.1.gz
share/Aster/cms.py
share/awk/abs2rel.awk
share/awk/mbdyn2easyanim.awk
share/awk/mbdyn2pod.awk
+share/awk/mbdyn_mov2ref.awk
+share/awk/mbdyn_ref2log.awk
share/awk/periodize.awk
share/c81/naca0012.c81
+share/octave/gradnorm.m
+share/octave/mbdyn_derivative.m
share/octave/pod.m
+share/octave/rotation_increment_gibbs_rodriguez.m
+share/octave/rotation_perturbation_matrix_gibbs_rodriguez.m