aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2006-04-25 03:46:15 +0800
committerthierry <thierry@FreeBSD.org>2006-04-25 03:46:15 +0800
commit1c8121b8933df78d69b75c763512bad6ecfa756e (patch)
tree10eaa053c8d5a1daf06cb1728e10ce65a2cbfab6 /science
parent0a11d0f6dbaf41480d3f3a5c3ab9d768e44973e6 (diff)
downloadfreebsd-ports-gnome-1c8121b8933df78d69b75c763512bad6ecfa756e.tar.gz
freebsd-ports-gnome-1c8121b8933df78d69b75c763512bad6ecfa756e.tar.zst
freebsd-ports-gnome-1c8121b8933df78d69b75c763512bad6ecfa756e.zip
A Mesh Generation Utility for use with the ELMER FEM package.
Elmer is an open-source computational tool for multi-physics problems. Elmer includes physical models of fluid dynamics, structural mechanics, electromagnetics and heat transfer. These are described by partial differential equations which Elmer solves by the Finite Element Method (FEM) Submitted by: Pedro F. Giffuni <giffunip@asme.org>
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/elmer-meshgen2d/Makefile24
-rw-r--r--science/elmer-meshgen2d/distinfo3
-rw-r--r--science/elmer-meshgen2d/pkg-descr9
4 files changed, 37 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 448171f2abc3..dbb4d9b9e7ef 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -17,6 +17,7 @@
SUBDIR += dcl
SUBDIR += devisor
SUBDIR += dft++
+ SUBDIR += elmer-meshgen2d
SUBDIR += euler
SUBDIR += fastcap
SUBDIR += fasthenry
diff --git a/science/elmer-meshgen2d/Makefile b/science/elmer-meshgen2d/Makefile
new file mode 100644
index 000000000000..f24ac8df1beb
--- /dev/null
+++ b/science/elmer-meshgen2d/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: elmer-meshgen2d
+# Date created: 5 Jan 2006
+# Whom: Pedro Giffuni <giffunip@asme.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= meshgen2d
+PORTVERSION= 5.0.0
+CATEGORIES= science
+MASTER_SITES= ftp://ftp.funet.fi/pub/sci/physics/elmer/
+PKGNAMEPREFIX= elmer-
+
+MAINTAINER= giffunip@asme.org
+COMMENT= A Mesh Generation Utility for use with the ELMER FEM package
+
+USE_GCC= 4.1+
+GNU_CONFIGURE= yes
+ALL_TARGET=
+
+PLIST_FILES= bin/${MACHINE_ARCH}-portbld-freebsd${OSREL}-ElmerMesh2D \
+ bin/${MACHINE_ARCH}-portbld-freebsd${OSREL}-Mesh2D
+
+.include <bsd.port.mk>
diff --git a/science/elmer-meshgen2d/distinfo b/science/elmer-meshgen2d/distinfo
new file mode 100644
index 000000000000..5d7a7d2ff3b3
--- /dev/null
+++ b/science/elmer-meshgen2d/distinfo
@@ -0,0 +1,3 @@
+MD5 (meshgen2d-5.0.0.tar.gz) = 82a8b0485789ae38a592408c83fe26e6
+SHA256 (meshgen2d-5.0.0.tar.gz) = b45225681a19843c2f61367d394341635d1f13cfd9bc552577d3457414c317e7
+SIZE (meshgen2d-5.0.0.tar.gz) = 133083
diff --git a/science/elmer-meshgen2d/pkg-descr b/science/elmer-meshgen2d/pkg-descr
new file mode 100644
index 000000000000..d45f5cca6743
--- /dev/null
+++ b/science/elmer-meshgen2d/pkg-descr
@@ -0,0 +1,9 @@
+A Mesh Generation Utility for use with the ELMER FEM package
+
+Elmer is an open-source computational tool for multi-physics problems.
+
+Elmer includes physical models of fluid dynamics, structural mechanics,
+electromagnetics and heat transfer. These are described by partial
+differential equations which Elmer solves by the Finite Element Method (FEM)
+
+WWW: http://www.csc.fi/elmer/