aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2011-10-20 22:32:54 +0800
committermakc <makc@FreeBSD.org>2011-10-20 22:32:54 +0800
commit21b0979fb3dc215c2a15600d1e23d1ecc03bf251 (patch)
treeabcca7423dbdd5a33a33f98c3a9a8630d434cdab /science
parentb6d99262086e3c8fc3cc3f818a1516d7b4ecb893 (diff)
downloadfreebsd-ports-gnome-21b0979fb3dc215c2a15600d1e23d1ecc03bf251.tar.gz
freebsd-ports-gnome-21b0979fb3dc215c2a15600d1e23d1ecc03bf251.tar.zst
freebsd-ports-gnome-21b0979fb3dc215c2a15600d1e23d1ecc03bf251.zip
Update to 2.0.4
Diffstat (limited to 'science')
-rw-r--r--science/kst2/Makefile15
-rw-r--r--science/kst2/distinfo4
-rw-r--r--science/kst2/files/patch-cmake__CMakeLists.txt21
-rw-r--r--science/kst2/files/patch-cmake__src__kst__CMakeLists.txt30
-rw-r--r--science/kst2/pkg-plist97
5 files changed, 61 insertions, 106 deletions
diff --git a/science/kst2/Makefile b/science/kst2/Makefile
index f7ead6ec2bf0..2a0c4be69c00 100644
--- a/science/kst2/Makefile
+++ b/science/kst2/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= kst
-DISTVERSION= 2.0.3
-PORTREVISION= 1
+DISTVERSION= 2.0.4
CATEGORIES= science kde
MASTER_SITES= SF/${PORTNAME}/Kst%20${DISTVERSION:C/-r.*//}/
@@ -14,7 +13,6 @@ MAINTAINER= makc@FreeBSD.org
COMMENT= Data viewing and plotting tool
LIB_DEPENDS= gsl.16:${PORTSDIR}/math/gsl
-RUN_DEPENDS= update-mime-database:${PORTSDIR}/misc/shared-mime-info
LATEST_LINK= kst2
@@ -50,10 +48,8 @@ PLIST_SUB+= NETCDF="@comment "
.endif
post-patch:
- ${REINPLACE_CMD} -e '/^Icon=/s,kst,${PREFIX}/share/pixmaps/kst2.png,' \
- ${WRKSRC}/src/kst/*kst.desktop
- ${REINPLACE_CMD} -e '/^Exec=kst2/s,-caption "%c" %i %m,%f,' \
- ${WRKSRC}/src/kst/kst.desktop
+ ${REINPLACE_CMD} -e '/^Exec=kst2/s,\(kst2\).*,\1 %f,' \
+ ${WRKSRC}/src/kst/kst2.desktop
pre-configure:
.if !defined(WITH_FITS)
@@ -65,9 +61,4 @@ pre-configure:
${CMAKE_SOURCE_PATH}/CMakeLists.txt
.endif
-post-install:
- ${MKDIR} ${PREFIX}/share/pixmaps
- ${INSTALL_DATA} ${WRKSRC}/src/images/kst.png ${PREFIX}/share/pixmaps/kst2.png
- @-update-mime-database ${PREFIX}/share/mime
-
.include <bsd.port.mk>
diff --git a/science/kst2/distinfo b/science/kst2/distinfo
index 18d7ac73932c..fecb852e08b7 100644
--- a/science/kst2/distinfo
+++ b/science/kst2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (kst-2.0.3.tar.gz) = 6f6eb90c561fd0d3b5143ca8c3d0094859609126a47baeb58245cdbbe7130451
-SIZE (kst-2.0.3.tar.gz) = 10768666
+SHA256 (kst-2.0.4.tar.gz) = 026774411ce919de6831139c378f632b2493bc31c39f901f5f4da712eb538da3
+SIZE (kst-2.0.4.tar.gz) = 10836992
diff --git a/science/kst2/files/patch-cmake__CMakeLists.txt b/science/kst2/files/patch-cmake__CMakeLists.txt
index 87b2dc03503d..a537f7f5027a 100644
--- a/science/kst2/files/patch-cmake__CMakeLists.txt
+++ b/science/kst2/files/patch-cmake__CMakeLists.txt
@@ -1,6 +1,15 @@
---- ./cmake/CMakeLists.txt.orig 2011-03-28 23:24:54.000000000 +0400
-+++ ./cmake/CMakeLists.txt 2011-03-30 22:24:15.779356501 +0400
-@@ -96,17 +96,6 @@
+--- ./cmake/CMakeLists.txt.orig 2011-09-12 15:34:28.000000000 +0000
++++ ./cmake/CMakeLists.txt 2011-10-15 00:37:11.813906096 +0000
+@@ -37,7 +37,7 @@
+ set(kst_version ${kst_version_string})
+ else()
+ set(kst_version_minor 0)
+- set(kst_version_patch x)
++ set(kst_version_patch 4)
+ set(kst_version ${kst_version_major}.${kst_version_minor}.${kst_version_patch})
+ endif()
+
+@@ -101,17 +101,6 @@
# React on options
@@ -18,7 +27,7 @@
if(kst_install_prefix)
set(CMAKE_INSTALL_PREFIX ${kst_install_prefix} CACHE PATH "User's choice for install prefix" FORCE)
-@@ -130,7 +119,7 @@
+@@ -135,7 +124,7 @@
endif()
#path to install the .desktop files
@@ -27,7 +36,7 @@
-@@ -177,7 +166,9 @@
+@@ -182,7 +171,9 @@
configure_file(${kst_dir}/cmake/config.h.cmake ${CMAKE_BINARY_DIR}/config.h)
@@ -38,7 +47,7 @@
message(STATUS "Build summary----------------------------------")
message(STATUS)
-@@ -203,7 +194,6 @@
+@@ -208,7 +199,6 @@
endif()
if (NOT APPLE)
diff --git a/science/kst2/files/patch-cmake__src__kst__CMakeLists.txt b/science/kst2/files/patch-cmake__src__kst__CMakeLists.txt
index 0a561668f394..7c8375defb87 100644
--- a/science/kst2/files/patch-cmake__src__kst__CMakeLists.txt
+++ b/science/kst2/files/patch-cmake__src__kst__CMakeLists.txt
@@ -1,5 +1,5 @@
---- ./cmake/src/kst/CMakeLists.txt.orig 2011-03-28 23:24:54.000000000 +0400
-+++ ./cmake/src/kst/CMakeLists.txt 2011-03-30 22:22:29.406950318 +0400
+--- ./cmake/src/kst/CMakeLists.txt.orig 2011-09-12 15:34:28.000000000 +0000
++++ ./cmake/src/kst/CMakeLists.txt 2011-10-15 00:36:57.039906521 +0000
@@ -37,9 +37,7 @@
if(UNIX AND NOT APPLE)
set(man ${CMAKE_BINARY_DIR}/${kst_binary_name}.1)
@@ -10,18 +10,14 @@
+ install(FILES ${man} DESTINATION man/man1)
set(k ${kst_dir}/src/kst)
- install(FILES ${k}/kstplugin.desktop
-@@ -48,9 +46,8 @@
- ${k}/kstbasicplugin.desktop
- ${k}/kstfilter.desktop
- ${k}/kstextension.desktop
-- DESTINATION share/servicetypes/kst)
-- install(FILES ${k}/kst.desktop DESTINATION share/applnk/Graphics)
-- install(FILES ${k}/kstui.rc DESTINATION share/apps/kst)
-- install(FILES ${k}/x-kst.desktop DESTINATION share/mimelink/application)
-- install(FILES ${k}/kst.desktop DESTINATION share/applications)
-+ DESTINATION share/servicetypes/kst2)
-+ install(FILES ${k}/kstui.rc DESTINATION share/apps/kst2)
-+ install(FILES ${k}/x-kst.desktop DESTINATION share/mime/application)
-+ install(FILES ${k}/kst.desktop DESTINATION share/applications RENAME kst2.desktop)
- endif()
+ # install(FILES ${k}/kstplugin.desktop
+@@ -49,8 +47,7 @@
+ # ${k}/kstfilter.desktop
+ # ${k}/kstextension.desktop
+ # DESTINATION share/servicetypes/kst)
+- install(FILES ${k}/kst2.desktop DESTINATION share/applnk/Graphics)
+- install(FILES ${k}/x-kst2.desktop DESTINATION share/mimelink/application)
++ install(FILES ${k}/x-kst2.desktop DESTINATION share/mimelnk/application)
+ install(FILES ${k}/kst2.desktop DESTINATION share/applications)
+
+ # icons
diff --git a/science/kst2/pkg-plist b/science/kst2/pkg-plist
index 79680c738c29..11cea7fe807b 100644
--- a/science/kst2/pkg-plist
+++ b/science/kst2/pkg-plist
@@ -53,80 +53,39 @@ lib/kst2/plugins/libkst2_fits_sinusoid_weighted.so
lib/libkst2app.a
lib/libkst2core.so
lib/libkst2core.so.2
-lib/libkst2core.so.2.0.3
+lib/libkst2core.so.2.0.4
lib/libkst2math.so
lib/libkst2math.so.2
-lib/libkst2math.so.2.0.3
+lib/libkst2math.so.2.0.4
lib/libkst2widgets.so
lib/libkst2widgets.so.2
-lib/libkst2widgets.so.2.0.3
+lib/libkst2widgets.so.2.0.4
share/applications/kst2.desktop
-share/apps/kst2/kstui.rc
-share/mime/application/x-kst.desktop
-share/pixmaps/kst2.png
-share/services/kst2/kstdata_ascii.desktop
-%%FITS%%share/services/kst2/kstdata_fitsimage.desktop
-%%NETCDF%%share/services/kst2/kstdata_netcdf.desktop
-share/services/kst2/kstdata_qimagesource.desktop
-share/services/kst2/kstdata_sampledatasource.desktop
-share/services/kst2/kstplugin_akima.desktop
-share/services/kst2/kstplugin_akimaperiodic.desktop
-share/services/kst2/kstplugin_autocorrelation.desktop
-share/services/kst2/kstplugin_bin.desktop
-share/services/kst2/kstplugin_chop.desktop
-share/services/kst2/kstplugin_convolve.desktop
-share/services/kst2/kstplugin_crosscorrelation.desktop
-share/services/kst2/kstplugin_crossspectrum.desktop
-share/services/kst2/kstplugin_csplineperiodic.desktop
-share/services/kst2/kstplugin_cumulativesum.desktop
-share/services/kst2/kstplugin_deconvolve.desktop
-share/services/kst2/kstplugin_differentiation.desktop
-share/services/kst2/kstplugin_effectivebandwidth.desktop
-share/services/kst2/kstplugin_filter_butterworth_bandpass.desktop
-share/services/kst2/kstplugin_filter_butterworth_bandstop.desktop
-share/services/kst2/kstplugin_filter_butterworth_highpass.desktop
-share/services/kst2/kstplugin_filter_butterworth_lowpass.desktop
-share/services/kst2/kstplugin_filter_despike.desktop
-share/services/kst2/kstplugin_fits_exponential_unweighted.desktop
-share/services/kst2/kstplugin_fits_exponential_weighted.desktop
-share/services/kst2/kstplugin_fits_gaussian_unweighted.desktop
-share/services/kst2/kstplugin_fits_gaussian_weighted.desktop
-share/services/kst2/kstplugin_fits_gradient_unweighted.desktop
-share/services/kst2/kstplugin_fits_gradient_weighted.desktop
-share/services/kst2/kstplugin_fits_kneefrequency.desktop
-share/services/kst2/kstplugin_fits_linear_unweighted.desktop
-share/services/kst2/kstplugin_fits_linear_weighted.desktop
-share/services/kst2/kstplugin_fits_lorentzian_unweighted.desktop
-share/services/kst2/kstplugin_fits_lorentzian_weighted.desktop
-share/services/kst2/kstplugin_fits_polynomial_unweighted.desktop
-share/services/kst2/kstplugin_fits_polynomial_weighted.desktop
-share/services/kst2/kstplugin_fits_sinusoid_unweighted.desktop
-share/services/kst2/kstplugin_fits_sinusoid_weighted.desktop
-share/services/kst2/kstplugin_genericfilter.desktop
-share/services/kst2/kstplugin_linear.desktop
-share/services/kst2/kstplugin_linefit.desktop
-share/services/kst2/kstplugin_lockin.desktop
-share/services/kst2/kstplugin_noiseaddition.desktop
-share/services/kst2/kstplugin_periodogram.desktop
-share/services/kst2/kstplugin_phase.desktop
-share/services/kst2/kstplugin_polynomial.desktop
-share/services/kst2/kstplugin_shift.desktop
-share/services/kst2/kstplugin_statistics.desktop
-share/services/kst2/kstplugin_syncbin.desktop
-share/servicetypes/kst2/kstbasicplugin.desktop
-share/servicetypes/kst2/kstdataobjectplugin.desktop
-share/servicetypes/kst2/kstdatasourceplugin.desktop
-share/servicetypes/kst2/kstextension.desktop
-share/servicetypes/kst2/kstfilter.desktop
-share/servicetypes/kst2/kstplugin.desktop
-@dirrm share/servicetypes/kst2
-@dirrmtry share/servicetypes
-@dirrm share/services/kst2
-@dirrmtry share/services
-@dirrm share/apps/kst2
-@dirrmtry share/apps
+share/icons/hicolor/128x128/apps/application-x-kst.png
+share/icons/hicolor/128x128/apps/kst.png
+share/icons/hicolor/32x32/apps/application-x-kst.png
+share/icons/hicolor/32x32/apps/kst.png
+share/icons/hicolor/48x48/apps/application-x-kst.png
+share/icons/hicolor/48x48/apps/kst.png
+share/icons/hicolor/64x64/apps/application-x-kst.png
+share/icons/hicolor/64x64/apps/kst.png
+share/icons/hicolor/scalable/apps/application-x-kst.svg
+share/icons/hicolor/scalable/apps/kst.svg
+share/mimelnk/application/x-kst2.desktop
+@dirrmtry share/mimelnk/application
+@dirrmtry share/mimelnk
+@dirrmtry share/icons/hicolor/scalable/apps
+@dirrmtry share/icons/hicolor/scalable
+@dirrmtry share/icons/hicolor/64x64/apps
+@dirrmtry share/icons/hicolor/64x64
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor/32x32/apps
+@dirrmtry share/icons/hicolor/32x32
+@dirrmtry share/icons/hicolor/128x128/apps
+@dirrmtry share/icons/hicolor/128x128
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
@dirrmtry share/applications
@dirrm lib/kst2/plugins
@dirrm lib/kst2
-@exec %%LOCALBASE%%/bin/update-mime-database %D/share/mime > /dev/null || /usr/bin/true
-@unexec %%LOCALBASE%%/bin/update-mime-database %D/share/mime > /dev/null || /usr/bin/true