aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-28 15:53:46 +0800
committerMartin Wilke <miwi@FreeBSD.org>2008-04-28 15:53:46 +0800
commit21bfc0b836e17f33985f1ebd241b3e0c615a0470 (patch)
tree9f196d0794e5b57b24f2aa124a7c8919789c2892 /science
parent5c5b0ab7cde054cecf8bb6cf99067f517e6cb1ab (diff)
downloadfreebsd-ports-gnome-21bfc0b836e17f33985f1ebd241b3e0c615a0470.tar.gz
freebsd-ports-gnome-21bfc0b836e17f33985f1ebd241b3e0c615a0470.tar.zst
freebsd-ports-gnome-21bfc0b836e17f33985f1ebd241b3e0c615a0470.zip
- Fix build after math/GiNaC update
PR: 122503 Submitted by: Ports Fury
Diffstat (limited to 'science')
-rw-r--r--science/xloops-ginac/Makefile19
-rw-r--r--science/xloops-ginac/files/patch-Makefile.in11
-rw-r--r--science/xloops-ginac/files/patch-configure.ac13
-rw-r--r--science/xloops-ginac/files/patch-ginsh_parser.yy59
4 files changed, 76 insertions, 26 deletions
diff --git a/science/xloops-ginac/Makefile b/science/xloops-ginac/Makefile
index cbaf723b7636..fb9ee0486f0a 100644
--- a/science/xloops-ginac/Makefile
+++ b/science/xloops-ginac/Makefile
@@ -15,22 +15,21 @@ MASTER_SITES= http://wwwthep.physik.uni-mainz.de/~xloops/
MAINTAINER= ports@FreeBSD.org
COMMENT= A program calculating Feynman diagrams
-LIB_DEPENDS= ginac-1.3.8:${PORTSDIR}/math/GiNaC
+LIB_DEPENDS= ginac-1.4.0:${PORTSDIR}/math/GiNaC
-BROKEN= Does not configure (cannot find GiNaC)
-DEPRECATED= ${BROKEN}
-EXPIRATION_DATE=2008-03-17
-
-USE_GCC= 3.4
-USE_GMAKE= yes
USE_GNOME= gnometarget
-GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_AUTOTOOLS= aclocal:110 autoheader:261 autoconf:261 automake:110 \
+ libtool:15
+ACLOCAL_ARGS= -I ${LOCALBASE}/share/aclocal
+AUTOMAKE_ARGS= --add-missing
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
- AUTOHEADER="${TRUE}"
CFLAGS+= -fpermissive
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
+post-patch:
+ @${REINPLACE_CMD} -e '/^SUBDIRS/s|doc||g' ${WRKSRC}/Makefile.am
+
.include <bsd.port.mk>
diff --git a/science/xloops-ginac/files/patch-Makefile.in b/science/xloops-ginac/files/patch-Makefile.in
deleted file mode 100644
index 5ce920225565..000000000000
--- a/science/xloops-ginac/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig Thu Nov 8 23:19:05 2001
-+++ Makefile.in Fri Oct 10 11:10:31 2003
-@@ -91,7 +91,7 @@
- am__quote = @am__quote@
- install_sh = @install_sh@
-
--SUBDIRS = lib check xloops ginsh doc
-+SUBDIRS = lib check xloops ginsh
-
- # Requires automake 1.4
- AUTOMAKE_OPTIONS = 1.4
diff --git a/science/xloops-ginac/files/patch-configure.ac b/science/xloops-ginac/files/patch-configure.ac
new file mode 100644
index 000000000000..3261ab78058b
--- /dev/null
+++ b/science/xloops-ginac/files/patch-configure.ac
@@ -0,0 +1,13 @@
+--- configure.ac.orig 2001-11-08 23:18:49.000000000 +0900
++++ configure.ac 2008-04-06 20:58:27.000000000 +0900
+@@ -72,8 +72,8 @@
+ ln -fs ${with_ginac}/ginsh/ginsh_parser.yy . \
+ )
+ else
+- AM_PATH_GINAC([0.9.4], , AC_MSG_ERROR([need to have GiNaC installed]))
+- CPPFLAGS="$CPPFLAGS $GINACLIB_CPPFLAGS"
++ PKG_CHECK_MODULES(GINACLIB, ginac >= 0.9.4, , AC_MSG_ERROR([need to have GiNaC installed]))
++ CPPFLAGS="$CPPFLAGS $GINACLIB_CFLAGS"
+ LIBS="$LIBS $GINACLIB_LIBS"
+ fi
+
diff --git a/science/xloops-ginac/files/patch-ginsh_parser.yy b/science/xloops-ginac/files/patch-ginsh_parser.yy
index 80fe08e52859..e03f32c1d1c3 100644
--- a/science/xloops-ginac/files/patch-ginsh_parser.yy
+++ b/science/xloops-ginac/files/patch-ginsh_parser.yy
@@ -1,5 +1,5 @@
---- ginsh/ginsh_parser.yy.orig Tue Oct 15 17:15:25 2002
-+++ ginsh/ginsh_parser.yy Tue Oct 15 17:18:14 2002
+--- ginsh/ginsh_parser.yy.orig 2001-11-01 00:46:50.000000000 +0900
++++ ginsh/ginsh_parser.yy 2008-04-09 21:35:18.000000000 +0900
@@ -29,6 +29,7 @@
%{
#include "config.h"
@@ -8,12 +8,61 @@
#include <sys/resource.h>
#if HAVE_UNISTD_H
-@@ -796,6 +797,8 @@
+@@ -50,6 +51,12 @@
+ static const char *orig_basic_word_break_characters;
+ #endif
+
++#if (GINAC_RL_VERSION_MAJOR >= 5)
++#define GINAC_RL_COMPLETER_CAST(a) const_cast<char *>((a))
++#else
++#define GINAC_RL_COMPLETER_CAST(a) (a)
++#endif
++
+ // Expression stack for ", "" and """
+ static void push(const ex &e);
+ static ex exstack[3];
+@@ -625,7 +632,8 @@
+ }
+
+ // All registered GiNaC functions
+-void GiNaC::ginsh_get_ginac_functions(void)
++namespace GiNaC {
++void ginsh_get_ginac_functions(void)
+ {
+ vector<function_options>::const_iterator i = function::registered_functions().begin(), end = function::registered_functions().end();
+ unsigned serial = 0;
+@@ -635,6 +643,7 @@
+ serial++;
+ }
+ }
++}
+
+
/*
+@@ -764,7 +773,7 @@
+ // For shell commands, revert back to filename completion
+ rl_completion_append_character = orig_completion_append_character;
+ rl_basic_word_break_characters = orig_basic_word_break_characters;
+- rl_completer_word_break_characters = rl_basic_word_break_characters;
++ rl_completer_word_break_characters = GINAC_RL_COMPLETER_CAST(rl_basic_word_break_characters);
+ #if (GINAC_RL_VERSION_MAJOR < 4) || (GINAC_RL_VERSION_MAJOR == 4 && GINAC_RL_VERSION_MINOR < 2)
+ return completion_matches(const_cast<char *>(text), (CPFunction *)filename_completion_function);
+ #else
+@@ -774,7 +783,7 @@
+ // Otherwise, complete function names
+ rl_completion_append_character = '(';
+ rl_basic_word_break_characters = " \t\n\"#$%&'()*+,-./:;<=>?@[\\]^`{|}~";
+- rl_completer_word_break_characters = rl_basic_word_break_characters;
++ rl_completer_word_break_characters = GINAC_RL_COMPLETER_CAST(rl_basic_word_break_characters);
+ #if (GINAC_RL_VERSION_MAJOR < 4) || (GINAC_RL_VERSION_MAJOR == 4 && GINAC_RL_VERSION_MINOR < 2)
+ return completion_matches(const_cast<char *>(text), (CPFunction *)fcn_generator);
+ #else
+@@ -797,6 +806,8 @@
* Main program
*/
-+
-+int yyparse();
++int yyparse();
++
int main(int argc, char **argv)
{
+ // Print banner in interactive mode