aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-10-07 20:26:54 +0800
committermakc <makc@FreeBSD.org>2013-10-07 20:26:54 +0800
commit28d85c1edfec0ebeb6deae7dcb602f29fc71141f (patch)
treecd193dd8c561bb2f429a8bf31172de87b83d4a9f /science
parent265e6d93a31592bc765ae1c17206bc2205c3f5e4 (diff)
downloadfreebsd-ports-gnome-28d85c1edfec0ebeb6deae7dcb602f29fc71141f.tar.gz
freebsd-ports-gnome-28d85c1edfec0ebeb6deae7dcb602f29fc71141f.tar.zst
freebsd-ports-gnome-28d85c1edfec0ebeb6deae7dcb602f29fc71141f.zip
- Remove LATEST_LINK from my Qt4/KDE4 ports
- Use new LIB_DEPENDS syntax - Use options helpers
Diffstat (limited to 'science')
-rw-r--r--science/kst2/Makefile30
1 files changed, 7 insertions, 23 deletions
diff --git a/science/kst2/Makefile b/science/kst2/Makefile
index c39a45e7187b..fb508c7ae2c9 100644
--- a/science/kst2/Makefile
+++ b/science/kst2/Makefile
@@ -12,8 +12,6 @@ COMMENT= Data viewing and plotting tool
LIB_DEPENDS= gsl:${PORTSDIR}/math/gsl
-LATEST_LINK= kst2
-
USES= cmake
USE_QT4= gui xml designer svg opengl \
qmake_build moc_build rcc_build uic_build
@@ -28,33 +26,19 @@ PLIST_SUB= SHLIB_VER=${PORTVERSION}
OPTIONS_DEFINE= FITS MATLAB NETCDF
FITS_DESC= Support for data in FITS format
+FITS_LIB_DEPENDS= libcfitsio.so:${PORTSDIR}/astro/cfitsio
+
MATLAB_DESC= Support for data in MATLAB format
+MATLAB_BUILD_DEPENDS= ${LOCALBASE}/lib/libmatio.a:${PORTSDIR}/math/matio
+
NETCDF_DESC= Support for data in NetCDF format
+NETCDF_LIB_DEPENDS= libnetcdf.so:${PORTSDIR}/science/netcdf
+
+OPTIONS_SUB= yes
NO_STAGE= yes
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MFITS}
-LIB_DEPENDS+= cfitsio.0:${PORTSDIR}/astro/cfitsio
-PLIST_SUB+= FITS=""
-.else
-PLIST_SUB+= FITS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MMATLAB}
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libmatio.a:${PORTSDIR}/math/matio
-PLIST_SUB+= MATLAB=""
-.else
-PLIST_SUB+= MATLAB="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MNETCDF}
-LIB_DEPENDS+= netcdf.4:${PORTSDIR}/science/netcdf
-PLIST_SUB+= NETCDF=""
-.else
-PLIST_SUB+= NETCDF="@comment "
-.endif
-
post-patch:
${REINPLACE_CMD} -e '/^Exec=kst2/s,\(kst2\).*,\1 %f,' \
${WRKSRC}/src/kst/kst2.desktop