aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2005-03-18 23:54:11 +0800
committerglewis <glewis@FreeBSD.org>2005-03-18 23:54:11 +0800
commit3b6c1f6bdfd3c713cec21df18335d4de1c8d382f (patch)
tree169cdb3ee2a056bb0f65c99e598466ebfc7de011 /science
parentd9cdbcb921f69bdfa38ef1d7994b5ed2e20ce391 (diff)
downloadfreebsd-ports-gnome-3b6c1f6bdfd3c713cec21df18335d4de1c8d382f.tar.gz
freebsd-ports-gnome-3b6c1f6bdfd3c713cec21df18335d4de1c8d382f.tar.zst
freebsd-ports-gnome-3b6c1f6bdfd3c713cec21df18335d4de1c8d382f.zip
. Fix the build for gcc 3.4 (and hence FreeBSD 5.x). For some reason -lm
is added when we're using gcc 2.95.4, but not using gcc 3.4. Since its required, add it explicitly.
Diffstat (limited to 'science')
-rw-r--r--science/szip/files/patch-examples-Makefile.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/science/szip/files/patch-examples-Makefile.in b/science/szip/files/patch-examples-Makefile.in
new file mode 100644
index 000000000000..c09e3b5dee8c
--- /dev/null
+++ b/science/szip/files/patch-examples-Makefile.in
@@ -0,0 +1,13 @@
+$FreeBSD$
+
+--- examples/Makefile.in.orig Fri Mar 18 08:46:51 2005
++++ examples/Makefile.in Fri Mar 18 08:47:39 2005
+@@ -203,7 +203,7 @@
+ done
+ burst_szip$(EXEEXT): $(burst_szip_OBJECTS) $(burst_szip_DEPENDENCIES)
+ @rm -f burst_szip$(EXEEXT)
+- $(LINK) $(burst_szip_LDFLAGS) $(burst_szip_OBJECTS) $(burst_szip_LDADD) $(LIBS)
++ $(LINK) $(burst_szip_LDFLAGS) $(burst_szip_OBJECTS) $(burst_szip_LDADD) $(LIBS) -lm
+ example$(EXEEXT): $(example_OBJECTS) $(example_DEPENDENCIES)
+ @rm -f example$(EXEEXT)
+ $(LINK) $(example_LDFLAGS) $(example_OBJECTS) $(example_LDADD) $(LIBS)