aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-08-09 05:05:43 +0800
committerYuri Victorovich <yuri@FreeBSD.org>2019-08-09 05:05:43 +0800
commit3baf2e986b85bf565f986f2ea84b6dc92b36543b (patch)
tree1ba430439bc3137f4912f49a38e03e5fd239c4a0 /science
parentc8d423cde90b1c9c87d101d23ec1d5878149d5c0 (diff)
downloadfreebsd-ports-gnome-3baf2e986b85bf565f986f2ea84b6dc92b36543b.tar.gz
freebsd-ports-gnome-3baf2e986b85bf565f986f2ea84b6dc92b36543b.tar.zst
freebsd-ports-gnome-3baf2e986b85bf565f986f2ea84b6dc92b36543b.zip
New port: science/py-chainer-chemistry: Library for deep learning in biology and chemistry
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/py-chainer-chemistry/Makefile28
-rw-r--r--science/py-chainer-chemistry/distinfo3
-rw-r--r--science/py-chainer-chemistry/pkg-descr6
4 files changed, 38 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index ca17add424cc..d7d2e8276a0a 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -233,6 +233,7 @@
SUBDIR += py-avogadrolibs
SUBDIR += py-cdo
SUBDIR += py-chainer
+ SUBDIR += py-chainer-chemistry
SUBDIR += py-chempy
SUBDIR += py-coards
SUBDIR += py-dlib
diff --git a/science/py-chainer-chemistry/Makefile b/science/py-chainer-chemistry/Makefile
new file mode 100644
index 000000000000..a8687c0814e8
--- /dev/null
+++ b/science/py-chainer-chemistry/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= chainer-chemistry
+DISTVERSION= 0.5.0
+CATEGORIES= science biology
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Library for deep learning in biology and chemistry
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}chainer>0:science/py-chainer@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}joblib>0:devel/py-joblib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pandas>0:math/py-pandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scikit-learn>0:science/py-scikit-learn@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tqdm>0:misc/py-tqdm@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/science/py-chainer-chemistry/distinfo b/science/py-chainer-chemistry/distinfo
new file mode 100644
index 000000000000..b73d5a970e0b
--- /dev/null
+++ b/science/py-chainer-chemistry/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1565289694
+SHA256 (chainer-chemistry-0.5.0.tar.gz) = 12a2c19d4846907cdd2e51eeb65ba21d7012e759c7fed3ddb0ee89f2d239a4f5
+SIZE (chainer-chemistry-0.5.0.tar.gz) = 77660
diff --git a/science/py-chainer-chemistry/pkg-descr b/science/py-chainer-chemistry/pkg-descr
new file mode 100644
index 000000000000..c951f9ff5c8b
--- /dev/null
+++ b/science/py-chainer-chemistry/pkg-descr
@@ -0,0 +1,6 @@
+Chainer Chemistry is a deep learning framework (based on Chainer) with
+applications in Biology and Chemistry. It supports various state-of-the-art
+models (especially GCNN - Graph Convolutional Neural Network) for chemical
+property prediction.
+
+WWW: https://github.com/pfnet-research/chainer-chemistry