aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2012-04-08 18:31:29 +0800
committermiwi <miwi@FreeBSD.org>2012-04-08 18:31:29 +0800
commit4e7b8c911aed548ea884dbc536b5d81c9579823b (patch)
treed8d1c72914ebe2334926556c14cd117b946a1abe /science
parentec59d3fc5178caf84f5b2ca6a98cae57b320f1f7 (diff)
downloadfreebsd-ports-gnome-4e7b8c911aed548ea884dbc536b5d81c9579823b.tar.gz
freebsd-ports-gnome-4e7b8c911aed548ea884dbc536b5d81c9579823b.tar.zst
freebsd-ports-gnome-4e7b8c911aed548ea884dbc536b5d81c9579823b.zip
- Remove unnecessary LIB_DEPENDS for x11-toolkits/fltk
- Switch to textproc/xerces-c3 instead of textproc/xerces-c2 - Add LICENSE - Add MAKE_JOBS_SAFE - Support CFLAGS properly PR: 166050 Submitted by: Ports Fury Approved by: maintainer Feature safe: yes
Diffstat (limited to 'science')
-rw-r--r--science/peekabot/Makefile30
1 files changed, 20 insertions, 10 deletions
diff --git a/science/peekabot/Makefile b/science/peekabot/Makefile
index dda45ce3892d..b30a882dd023 100644
--- a/science/peekabot/Makefile
+++ b/science/peekabot/Makefile
@@ -7,26 +7,30 @@
PORTNAME= peekabot
PORTVERSION= 0.8.6
+PORTREVISION= 1
CATEGORIES= science
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:R}.x/
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:R}.x
MAINTAINER= 5u623l20@gmail.com
COMMENT= Distributed real-time 3D visualization tool for robotics researchers
+LICENSE= BSL GPLv3
+LICENSE_COMB= multi
+
LIB_DEPENDS= boost_regex.4:${PORTSDIR}/devel/boost-libs \
- xerces-c.27:${PORTSDIR}/textproc/xerces-c2 \
- fltk.1:${PORTSDIR}/x11-toolkits/fltk \
+ xerces-c.3:${PORTSDIR}/textproc/xerces-c3 \
gtkglextmm-x11-1.2:${PORTSDIR}/x11-toolkits/gtkglextmm
-GNU_CONFIGURE= yes
-CPPFLAGS+= `fltk-config --cflags`
-LDFLAGS+= `fltk-config --ldflags`
-USE_LDCONFIG= yes
USE_BZIP2= yes
-USE_GMAKE= yes
USE_GNOME= gnomehack
-#Internal compiler error with < 4.4
-USE_GCC= 4.4+
+USE_GCC= 4.6+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.pre.mk>
@@ -34,4 +38,10 @@ USE_GCC= 4.4+
BROKEN= does not compile with boost on sparc64
.endif
+post-patch:
+ @${REINPLACE_CMD} -e \
+ "/names_next_round/s|'xerces-c'|'xerces-c-3.1'|" ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ "/^AM_/s|-O2||" ${WRKSRC}/src/Makefile.in
+
.include <bsd.port.post.mk>