aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2015-06-16 05:49:52 +0800
committerrakuco <rakuco@FreeBSD.org>2015-06-16 05:49:52 +0800
commit6591f7a18ee1e7d4043aaa22a71d2eaff09adc03 (patch)
treea31fd8191f701d728343930164a4265eb30f59f9 /science
parentc41f422cd6fa4ac4a8be67036e3b41b8d70b8501 (diff)
downloadfreebsd-ports-gnome-6591f7a18ee1e7d4043aaa22a71d2eaff09adc03.tar.gz
freebsd-ports-gnome-6591f7a18ee1e7d4043aaa22a71d2eaff09adc03.tar.zst
freebsd-ports-gnome-6591f7a18ee1e7d4043aaa22a71d2eaff09adc03.zip
Add patch to fix the build with CMake 3.2.
Explicitly look for X11, since FindOpenGL.cmake no longer does that automatically.
Diffstat (limited to 'science')
-rw-r--r--science/avogadro/files/patch-CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/science/avogadro/files/patch-CMakeLists.txt b/science/avogadro/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..afc08f2eb271
--- /dev/null
+++ b/science/avogadro/files/patch-CMakeLists.txt
@@ -0,0 +1,22 @@
+Explicitly look for X11 when using it.
+
+This fixes the build with CMake 3.2, whose FindOpenGL.cmake stopped
+calling find_package(X11).
+
+Instead, do that ourselves when Q_WS_X11 is true, since that is when we
+already try to link against libX11.
+
+Sent upstream: https://github.com/cryos/avogadro/pull/13
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -230,6 +230,10 @@ if(NOT Linguist_FOUND)
+ message(WARNING " Qt4 Linguist not found, please install it if you want Avogadro translations")
+ endif()
+
++if(Q_WS_X11)
++ find_package(X11 REQUIRED) # avogadro/src/main.cpp calls XInitThread().
++endif()
++
+ find_package(Eigen3) # find and setup Eigen3 if available
+ if(NOT EIGEN3_FOUND)
+ message(STATUS "Cannot find Eigen3, trying Eigen2")