aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2021-02-14 18:10:27 +0800
committerMax Brazhnikov <makc@FreeBSD.org>2021-02-14 18:10:27 +0800
commit89bb6a17a0fd86e5acbae73b07bab858f88e0b15 (patch)
tree686648bcc7bb8a6883f9bba7ad0f5bf02c485203 /science
parent73364c4d5b2627a5913222f24255640edf55e9f1 (diff)
downloadfreebsd-ports-gnome-89bb6a17a0fd86e5acbae73b07bab858f88e0b15.tar.gz
freebsd-ports-gnome-89bb6a17a0fd86e5acbae73b07bab858f88e0b15.tar.zst
freebsd-ports-gnome-89bb6a17a0fd86e5acbae73b07bab858f88e0b15.zip
science/kst2:
- Switch from GitHub to the primary source repo (KDE invent) [1] and update to 2021.01.24 snapshot. The project development is stalled, therefore no changes in this update except translations. - Drop stale patches. - Amend description and WWW. - Install man page to the default path. Suggested by: adridg [1]
Diffstat (limited to 'science')
-rw-r--r--science/kst2/Makefile16
-rw-r--r--science/kst2/distinfo6
-rw-r--r--science/kst2/files/patch-src__kst__CMakeLists.txt2
-rw-r--r--science/kst2/files/patch-src_libkstapp_shortcutdialog.cpp10
-rw-r--r--science/kst2/files/patch-src_libkstapp_view.h12
-rw-r--r--science/kst2/pkg-descr6
-rw-r--r--science/kst2/pkg-plist2
7 files changed, 12 insertions, 42 deletions
diff --git a/science/kst2/Makefile b/science/kst2/Makefile
index e4b7f26e1033..98ac2cf763dd 100644
--- a/science/kst2/Makefile
+++ b/science/kst2/Makefile
@@ -3,7 +3,6 @@
PORTNAME= kst
DISTVERSION= ${KST_VERSION}.${KST_DATE}
-PORTREVISION= 5
CATEGORIES= science
MAINTAINER= makc@FreeBSD.org
@@ -18,24 +17,21 @@ LICENSE_FILE_LGPL20= ${WRKSRC}/COPYING.LGPL
LIB_DEPENDS= libgsl.so:math/gsl \
libtiff.so:graphics/tiff
-KST_VERSION= 2.0.8
-KST_DATE= 20190325
-
-USES= cmake compiler:c++11-lang desktop-file-utils pkgconfig \
+USES= cmake compiler:c++11-lang desktop-file-utils kde:5 pkgconfig \
qt:5 shared-mime-info
USE_QT= concurrent core gui network printsupport svg widgets xml \
buildtools_build linguisttools_build qmake_build
USE_LDCONFIG= yes
-USE_GITHUB= yes
-GH_ACCOUNT= KDE
-GH_PROJECT= kst-plot
-GH_TAGNAME= 35c35e1
+KST_VERSION= 2.0.8
+KST_DATE= 20210124
+KST_COMMIT= 38eddb53
+KDE_INVENT= 38eddb5322a1d557f9d86ea95d456d76272941e3 graphics kst-plot
CMAKE_ARGS= -Dkst_install_prefix=${PREFIX} \
-Dkst_pch=off \
-Dkst_version_string=${KST_VERSION} \
- -Dkst_revision="${GH_TAGNAME} ${KST_DATE}" \
+ -Dkst_revision="${KST_COMMIT} ${KST_DATE}" \
-DCMAKE_DISABLE_FIND_PACKAGE_Getdata=ON \
-Dkst_qt5=on
diff --git a/science/kst2/distinfo b/science/kst2/distinfo
index 84144b7cb1d8..691b89bbaf49 100644
--- a/science/kst2/distinfo
+++ b/science/kst2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1555765884
-SHA256 (KDE-kst-plot-2.0.8.20190325-35c35e1_GH0.tar.gz) = b448a857d18ae066001a80e20b6eb0cbfaa40fa3634791793221c5e08ee61a14
-SIZE (KDE-kst-plot-2.0.8.20190325-35c35e1_GH0.tar.gz) = 18791194
+TIMESTAMP = 1613293183
+SHA256 (graphics-kst-plot-38eddb5322a1d557f9d86ea95d456d76272941e3_GL0.tar.gz) = dbda1392146cb1dde219109384f44087b1217b4015d54358fb7c6416c428a11d
+SIZE (graphics-kst-plot-38eddb5322a1d557f9d86ea95d456d76272941e3_GL0.tar.gz) = 18790860
diff --git a/science/kst2/files/patch-src__kst__CMakeLists.txt b/science/kst2/files/patch-src__kst__CMakeLists.txt
index 9835acd543c8..c73b8e0b6ec9 100644
--- a/science/kst2/files/patch-src__kst__CMakeLists.txt
+++ b/science/kst2/files/patch-src__kst__CMakeLists.txt
@@ -7,7 +7,7 @@
- install(CODE "execute_process(COMMAND gzip ${man})")
- set_source_files_properties(${man}.gz PROPERTIES GENERATED TRUE)
- install(FILES ${man}.gz DESTINATION share/man/man1)
-+ install(FILES ${man} DESTINATION man/man1)
++ install(FILES ${man} DESTINATION share/man/man1)
set(k ${kst_dir}/src/kst)
# install(FILES ${k}/kstplugin.desktop
diff --git a/science/kst2/files/patch-src_libkstapp_shortcutdialog.cpp b/science/kst2/files/patch-src_libkstapp_shortcutdialog.cpp
deleted file mode 100644
index 036c635ca902..000000000000
--- a/science/kst2/files/patch-src_libkstapp_shortcutdialog.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/libkstapp/shortcutdialog.cpp.orig 2018-11-23 19:35:50 UTC
-+++ src/libkstapp/shortcutdialog.cpp
-@@ -17,6 +17,7 @@
- #include <QDebug>
- #include <QTextEdit>
- #include <QFile>
-+#include <QStyle>
-
- #include <QStringList>
-
diff --git a/science/kst2/files/patch-src_libkstapp_view.h b/science/kst2/files/patch-src_libkstapp_view.h
deleted file mode 100644
index c27f6b63d591..000000000000
--- a/science/kst2/files/patch-src_libkstapp_view.h
+++ /dev/null
@@ -1,12 +0,0 @@
-Fix build with Qt 5.11
-
---- src/libkstapp/view.h.orig 2018-08-31 07:50:35 UTC
-+++ src/libkstapp/view.h
-@@ -14,6 +14,7 @@
- #define VIEW_H
-
- #include <QGraphicsView>
-+#include <QMenu>
-
- #include "kst_export.h"
-
diff --git a/science/kst2/pkg-descr b/science/kst2/pkg-descr
index baee28eae5af..64988c0735ef 100644
--- a/science/kst2/pkg-descr
+++ b/science/kst2/pkg-descr
@@ -17,8 +17,4 @@ Features of Kst include:
- Support for several popular data formats.
- Extended annotation objects similar to vector graphics applications.
-This port provide Kst 2, which is based on Qt4. It still lacks scripting
-support and backward compatibility with Kst 1.x series (you can't open
-kst-1 files in Kst 2).
-
-WWW: http://kst.kde.org
+WWW: https://kst-plot.kde.org
diff --git a/science/kst2/pkg-plist b/science/kst2/pkg-plist
index 7c67e08c32b2..b7cee2d240ff 100644
--- a/science/kst2/pkg-plist
+++ b/science/kst2/pkg-plist
@@ -69,7 +69,6 @@ lib/libkst2math.so.%%SHLIB_VER%%
lib/libkst2widgets.so
lib/libkst2widgets.so.2
lib/libkst2widgets.so.%%SHLIB_VER%%
-man/man1/kst2.1.gz
share/applications/kst2.desktop
share/icons/hicolor/128x128/apps/kst.png
share/icons/hicolor/128x128/mimetypes/application-x-kst.png
@@ -81,4 +80,5 @@ share/icons/hicolor/64x64/apps/kst.png
share/icons/hicolor/64x64/mimetypes/application-x-kst.png
share/icons/hicolor/scalable/apps/kst.svg
share/icons/hicolor/scalable/mimetypes/application-x-kst.svg
+share/man/man1/kst2.1.gz
share/mime/packages/x-kst.xml