aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2013-08-18 00:27:24 +0800
committergerald <gerald@FreeBSD.org>2013-08-18 00:27:24 +0800
commit92621d361d009a9f1c5fbfe137cf9e878dbe34cf (patch)
treec1657d06d35b5f160b90b16620933ca757495766 /science
parent9e9651b8c9f8d3ec1375dfb2e0d48a491ad6c121 (diff)
downloadfreebsd-ports-gnome-92621d361d009a9f1c5fbfe137cf9e878dbe34cf.tar.gz
freebsd-ports-gnome-92621d361d009a9f1c5fbfe137cf9e878dbe34cf.tar.zst
freebsd-ports-gnome-92621d361d009a9f1c5fbfe137cf9e878dbe34cf.zip
Replace USE_GCC=4.6+ and USE_GCC=4.4+ by USE_GCC=yes.
Right now this is a noop in the former case and a noop in the latter case unless lang/gcc44 has been installed explicitly. This puts a bit more emphasis on standardizing on a canonical version "current" GCC and makes it easier to update that canonical version by changing the default in Mk/bsd.gcc.mk and updating the lang/gcc port. That is, USE_GCC=yes means "use a decent/modern version of GCC" without having to worry about details. Approved by: portmgr (bdrewery)
Diffstat (limited to 'science')
-rw-r--r--science/gnudatalanguage/Makefile2
-rw-r--r--science/harminv/Makefile2
-rw-r--r--science/kalzium/Makefile3
-rw-r--r--science/meep/Makefile2
-rw-r--r--science/peekabot/Makefile2
5 files changed, 5 insertions, 6 deletions
diff --git a/science/gnudatalanguage/Makefile b/science/gnudatalanguage/Makefile
index bfe754b61c80..eb780e01f7d4 100644
--- a/science/gnudatalanguage/Makefile
+++ b/science/gnudatalanguage/Makefile
@@ -33,7 +33,7 @@ LIB_DEPENDS+= plplotd.11:${PORTSDIR}/math/plplot \
gsl.16:${PORTSDIR}/math/gsl \
dps.0:${PORTSDIR}/x11/dgs
-USE_GCC= 4.6+
+USE_GCC= yes
USE_WX= 2.8
USES= pkgconfig
GNU_CONFIGURE= yes
diff --git a/science/harminv/Makefile b/science/harminv/Makefile
index 433048bfdf1e..0f3d3d8c6044 100644
--- a/science/harminv/Makefile
+++ b/science/harminv/Makefile
@@ -17,7 +17,7 @@ COMMENT= Solver of harmonic inversion
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_FORTRAN= yes
-USE_GCC= 4.4+
+USE_GCC= yes
CPPFLAGS+= -I${LOCALBASE}/include
LD_LIBRARY_PATH= -L${LOCALBASE}/lib -L/usr/lib
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/science/kalzium/Makefile b/science/kalzium/Makefile
index cc822b138913..d24941353369 100644
--- a/science/kalzium/Makefile
+++ b/science/kalzium/Makefile
@@ -18,8 +18,7 @@ BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/eigen2.pc:${PORTSDIR}/math/eigen2
CONFLICTS= kdeedu-4.[0-6].*
-# Keep USE_GCC in sync with science/avogadro.
-USE_GCC= 4.4+
+USE_GCC= yes
USE_KDE4= kdehier kdelibs kdeprefix automoc4
USES= cmake:outsource
USE_OCAML= yes
diff --git a/science/meep/Makefile b/science/meep/Makefile
index 73ff7f5ef060..b4f3ffe9d96e 100644
--- a/science/meep/Makefile
+++ b/science/meep/Makefile
@@ -22,7 +22,7 @@ RUN_DEPENDS+= harminv:${PORTSDIR}/science/harminv
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_FORTRAN= yes
-USE_GCC= 4.6+
+USE_GCC= yes
USES= gettext iconv pathfix
USE_AUTOTOOLS+= libltdl
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/science/peekabot/Makefile b/science/peekabot/Makefile
index 0ea1afb923d1..1359127e884f 100644
--- a/science/peekabot/Makefile
+++ b/science/peekabot/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= boost_regex:${PORTSDIR}/devel/boost-libs \
USE_BZIP2= yes
USES= pathfix gmake
-USE_GCC= 4.6+
+USE_GCC= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes