aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-05-20 00:48:08 +0800
committerYuri Victorovich <yuri@FreeBSD.org>2019-05-20 00:48:08 +0800
commita60337fb4eab908c299d79f93d8fdc1f249a3c55 (patch)
tree6f649e419a10996da2a45c5532d6cb39e79ddc45 /science
parentd1c5d80eec2a573374600975e5eb683e0be52381 (diff)
downloadfreebsd-ports-gnome-a60337fb4eab908c299d79f93d8fdc1f249a3c55.tar.gz
freebsd-ports-gnome-a60337fb4eab908c299d79f93d8fdc1f249a3c55.tar.zst
freebsd-ports-gnome-a60337fb4eab908c299d79f93d8fdc1f249a3c55.zip
science/py-phono3py: Fix build on 12/13 (broken due to missing libgomp.so); Add USES=blaslapack:openblas
libgomp.so was found in gcc8, which this ports doesn't explicitly depend on, and openmp wasn't installed but the build was failing later on 12 due to the lack of libgomp.so. Solution: Move openmp dependency from LIB_DEPENDS to BUILD_DEPENDS/RUN_DEPENDS. Reported by: Gleb Popov <6yearold@gmail.com> (USES=blaslapack:openblas)
Diffstat (limited to 'science')
-rw-r--r--science/py-phono3py/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/science/py-phono3py/Makefile b/science/py-phono3py/Makefile
index 56208a39a660..ffa381dc5c1d 100644
--- a/science/py-phono3py/Makefile
+++ b/science/py-phono3py/Makefile
@@ -18,16 +18,16 @@ BUILD_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}phonopy>=1.13.2:science/py-phonopy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml@${PY_FLAVOR} \
- ${LOCALBASE}/include/lapacke.h:math/lapacke
-LIB_DEPENDS= libgomp.so:devel/openmp \
- libopenblas.so:math/openblas
+ ${LOCALBASE}/include/lapacke.h:math/lapacke \
+ openmp>0:devel/openmp
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}h5py>0:science/py-h5py@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}phonopy>=1.13.2:science/py-phonopy@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml@${PY_FLAVOR} \
+ openmp>0:devel/openmp
-USES= localbase python
+USES= blaslapack:openblas localbase python
USE_PYTHON= distutils cython autoplist
.include <bsd.port.mk>