aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2020-12-17 00:19:30 +0800
committerThierry Thomas <thierry@FreeBSD.org>2020-12-17 00:19:30 +0800
commita64c1df6e371e996fb3860b6c6a233cc9363249c (patch)
tree209eacdbc328b4c57836307aa3e6afbab52dac40 /science
parentf5e1e76364f4bd27f07836dfd09005beb7046426 (diff)
downloadfreebsd-ports-gnome-a64c1df6e371e996fb3860b6c6a233cc9363249c.tar.gz
freebsd-ports-gnome-a64c1df6e371e996fb3860b6c6a233cc9363249c.tar.zst
freebsd-ports-gnome-a64c1df6e371e996fb3860b6c6a233cc9363249c.zip
Rescue PETSc by upgrading to 3.14.1, and thus switch to Python 3.x.
Changelogs avilable at <https://www.mcs.anl.gov/petsc/documentation/changes/index.html>. PR: 249757 Submitted by: /me Reported by: swills@ Approved by: maintainerĀ“s time-out
Diffstat (limited to 'science')
-rw-r--r--science/PETSc/Makefile20
-rw-r--r--science/PETSc/distinfo6
-rw-r--r--science/PETSc/pkg-plist82
3 files changed, 92 insertions, 16 deletions
diff --git a/science/PETSc/Makefile b/science/PETSc/Makefile
index 207766ef16ca..3b74e3bfaf93 100644
--- a/science/PETSc/Makefile
+++ b/science/PETSc/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= PETSc
-DISTVERSION= 3.10.2
-PORTREVISION= 4
+PORTVERSION= 3.14.1
CATEGORIES= science devel
-MASTER_SITES= http://ftp.mcs.anl.gov/pub/petsc/release-snapshots/
+MASTER_SITES= https://ftp.mcs.anl.gov/pub/petsc/release-snapshots/
DISTNAME= ${PORTNAME:tl}-${DISTVERSION}
MAINTAINER= yuri@FreeBSD.org
@@ -14,19 +13,25 @@ COMMENT= Suite of data structures and routines from Argonne National Laboratory
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= cmake:devel/cmake
LIB_DEPENDS= libmpich.so:net/mpich
-USES= blaslapack fortran gmake python:2.7 shebangfix xorg
+USES= blaslapack fortran gmake python:3.7+ shebangfix xorg
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-shared-libraries=1 \
--with-mpi-dir=${LOCALBASE} \
+ --with-python=1 --with-python-pkg-config=${LOCALBASE}/libdata/pkgconfig \
+ FCFLAGS="${FCFLAGS}" FFLAGS="${FCFLAGS}" \
${CONFIGURE_ARGS_${ARCH}} CPPFLAGS="${CPPFLAGS}" \
- LDFLAGS="${LDFLAGS}" LIBS=""
+ AR=${AR} RANLIB=${RANLIB} \
+ MAKEFLAGS="${MAKEFLAGS}" LDFLAGS="${LDFLAGS}" LIBS=""
CONFIGURE_ARGS_amd64= CFLAGS="${CFLAGS} -msse2" CXXFLAGS="${CXXFLAGS} -msse2"
CONFIGURE_ARGS_i386= CFLAGS="${CFLAGS} -msse2" CXXFLAGS="${CXXFLAGS} -msse2"
+CONFIGURE_LOG= configure.log
USE_XORG= x11
MAKEFILE= makefile
-SHEBANG_FILES= lib/petsc/bin/*.py lib/petsc/bin/saws/SAWs.py lib/petsc/bin/saws/*.bash config/*.py
+SHEBANG_FILES= lib/petsc/bin/*.py lib/petsc/bin/saws/SAWs.py lib/petsc/bin/saws/*.bash config/*.py \
+ lib/petsc/bin/petscnagfor lib/petsc/bin/petsc-performance-view
USE_LDCONFIG= yes
TEST_TARGET= test
BINARY_ALIAS= python=${PYTHON_CMD}
@@ -36,6 +41,9 @@ LDFLAGS+= ${LOCALBASE}/lib/libmpi.so
DATADIR= ${PREFIX}/share/${PORTNAME:tl}
PLIST_SUB= SHLIB=${DISTVERSION} SHL=${DISTVERSION:C/\.[0-9]$//}
+pre-configure:
+ ${REINPLACE_CMD} -e 's|python3|${PYTHON_CMD}|' ${WRKSRC}/${CONFIGURE_SCRIPT}
+
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libpetsc.so.${DISTVERSION}
@${FIND} ${STAGEDIR}${PREFIX} -name "*.html" -delete
diff --git a/science/PETSc/distinfo b/science/PETSc/distinfo
index c4d4a888de70..b8e6e5490c5d 100644
--- a/science/PETSc/distinfo
+++ b/science/PETSc/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1540050650
-SHA256 (petsc-3.10.2.tar.gz) = 9d3381bcf9c63abe6521b21a88efc70f8e893293503cff497971d0d9c1ec68cc
-SIZE (petsc-3.10.2.tar.gz) = 31083036
+TIMESTAMP = 1606837215
+SHA256 (petsc-3.14.1.tar.gz) = dde246d97ca77e7e4165ff3c74e5517a2f08316cd8cb6d2c4e172743c1836ef8
+SIZE (petsc-3.14.1.tar.gz) = 37888585
diff --git a/science/PETSc/pkg-plist b/science/PETSc/pkg-plist
index fb528daa8626..9b67ede07e7d 100644
--- a/science/PETSc/pkg-plist
+++ b/science/PETSc/pkg-plist
@@ -1,3 +1,4 @@
+include/ftn-auto/petscloghf.c
include/petsc.h
include/petsc.mod
include/petsc/finclude/petsc.h
@@ -8,8 +9,8 @@ include/petsc/finclude/petscdmda.h
include/petsc/finclude/petscdmlabel.h
include/petsc/finclude/petscdmnetwork.h
include/petsc/finclude/petscdmplex.h
+include/petsc/finclude/petscdmswarm.h
include/petsc/finclude/petscdraw.h
-include/petsc/finclude/petscerror.h
include/petsc/finclude/petscis.h
include/petsc/finclude/petscksp.h
include/petsc/finclude/petsclog.h
@@ -24,6 +25,7 @@ include/petsc/finclude/petscvec.h
include/petsc/finclude/petscviewer.h
include/petsc/private/bagimpl.h
include/petsc/private/characteristicimpl.h
+include/petsc/private/cudavecimpl.h
include/petsc/private/dmadaptorimpl.h
include/petsc/private/dmdaimpl.h
include/petsc/private/dmfieldimpl.h
@@ -34,6 +36,8 @@ include/petsc/private/dmmbimpl.h
include/petsc/private/dmnetworkimpl.h
include/petsc/private/dmpatchimpl.h
include/petsc/private/dmpleximpl.h
+include/petsc/private/dmproductimpl.h
+include/petsc/private/dmstagimpl.h
include/petsc/private/dmswarmimpl.h
include/petsc/private/drawimpl.h
include/petsc/private/dtimpl.h
@@ -44,6 +48,7 @@ include/petsc/private/glvisviewerimpl.h
include/petsc/private/hashmap.h
include/petsc/private/hashmapi.h
include/petsc/private/hashmapij.h
+include/petsc/private/hashmapiv.h
include/petsc/private/hashset.h
include/petsc/private/hashseti.h
include/petsc/private/hashsetij.h
@@ -59,40 +64,50 @@ include/petsc/private/linesearchimpl.h
include/petsc/private/logimpl.h
include/petsc/private/matimpl.h
include/petsc/private/matorderimpl.h
+include/petsc/private/partitionerimpl.h
include/petsc/private/pcgamgimpl.h
include/petsc/private/pcimpl.h
include/petsc/private/pcmgimpl.h
include/petsc/private/pcpatchimpl.h
include/petsc/private/petscconvestimpl.h
include/petsc/private/petscdsimpl.h
+include/petsc/private/petscelemental.h
include/petsc/private/petscfeimpl.h
include/petsc/private/petscfptimpl.h
include/petsc/private/petscfvimpl.h
+include/petsc/private/petschpddm.h
+include/petsc/private/petschypre.h
include/petsc/private/petscimpl.h
+include/petsc/private/petscscalapack.h
+include/petsc/private/sectionimpl.h
include/petsc/private/sfimpl.h
include/petsc/private/snesimpl.h
include/petsc/private/taoimpl.h
include/petsc/private/taolinesearchimpl.h
+include/petsc/private/tshistoryimpl.h
include/petsc/private/tsimpl.h
include/petsc/private/vecimpl.h
include/petsc/private/vecscatterimpl.h
include/petsc/private/vieweradios2impl.h
include/petsc/private/vieweradiosimpl.h
+include/petsc/private/viewerexodusiiimpl.h
+include/petsc/private/viewerhdf5impl.h
include/petsc/private/viewerimpl.h
+include/petscaijdevice.h
include/petscao.h
include/petscao.mod
include/petscaodef.mod
include/petscbag.h
include/petscblaslapack.h
include/petscblaslapack_mangle.h
-include/petscblaslapack_stdcall.h
include/petscbt.h
include/petsccharacteristic.h
include/petscconf.h
include/petscconfiginfo.h
include/petscconvest.h
include/petscctable.h
-include/petsccuda.h
+include/petsccublas.h
+include/petsccxxcomplexfix.h
include/petscdef.mod
include/petscdm.h
include/petscdm.mod
@@ -121,10 +136,15 @@ include/petscdmpatchdef.mod
include/petscdmplex.h
include/petscdmplex.mod
include/petscdmplexdef.mod
+include/petscdmplextypes.h
+include/petscdmproduct.h
include/petscdmredundant.h
include/petscdmshell.h
include/petscdmsliced.h
+include/petscdmstag.h
include/petscdmswarm.h
+include/petscdmswarm.mod
+include/petscdmswarmdef.mod
include/petscdmtypes.h
include/petscdraw.h
include/petscdrawtypes.h
@@ -138,7 +158,6 @@ include/petscfetypes.h
include/petscfix.h
include/petscfv.h
include/petscfvtypes.h
-include/petscgll.h
include/petscis.h
include/petscis.mod
include/petscisdef.mod
@@ -148,6 +167,8 @@ include/petscksp.h
include/petscksp.mod
include/petsckspdef.mod
include/petsckspdefdummy.mod
+include/petsclandau.h
+include/petsclayouthdf5.h
include/petsclog.h
include/petscmachineinfo.h
include/petscmat.h
@@ -160,12 +181,16 @@ include/petscmath.h
include/petscmathypre.h
include/petscmatlab.h
include/petscoptions.h
+include/petscpartitioner.h
include/petscpc.h
include/petscpc.mod
include/petscpcdef.mod
include/petscpcdefdummy.mod
include/petscpctypes.h
include/petscpf.h
+include/petscpkg_version.h
+include/petscsection.h
+include/petscsectiontypes.h
include/petscsf.h
include/petscsftypes.h
include/petscsnes.h
@@ -176,6 +201,7 @@ include/petscsys.h
include/petscsys.mod
include/petscsysdef.mod
include/petscsysdefdummy.mod
+include/petscsystypes.h
include/petsctao.h
include/petsctao.mod
include/petsctaodef.mod
@@ -187,12 +213,14 @@ include/petsctsdef.mod
include/petsctsdefdummy.mod
include/petscvalgrind.h
include/petscvec.h
+include/petscvec.hpp
include/petscvec.mod
include/petscvecdef.mod
include/petscvecdefdummy.mod
include/petscversion.h
include/petscviennacl.h
include/petscviewer.h
+include/petscviewerexodusii.h
include/petscviewerhdf5.h
include/petscviewersaws.h
include/petscviewertypes.h
@@ -203,17 +231,24 @@ lib/libpetsc.so.%%SHLIB%%
lib/petsc/bin/PetscBinaryIO.py
lib/petsc/bin/PetscBinaryIOTrajectory.py
lib/petsc/bin/PetscBinaryIO_tests.py
+lib/petsc/bin/configureTAS.py
+lib/petsc/bin/extract.py
+lib/petsc/bin/petsc-performance-view
lib/petsc/bin/petsc_conf.py
lib/petsc/bin/petsc_gen_xdmf.py
+lib/petsc/bin/petsc_tas_analysis.py
+lib/petsc/bin/petsc_tas_style.mplstyle
lib/petsc/bin/petscdiff
lib/petsc/bin/petsclogformat.py
lib/petsc/bin/petscmpiexec
+lib/petsc/bin/petscnagfor
lib/petsc/bin/petscnagupgrade.py
lib/petsc/bin/saws/SAWs.py
lib/petsc/bin/saws/getSAWs.bash
lib/petsc/bin/saws/getStack.bash
lib/petsc/bin/taucc.py
-lib/petsc/conf/PETScBuildInternal.cmake
+lib/petsc/conf/configure-hash
+lib/petsc/conf/memoryerror.log
lib/petsc/conf/modules/petsc/%%SHLIB%%
lib/petsc/conf/petscrules
lib/petsc/conf/petscvariables
@@ -223,11 +258,15 @@ lib/petsc/conf/test
lib/petsc/conf/test.common
lib/petsc/conf/variables
libdata/pkgconfig/PETSc.pc
+libdata/pkgconfig/petsc.pc
+%%DATADIR%%/Makefile.user
+%%DATADIR%%/datafiles/matrices/LFAT5.mtx
%%DATADIR%%/datafiles/matrices/amesos2_test_mat0.mtx
%%DATADIR%%/datafiles/matrices/hpd-complex-int32-float32
%%DATADIR%%/datafiles/matrices/hpd-complex-int32-float64
%%DATADIR%%/datafiles/matrices/hpd-complex-int64-float32
%%DATADIR%%/datafiles/matrices/hpd-complex-int64-float64
+%%DATADIR%%/datafiles/matrices/m_05_05_crk.mtx
%%DATADIR%%/datafiles/matrices/nh-complex-int32-float32
%%DATADIR%%/datafiles/matrices/nh-complex-int32-float64
%%DATADIR%%/datafiles/matrices/nh-complex-int64-float32
@@ -243,6 +282,8 @@ libdata/pkgconfig/PETSc.pc
%%DATADIR%%/datafiles/matrices/spd-real-int64-float64
%%DATADIR%%/datafiles/matrices/tiny_system
%%DATADIR%%/datafiles/matrices/tiny_system_with_x0
+%%DATADIR%%/datafiles/matrices/tiny_system_with_x0.mat
+%%DATADIR%%/datafiles/matrices/tiny_system_with_x0_complex.mat
%%DATADIR%%/datafiles/matrices/tiny_system_x0
%%DATADIR%%/datafiles/meshes/2Dgrd.exo
%%DATADIR%%/datafiles/meshes/FourBrickHex-large.exo
@@ -253,20 +294,45 @@ libdata/pkgconfig/PETSc.pc
%%DATADIR%%/datafiles/meshes/Rect-tri3.exo
%%DATADIR%%/datafiles/meshes/TwoQuads.exo
%%DATADIR%%/datafiles/meshes/annulus-20.exo
+%%DATADIR%%/datafiles/meshes/barycentricallyrefinedcube.h5
%%DATADIR%%/datafiles/meshes/blockcylinder-50.exo
%%DATADIR%%/datafiles/meshes/blockcylinder-50.h5
%%DATADIR%%/datafiles/meshes/blockcylinder-50.xmf
%%DATADIR%%/datafiles/meshes/cow.msh
%%DATADIR%%/datafiles/meshes/cube_5tets.cas
%%DATADIR%%/datafiles/meshes/cube_5tets_ascii.cas
-%%DATADIR%%/datafiles/meshes/cube_periodic.msh
-%%DATADIR%%/datafiles/meshes/cube_periodic_bin.msh
%%DATADIR%%/datafiles/meshes/cylinder.med
%%DATADIR%%/datafiles/meshes/doublet-tet.msh
+%%DATADIR%%/datafiles/meshes/gmsh-3d-ascii-32.msh
+%%DATADIR%%/datafiles/meshes/gmsh-3d-ascii-64.msh
+%%DATADIR%%/datafiles/meshes/gmsh-3d-ascii.msh2
+%%DATADIR%%/datafiles/meshes/gmsh-3d-ascii.msh4
+%%DATADIR%%/datafiles/meshes/gmsh-3d-binary-32.msh
+%%DATADIR%%/datafiles/meshes/gmsh-3d-binary-64.msh
+%%DATADIR%%/datafiles/meshes/gmsh-3d-binary.msh2
+%%DATADIR%%/datafiles/meshes/gmsh-3d-binary.msh4
+%%DATADIR%%/datafiles/meshes/gmsh-3d.geo
+%%DATADIR%%/datafiles/meshes/gmsh-B2qua.geo
+%%DATADIR%%/datafiles/meshes/gmsh-B2tri.geo
+%%DATADIR%%/datafiles/meshes/gmsh-B3hex.geo
+%%DATADIR%%/datafiles/meshes/gmsh-B3tet.geo
+%%DATADIR%%/datafiles/meshes/gmsh-hex.geo
+%%DATADIR%%/datafiles/meshes/gmsh-qua.geo
+%%DATADIR%%/datafiles/meshes/gmsh-seg.geo
+%%DATADIR%%/datafiles/meshes/gmsh-tet.geo
+%%DATADIR%%/datafiles/meshes/gmsh-tri.geo
+%%DATADIR%%/datafiles/meshes/gmsh-vtx.geo
+%%DATADIR%%/datafiles/meshes/gmsh-wed.geo
%%DATADIR%%/datafiles/meshes/grid_c.cgns
%%DATADIR%%/datafiles/meshes/horse.ply.bz2
+%%DATADIR%%/datafiles/meshes/hybrid_3d_cube.msh
+%%DATADIR%%/datafiles/meshes/hybrid_hexwedge.exo
+%%DATADIR%%/datafiles/meshes/hybrid_hexwedge.msh
%%DATADIR%%/datafiles/meshes/hybrid_tetwedge.msh
%%DATADIR%%/datafiles/meshes/hybrid_triquad.msh
+%%DATADIR%%/datafiles/meshes/mesh-3d-box-innersphere.msh
+%%DATADIR%%/datafiles/meshes/mesh-3d-box-innersphere_bin.msh
+%%DATADIR%%/datafiles/meshes/nozzle.egadslite
%%DATADIR%%/datafiles/meshes/sevenside-quad-15.exo
%%DATADIR%%/datafiles/meshes/sevenside-quad.exo
%%DATADIR%%/datafiles/meshes/sevenside.exo
@@ -283,6 +349,7 @@ libdata/pkgconfig/PETSc.pc
%%DATADIR%%/datafiles/meshes/surfacesphere_bin.msh
%%DATADIR%%/datafiles/meshes/texas.msh
%%DATADIR%%/datafiles/meshes/tut21.cgns
+%%DATADIR%%/datafiles/meshes/unit_sphere.egadslite
%%DATADIR%%/matlab/@PetscOpenFile/PetscOpenFile.m
%%DATADIR%%/matlab/@PetscOpenFile/close.m
%%DATADIR%%/matlab/@PetscOpenFile/read.m
@@ -322,3 +389,4 @@ libdata/pkgconfig/PETSc.pc
%%DATADIR%%/saws/js/utils.js
%%DATADIR%%/saws/readme
%%DATADIR%%/xml/performance_xml2html.xsl
+@dir lib/petsc/bin/__pycache__