aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2014-09-03 03:00:27 +0800
committermva <mva@FreeBSD.org>2014-09-03 03:00:27 +0800
commita7fbec902b1821221716b11580719f15bfa0db5f (patch)
treedbfb96cc16f7a4579e34f08d10ae68da0f86188c /science
parentcf98d06976534ff64f8e97cbebcf2974bba8f447 (diff)
downloadfreebsd-ports-gnome-a7fbec902b1821221716b11580719f15bfa0db5f.tar.gz
freebsd-ports-gnome-a7fbec902b1821221716b11580719f15bfa0db5f.tar.zst
freebsd-ports-gnome-a7fbec902b1821221716b11580719f15bfa0db5f.zip
- Enable concurrent installation support for different python versions
- Remove LATEST_LINK and the usage of math/py-numpy's options - both do not seem to have any value for the port PR: 192893 Submitted by: myself Approved by: wen@ (maintainer)
Diffstat (limited to 'science')
-rw-r--r--science/py-scipy/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/science/py-scipy/Makefile b/science/py-scipy/Makefile
index 33136a0a9455..307e7a9fe15f 100644
--- a/science/py-scipy/Makefile
+++ b/science/py-scipy/Makefile
@@ -3,7 +3,7 @@
PORTNAME= scipy
PORTVERSION= 0.14.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science python
MASTER_SITES= http://docs.scipy.org/doc/${DISTNAME}/:doc \
SF:source
@@ -23,11 +23,8 @@ LIB_DEPENDS= libfftw3.so:${PORTSDIR}/math/fftw3
RUN_DEPENDS= ${PYNUMPY} \
nosetests:${PORTSDIR}/devel/py-nose
-LATEST_LINK= py-${PORTNAME}
-OPTIONSFILE= ${PORT_DBDIR}/py-numpy/options
-
USES= fortran python
-USE_PYTHON= distutils autoplist
+USE_PYTHON= distutils autoplist concurrent
OPTIONS_DEFINE= ATLAS DOCS SUITESPARSE
OPTIONS_DEFAULT=SUITESPARSE