aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorbofh <bofh@FreeBSD.org>2016-04-11 05:01:55 +0800
committerbofh <bofh@FreeBSD.org>2016-04-11 05:01:55 +0800
commitacf949871f51d54f4d2bef576ec3b01693d2c2ed (patch)
tree1603f87ab7360f4523381e49b2f652300676f02b /science
parentaa6284182e8fa9e1f62f3632446aeea15215a8ad (diff)
downloadfreebsd-ports-gnome-acf949871f51d54f4d2bef576ec3b01693d2c2ed.tar.gz
freebsd-ports-gnome-acf949871f51d54f4d2bef576ec3b01693d2c2ed.tar.zst
freebsd-ports-gnome-acf949871f51d54f4d2bef576ec3b01693d2c2ed.zip
science/clhep: Update version 2.2.0.8=>2.3.1.1
- Add conditional compiler type c++11-lib for 9.X and openmp for 10.X+
Diffstat (limited to 'science')
-rw-r--r--science/clhep/Makefile10
-rw-r--r--science/clhep/distinfo4
-rw-r--r--science/clhep/pkg-plist14
3 files changed, 24 insertions, 4 deletions
diff --git a/science/clhep/Makefile b/science/clhep/Makefile
index 997f7513a9dc..f9be1bbfe4cf 100644
--- a/science/clhep/Makefile
+++ b/science/clhep/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= clhep
-PORTVERSION= 2.2.0.8
+PORTVERSION= 2.3.1.1
CATEGORIES= science
MASTER_SITES= http://proj-clhep.web.cern.ch/proj-clhep/DISTRIBUTION/tarFiles/
@@ -20,6 +20,14 @@ USE_LDCONFIG= yes
PLIST_SUB= VERSION="${PORTVERSION}"
+.include <bsd.port.options.mk>
+
+.if ${OSVERSION} < 1000000
+USES+= compiler:c++11-lib
+.else
+USES+= compiler:openmp
+.endif
+
post-patch:
@${REINPLACE_CMD} -e \
'/DESTINATION/s|lib$${LIB_SUFFIX}|libdata|' \
diff --git a/science/clhep/distinfo b/science/clhep/distinfo
index d04d445efaec..d34651101442 100644
--- a/science/clhep/distinfo
+++ b/science/clhep/distinfo
@@ -1,2 +1,2 @@
-SHA256 (clhep-2.2.0.8.tgz) = 60271575d6dd481095b96a348ff76b58a26d0b065b3c032caa983249e891e738
-SIZE (clhep-2.2.0.8.tgz) = 1847332
+SHA256 (clhep-2.3.1.1.tgz) = 0e2b170df99176feb0aa4f20ea3b33463193c086682749790c5b9b79388d0ff4
+SIZE (clhep-2.3.1.1.tgz) = 1500859
diff --git a/science/clhep/pkg-plist b/science/clhep/pkg-plist
index 98308331487e..ff42a62e0c94 100644
--- a/science/clhep/pkg-plist
+++ b/science/clhep/pkg-plist
@@ -193,6 +193,7 @@ include/CLHEP/Random/EngineFactory.h
include/CLHEP/Random/Hurd160Engine.h
include/CLHEP/Random/Hurd288Engine.h
include/CLHEP/Random/JamesRandom.h
+include/CLHEP/Random/MixMaxRng.h
include/CLHEP/Random/MTwistEngine.h
include/CLHEP/Random/NonRandomEngine.h
include/CLHEP/Random/RandBinomial.h
@@ -248,6 +249,8 @@ include/CLHEP/Random/StaticRandomStates.h
include/CLHEP/Random/TripleRand.h
include/CLHEP/Random/defs.h
include/CLHEP/Random/engineIDulong.h
+include/CLHEP/Random/mixmax.h
+include/CLHEP/Random/mixmax_skip_N256.icc
include/CLHEP/RandomObjects/RandMultiGauss.h
include/CLHEP/RandomObjects/RandomVector.h
include/CLHEP/RandomObjects/RandomVector.icc
@@ -268,7 +271,6 @@ include/CLHEP/Utility/keywords.h
include/CLHEP/Utility/memory.h
include/CLHEP/Utility/noncopyable.h
include/CLHEP/Utility/thread_local.h
-include/CLHEP/Utility/type_traits.h
include/CLHEP/Vector/AxisAngle.h
include/CLHEP/Vector/AxisAngle.icc
include/CLHEP/Vector/Boost.h
@@ -331,3 +333,13 @@ libdata/CLHEP-%%VERSION%%/CLHEPConfigVersion.cmake
libdata/CLHEP-%%VERSION%%/CLHEPLibraryDepends-%%CMAKE_BUILD_TYPE%%.cmake
libdata/CLHEP-%%VERSION%%/CLHEPLibraryDepends.cmake
libdata/pkgconfig/clhep.pc
+libdata/pkgconfig/clhep-cast.pc
+libdata/pkgconfig/clhep-evaluator.pc
+libdata/pkgconfig/clhep-exceptions.pc
+libdata/pkgconfig/clhep-genericfunctions.pc
+libdata/pkgconfig/clhep-geometry.pc
+libdata/pkgconfig/clhep-matrix.pc
+libdata/pkgconfig/clhep-random.pc
+libdata/pkgconfig/clhep-randomobjects.pc
+libdata/pkgconfig/clhep-refcount.pc
+libdata/pkgconfig/clhep-vector.pc