aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2017-05-02 13:26:40 +0800
committertcberner <tcberner@FreeBSD.org>2017-05-02 13:26:40 +0800
commitb2aa99496811f78484793ed0ffaf0d1bdd796d03 (patch)
tree3011639bcd64afa0e9b4dea9964e5ffbc5889570 /science
parent3f7bd0f8c2785b7c0a9c3b620311e01d604cce07 (diff)
downloadfreebsd-ports-gnome-b2aa99496811f78484793ed0ffaf0d1bdd796d03.tar.gz
freebsd-ports-gnome-b2aa99496811f78484793ed0ffaf0d1bdd796d03.tar.zst
freebsd-ports-gnome-b2aa99496811f78484793ed0ffaf0d1bdd796d03.zip
Update math/gsl to 2.3
This release introduces some new features and fixes several bugs: http://savannah.gnu.org/forum/forum.php?forum_id=8751 * update to 2.3 and take maintainership * update math/py-gsl to 2.2.0 for gsl2 support * update math/rubygem-rb-gsl to 2.1.0.2 for gsl2 support PR: 218952 Exp-run by: antoine Reviewed by: mat, rakuco Approved by: rakuco (mentor) Differential Revision: https://reviews.freebsd.org/D10522
Diffstat (limited to 'science')
-rw-r--r--science/afni/Makefile2
-rw-r--r--science/fisicalab/Makefile2
-rw-r--r--science/getdp/Makefile2
-rw-r--r--science/gnudatalanguage/Makefile2
-rw-r--r--science/kst2/Makefile1
-rw-r--r--science/kst2/files/patch-git_a9d24f9106
-rw-r--r--science/py-mlpy/Makefile2
-rw-r--r--science/step/Makefile2
8 files changed, 113 insertions, 6 deletions
diff --git a/science/afni/Makefile b/science/afni/Makefile
index cabb4159c8bc..3c40a38ea228 100644
--- a/science/afni/Makefile
+++ b/science/afni/Makefile
@@ -11,7 +11,7 @@
PORTNAME= afni
PORTVERSION= 2015.11.13
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science biology graphics
MASTER_SITES= http://www.acadix.biz/Ports/distfiles/
diff --git a/science/fisicalab/Makefile b/science/fisicalab/Makefile
index 4dfdf9cdc06c..c90708a04f46 100644
--- a/science/fisicalab/Makefile
+++ b/science/fisicalab/Makefile
@@ -2,7 +2,7 @@
PORTNAME= fisicalab
PORTVERSION= 0.3.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= science gnustep
MASTER_SITES= SAVANNAH
diff --git a/science/getdp/Makefile b/science/getdp/Makefile
index 34822ea44ba9..00396b5590c3 100644
--- a/science/getdp/Makefile
+++ b/science/getdp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= getdp
PORTVERSION= 2.8.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= science
MASTER_SITES= http://www.geuz.org/getdp/src/
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
diff --git a/science/gnudatalanguage/Makefile b/science/gnudatalanguage/Makefile
index 10b86c1739d6..9d14cd33f953 100644
--- a/science/gnudatalanguage/Makefile
+++ b/science/gnudatalanguage/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gnudatalanguage
DISTVERSION= 0.9.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science lang
MASTER_SITES= SF/${PORTNAME}/gdl/${PORTVERSION}
.if defined(BUILD_PYTHON_MODULE)
diff --git a/science/kst2/Makefile b/science/kst2/Makefile
index a5fda2435859..b2596e5432e9 100644
--- a/science/kst2/Makefile
+++ b/science/kst2/Makefile
@@ -3,6 +3,7 @@
PORTNAME= kst
DISTVERSION= 2.0.8
+PORTREVISION= 1
CATEGORIES= science kde
MASTER_SITES= SF/${PORTNAME}/Kst%20${DISTVERSION:C/-r.*//}/
DISTNAME= Kst-${DISTVERSION}
diff --git a/science/kst2/files/patch-git_a9d24f9 b/science/kst2/files/patch-git_a9d24f9
new file mode 100644
index 000000000000..3dd6306cb73b
--- /dev/null
+++ b/science/kst2/files/patch-git_a9d24f9
@@ -0,0 +1,106 @@
+Backport of:
+https://github.com/Kst-plot/kst/commit/a9d24f91057441bbd2e3ed9e7536b071121526cb
+
+From a9d24f91057441bbd2e3ed9e7536b071121526cb Mon Sep 17 00:00:00 2001
+From: "D. V. Wiebe" <dvw@ketiltrout.net>
+Date: Thu, 10 Mar 2016 14:09:26 -0800
+Subject: [PATCH] GSL-2.x support.
+
+
+--- src/plugins/fits/non_linear.h.orig 2014-02-13 09:41:44 UTC
++++ src/plugins/fits/non_linear.h
+@@ -18,6 +18,7 @@
+ #include <gsl/gsl_blas.h>
+ #include <gsl/gsl_multifit_nlin.h>
+ #include <gsl/gsl_statistics.h>
++#include <gsl/gsl_version.h>
+ #include "common.h"
+
+ struct data {
+@@ -100,6 +101,7 @@ bool kstfit_nonlinear(
+ gsl_multifit_function_fdf function;
+ gsl_vector_view vectorViewInitial;
+ gsl_matrix* pMatrixCovariance;
++ gsl_matrix* pMatrixJacobian;
+ struct data d;
+ double dXInitial[NUM_PARAMS];
+ double* pInputX;
+@@ -177,7 +179,16 @@ bool kstfit_nonlinear(
+ }
+ iIterations++;
+ } while( iStatus == GSL_CONTINUE && iIterations < MAX_NUM_ITERATIONS );
+- gsl_multifit_covar( pSolver->J, 0.0, pMatrixCovariance );
++#if GSL_MAJOR_VERSION >= 2
++ pMatrixJacobian = gsl_matrix_alloc( iLength, NUM_PARAMS );
++#else
++ pMatrixJacobian = pSolver->J;
++#endif
++ if ( pMatrixJacobian != NULL ) {
++#if GSL_MAJOR_VERSION >= 2
++ gsl_multifit_fdfsolver_jac( pSolver, pMatrixJacobian );
++#endif
++ gsl_multifit_covar( pMatrixJacobian, 0.0, pMatrixCovariance );
+
+ //
+ // determine the fitted values...
+@@ -207,7 +218,10 @@ bool kstfit_nonlinear(
+ scalarOutChi->setValue(gsl_blas_dnrm2( pSolver->f ));
+
+ bReturn = true;
+-
++#if GSL_MAJOR_VERSION >= 2
++ gsl_matrix_free( pMatrixJacobian );
++#endif
++ }
+ gsl_matrix_free( pMatrixCovariance );
+ }
+ gsl_multifit_fdfsolver_free( pSolver );
+--- src/plugins/fits/non_linear_weighted.h.orig 2014-02-13 09:41:44 UTC
++++ src/plugins/fits/non_linear_weighted.h
+@@ -18,6 +18,7 @@
+ #include <gsl/gsl_blas.h>
+ #include <gsl/gsl_multifit_nlin.h>
+ #include <gsl/gsl_statistics.h>
++#include <gsl/gsl_version.h>
+ #include "common.h"
+
+ struct data {
+@@ -101,6 +102,7 @@ bool kstfit_nonlinear_weighted(
+ gsl_multifit_function_fdf function;
+ gsl_vector_view vectorViewInitial;
+ gsl_matrix* pMatrixCovariance;
++ gsl_matrix* pMatrixJacobian;
+ struct data d;
+ double dXInitial[NUM_PARAMS];
+ double* pInputs[3];
+@@ -193,7 +195,17 @@ bool kstfit_nonlinear_weighted(
+ }
+ while( iStatus == GSL_CONTINUE && iIterations < MAX_NUM_ITERATIONS );
+
+- gsl_multifit_covar( pSolver->J, 0.0, pMatrixCovariance );
++#if GSL_MAJOR_VERSION >= 2
++ pMatrixJacobian = gsl_matrix_alloc( iLength, NUM_PARAMS );
++#else
++ pMatrixJacobian = pSolver->J;
++#endif
++
++ if ( pMatrixJacobian != NULL ) {
++#if GSL_MAJOR_VERSION >= 2
++ gsl_multifit_fdfsolver_jac( pSolver, pMatrixJacobian );
++#endif
++ gsl_multifit_covar( pMatrixJacobian, 0.0, pMatrixCovariance );
+
+ //
+ // determine the fitted values...
+@@ -223,7 +235,10 @@ bool kstfit_nonlinear_weighted(
+ scalarOutChi->setValue(gsl_blas_dnrm2( pSolver->f ));
+
+ bReturn = true;
+-
++#if GSL_VERSION_MAJOR >= 2
++ gsl_matrix_free( pMatrixJacobian );
++#endif
++ }
+ gsl_matrix_free( pMatrixCovariance );
+ }
+ gsl_multifit_fdfsolver_free( pSolver );
diff --git a/science/py-mlpy/Makefile b/science/py-mlpy/Makefile
index dc362ead1933..7f394aa865f2 100644
--- a/science/py-mlpy/Makefile
+++ b/science/py-mlpy/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mlpy
PORTVERSION= 3.5.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= science python
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20${PORTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/science/step/Makefile b/science/step/Makefile
index 5ad4662abb85..d648914cc747 100644
--- a/science/step/Makefile
+++ b/science/step/Makefile
@@ -2,7 +2,7 @@
PORTNAME= step
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= science kde kde-kde4
MAINTAINER= kde@FreeBSD.org