aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2014-11-07 19:42:30 +0800
committermakc <makc@FreeBSD.org>2014-11-07 19:42:30 +0800
commitca70d91524a2bec25bd6fb4431f76372211123c7 (patch)
tree209fc3bc1e96950b0f27daf60727e7234e0d1abd /science
parented2eb5a0efdf5182ce6d64a2b626446a3aa63f89 (diff)
downloadfreebsd-ports-gnome-ca70d91524a2bec25bd6fb4431f76372211123c7.tar.gz
freebsd-ports-gnome-ca70d91524a2bec25bd6fb4431f76372211123c7.tar.zst
freebsd-ports-gnome-ca70d91524a2bec25bd6fb4431f76372211123c7.zip
science/kst2:
- Update to 2.0.8 - Remove now needless patches - Add option for building with Qt 5
Diffstat (limited to 'science')
-rw-r--r--science/kst2/Makefile19
-rw-r--r--science/kst2/distinfo4
-rw-r--r--science/kst2/files/patch-CMakeLists.txt26
-rw-r--r--science/kst2/files/patch-cmake__CMakeLists.txt63
-rw-r--r--science/kst2/files/patch-src__datasources__ascii__kst_atof.cpp10
-rw-r--r--science/kst2/files/patch-src__kst__CMakeLists.txt (renamed from science/kst2/files/patch-cmake__src__kst__CMakeLists.txt)8
-rw-r--r--science/kst2/files/patch-src__libkst__ksttimezone.h10
-rw-r--r--science/kst2/files/patch-src__libkstapp__logdialog.h10
-rw-r--r--science/kst2/pkg-plist32
9 files changed, 61 insertions, 121 deletions
diff --git a/science/kst2/Makefile b/science/kst2/Makefile
index ad06f237d17a..8ce7b02f3a73 100644
--- a/science/kst2/Makefile
+++ b/science/kst2/Makefile
@@ -2,28 +2,32 @@
# $FreeBSD$
PORTNAME= kst
-DISTVERSION= 2.0.6
-PORTREVISION= 7
+DISTVERSION= 2.0.8
CATEGORIES= science kde
MASTER_SITES= SF/${PORTNAME}/Kst%20${DISTVERSION:C/-r.*//}/
+DISTNAME= Kst-${DISTVERSION}
MAINTAINER= makc@FreeBSD.org
COMMENT= Data viewing and plotting tool
LIB_DEPENDS= libgsl.so:${PORTSDIR}/math/gsl
-USES= cmake pkgconfig
-USE_QT4= gui xml designer svg opengl \
+USES= cmake:outsource pkgconfig
+_USE_QT4= gui xml designer svg linguist_build \
qmake_build moc_build rcc_build uic_build
+_USE_QT5= concurrent network printsupport widgets xml \
+ buildtools_build linguisttools_build qmake_build
USE_LDCONFIG= yes
-CMAKE_SOURCE_PATH= ${WRKSRC}/cmake
CMAKE_ARGS+= -Dkst_install_prefix=${PREFIX} \
-Dkst_pch=off
PLIST_SUB= SHLIB_VER=${PORTVERSION}
OPTIONS_DEFINE= FITS MATLAB NETCDF
+OPTIONS_SINGLE= TOOLKIT
+OPTIONS_SINGLE_TOOLKIT= QT4 QT5
+OPTIONS_DEFAULT= QT4
OPTIONS_SUB= yes
FITS_DESC= Support for data in FITS format
@@ -35,6 +39,11 @@ MATLAB_LIB_DEPENDS= libmatio.so:${PORTSDIR}/math/matio
NETCDF_DESC= Support for data in NetCDF format
NETCDF_LIB_DEPENDS= libnetcdf.so:${PORTSDIR}/science/netcdf
+TOOLKIT_DESC= Qt toolkit
+QT4_USE= ${_USE_QT4:S/^/QT4=/}
+QT5_USE= ${_USE_QT5:S/^/QT5=/}
+QT5_CMAKE_ON= -Dkst_qt5=on
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/science/kst2/distinfo b/science/kst2/distinfo
index dfb2ff6891e8..817d71a841d1 100644
--- a/science/kst2/distinfo
+++ b/science/kst2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (kst-2.0.6.tar.gz) = 7968e604a188065d02da48a9a971fb04afab4b4b5358315b09e66f3deab1b80f
-SIZE (kst-2.0.6.tar.gz) = 11388226
+SHA256 (Kst-2.0.8.tar.gz) = cefbfd3e3710771985e08f02a397ef8ab407168fa8415d2c3c5740c031af18c6
+SIZE (Kst-2.0.8.tar.gz) = 14527129
diff --git a/science/kst2/files/patch-CMakeLists.txt b/science/kst2/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..9ec0ca48bf14
--- /dev/null
+++ b/science/kst2/files/patch-CMakeLists.txt
@@ -0,0 +1,26 @@
+--- CMakeLists.txt.orig 2014-07-20 09:38:16 UTC
++++ CMakeLists.txt
+@@ -64,11 +64,6 @@
+ project(Kst)
+
+
+-if(kst_release)
+- set(CMAKE_BUILD_TYPE Release CACHE STRING "Build type" FORCE)
+-else()
+- set(CMAKE_BUILD_TYPE Debug CACHE STRING "Build type" FORCE)
+-endif()
+
+
+ if(kst_sanitize)
+@@ -226,11 +219,6 @@
+ # React on options
+
+
+-if(kst_verbose)
+- set(CMAKE_VERBOSE_MAKEFILE 1)
+-else()
+- set(CMAKE_VERBOSE_MAKEFILE 0)
+-endif()
+
+ if(kst_install_prefix)
+ set(CMAKE_INSTALL_PREFIX ${kst_install_prefix} CACHE PATH "User's choice for install prefix" FORCE)
diff --git a/science/kst2/files/patch-cmake__CMakeLists.txt b/science/kst2/files/patch-cmake__CMakeLists.txt
deleted file mode 100644
index 6a9952916306..000000000000
--- a/science/kst2/files/patch-cmake__CMakeLists.txt
+++ /dev/null
@@ -1,63 +0,0 @@
---- ./cmake/CMakeLists.txt.orig 2012-05-11 22:16:54.000000000 +0000
-+++ ./cmake/CMakeLists.txt 2012-05-13 16:13:25.632207723 +0000
-@@ -41,19 +41,12 @@
- message(STATUS)
-
-
--if(kst_release)
-- set(CMAKE_BUILD_TYPE Release)
--else()
-- set(CMAKE_BUILD_TYPE Debug)
--endif()
--
--
- set(kst_version_major 2)
- if(kst_version_string)
- set(kst_version ${kst_version_string})
- else()
- set(kst_version_minor 0)
-- set(kst_version_patch x)
-+ set(kst_version_patch 6)
- set(kst_version ${kst_version_major}.${kst_version_minor}.${kst_version_patch})
- endif()
-
-@@ -133,11 +126,6 @@
- # React on options
-
-
--if(kst_verbose)
-- set(CMAKE_VERBOSE_MAKEFILE 1)
--else()
-- set(CMAKE_VERBOSE_MAKEFILE 0)
--endif()
-
- if(kst_install_prefix)
- set(CMAKE_INSTALL_PREFIX ${kst_install_prefix} CACHE PATH "User's choice for install prefix" FORCE)
-@@ -161,7 +149,7 @@
- endif()
-
- #path to install the .desktop files
--set(kst_install_plugin_desktop_file_path share/services/kst)
-+set(kst_install_plugin_desktop_file_path share/services/kst2)
-
-
-
-@@ -210,7 +198,9 @@
-
- configure_file(${kst_dir}/cmake/config.h.cmake ${CMAKE_BINARY_DIR}/config.h)
-
--include_directories(${CMAKE_BINARY_DIR} ${QT_INCLUDES})
-+find_package(OpenGL)
-+
-+include_directories(${CMAKE_BINARY_DIR} ${QT_INCLUDES} ${OPENGL_INCLUDE_DIR})
-
- message(STATUS "Build summary----------------------------------")
- message(STATUS)
-@@ -236,7 +226,6 @@
- endif()
-
- if (NOT APPLE)
-- add_subdirectory(misc)
- endif()
-
- if(kst_python)
diff --git a/science/kst2/files/patch-src__datasources__ascii__kst_atof.cpp b/science/kst2/files/patch-src__datasources__ascii__kst_atof.cpp
deleted file mode 100644
index 986338370d29..000000000000
--- a/science/kst2/files/patch-src__datasources__ascii__kst_atof.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./src/datasources/ascii/kst_atof.cpp.orig 2012-07-22 13:24:59.000000000 +0000
-+++ ./src/datasources/ascii/kst_atof.cpp 2013-12-09 13:59:43.253923430 +0000
-@@ -8,6 +8,7 @@
- #include <ctype.h>
-
- #include <QLocale>
-+#include <locale.h>
-
-
- #define LOGHUGE 39
diff --git a/science/kst2/files/patch-cmake__src__kst__CMakeLists.txt b/science/kst2/files/patch-src__kst__CMakeLists.txt
index 7b29aa86d2dc..15746d4974b7 100644
--- a/science/kst2/files/patch-cmake__src__kst__CMakeLists.txt
+++ b/science/kst2/files/patch-src__kst__CMakeLists.txt
@@ -1,6 +1,6 @@
---- ./cmake/src/kst/CMakeLists.txt.orig 2012-08-05 15:16:15.233405189 +0000
-+++ ./cmake/src/kst/CMakeLists.txt 2012-08-05 15:17:39.675406925 +0000
-@@ -38,9 +38,7 @@
+--- src/kst/CMakeLists.txt.orig 2014-04-07 16:11:03 UTC
++++ src/kst/CMakeLists.txt
+@@ -37,9 +37,7 @@
if(UNIX AND NOT APPLE)
set(man ${CMAKE_BINARY_DIR}/${kst_binary_name}.1)
configure_file(${kst_dir}/src/kst/kst.1.txt ${man})
@@ -11,7 +11,7 @@
set(k ${kst_dir}/src/kst)
# install(FILES ${k}/kstplugin.desktop
-@@ -50,8 +48,7 @@
+@@ -49,8 +47,7 @@
# ${k}/kstfilter.desktop
# ${k}/kstextension.desktop
# DESTINATION share/servicetypes/kst)
diff --git a/science/kst2/files/patch-src__libkst__ksttimezone.h b/science/kst2/files/patch-src__libkst__ksttimezone.h
deleted file mode 100644
index 3c399b2b0711..000000000000
--- a/science/kst2/files/patch-src__libkst__ksttimezone.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./src/libkst/ksttimezone.h.orig 2012-07-22 13:24:59.000000000 +0000
-+++ ./src/libkst/ksttimezone.h 2013-12-07 17:57:37.647544068 +0000
-@@ -16,6 +16,7 @@
- #include "kst_export.h"
-
- #include <QStringList>
-+#include <sys/types.h>
-
- namespace Kst {
-
diff --git a/science/kst2/files/patch-src__libkstapp__logdialog.h b/science/kst2/files/patch-src__libkstapp__logdialog.h
deleted file mode 100644
index a75a607919c9..000000000000
--- a/science/kst2/files/patch-src__libkstapp__logdialog.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./src/libkstapp/logdialog.h.orig 2012-07-22 13:24:59.000000000 +0000
-+++ ./src/libkstapp/logdialog.h 2013-12-09 11:39:44.250919414 +0000
-@@ -17,6 +17,7 @@
-
- #include <QDialog>
- #include <QProcess>
-+#include <sys/types.h>
-
- #include "kst_export.h"
- #include "kst_i18n.h"
diff --git a/science/kst2/pkg-plist b/science/kst2/pkg-plist
index 5a4b9371e2bc..ea00c1950fe0 100644
--- a/science/kst2/pkg-plist
+++ b/science/kst2/pkg-plist
@@ -1,4 +1,5 @@
bin/kst2
+lib/kst2/plugins/libkst2_dataobject_activitylevel.so
lib/kst2/plugins/libkst2_dataobject_bin.so
lib/kst2/plugins/libkst2_dataobject_chop.so
lib/kst2/plugins/libkst2_dataobject_convolution_convolve.so
@@ -6,7 +7,6 @@ lib/kst2/plugins/libkst2_dataobject_convolution_deconvolve.so
lib/kst2/plugins/libkst2_dataobject_correlation_autocorrelation.so
lib/kst2/plugins/libkst2_dataobject_correlation_crosscorrelation.so
lib/kst2/plugins/libkst2_dataobject_crossspectrum.so
-lib/kst2/plugins/libkst2_dataobject_differentiation.so
lib/kst2/plugins/libkst2_dataobject_effectivebandwidth.so
lib/kst2/plugins/libkst2_dataobject_genericfilter.so
lib/kst2/plugins/libkst2_dataobject_interpolations_akima.so
@@ -29,13 +29,16 @@ lib/kst2/plugins/libkst2_datasource_ascii.so
%%NETCDF%%lib/kst2/plugins/libkst2_datasource_netcdf.so
lib/kst2/plugins/libkst2_datasource_qimagesource.so
lib/kst2/plugins/libkst2_datasource_sampledatasource.so
+lib/kst2/plugins/libkst2_datasource_sourcelist.so
lib/kst2/plugins/libkst2_filters_butterworth_bandpass.so
lib/kst2/plugins/libkst2_filters_butterworth_bandstop.so
lib/kst2/plugins/libkst2_filters_butterworth_highpass.so
lib/kst2/plugins/libkst2_filters_butterworth_lowpass.so
+lib/kst2/plugins/libkst2_filters_cumulativeaverage.so
lib/kst2/plugins/libkst2_filters_cumulativesum.so
lib/kst2/plugins/libkst2_filters_despike.so
lib/kst2/plugins/libkst2_filters_differentiation.so
+lib/kst2/plugins/libkst2_filters_unwind.so
lib/kst2/plugins/libkst2_fits_exponential_unweighted.so
lib/kst2/plugins/libkst2_fits_exponential_weighted.so
lib/kst2/plugins/libkst2_fits_gaussian_unweighted.so
@@ -73,20 +76,15 @@ share/icons/hicolor/64x64/apps/application-x-kst.png
share/icons/hicolor/64x64/apps/kst.png
share/icons/hicolor/scalable/apps/application-x-kst.svg
share/icons/hicolor/scalable/apps/kst.svg
+%%DATADIR%%/locale/kst_common_ca.qm
+%%DATADIR%%/locale/kst_common_ca@valencia.qm
+%%DATADIR%%/locale/kst_common_de.qm
+%%DATADIR%%/locale/kst_common_en_GB.qm
+%%DATADIR%%/locale/kst_common_fr.qm
+%%DATADIR%%/locale/kst_common_nl.qm
+%%DATADIR%%/locale/kst_common_pl.qm
+%%DATADIR%%/locale/kst_common_pt.qm
+%%DATADIR%%/locale/kst_common_pt_BR.qm
+%%DATADIR%%/locale/kst_common_sv.qm
+%%DATADIR%%/locale/kst_common_uk.qm
share/mimelnk/application/x-kst2.desktop
-@dirrmtry share/mimelnk/application
-@dirrmtry share/mimelnk
-@dirrmtry share/icons/hicolor/scalable/apps
-@dirrmtry share/icons/hicolor/scalable
-@dirrmtry share/icons/hicolor/64x64/apps
-@dirrmtry share/icons/hicolor/64x64
-@dirrmtry share/icons/hicolor/48x48/apps
-@dirrmtry share/icons/hicolor/48x48
-@dirrmtry share/icons/hicolor/32x32/apps
-@dirrmtry share/icons/hicolor/32x32
-@dirrmtry share/icons/hicolor/128x128/apps
-@dirrmtry share/icons/hicolor/128x128
-@dirrmtry share/icons/hicolor
-@dirrmtry share/icons
-@dirrm lib/kst2/plugins
-@dirrm lib/kst2