aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2020-06-14 17:14:03 +0800
committerThierry Thomas <thierry@FreeBSD.org>2020-06-14 17:14:03 +0800
commitd7625a0297e48549f1ec398409a18aeaf7fa2a3b (patch)
tree34810c6d73060f9afa3077df4367511db10accd1 /science
parenta9b5c9a5ba9adf5f8b109e9dd2f57cb4fb2a3d13 (diff)
downloadfreebsd-ports-gnome-d7625a0297e48549f1ec398409a18aeaf7fa2a3b.tar.gz
freebsd-ports-gnome-d7625a0297e48549f1ec398409a18aeaf7fa2a3b.tar.zst
freebsd-ports-gnome-d7625a0297e48549f1ec398409a18aeaf7fa2a3b.zip
Chase ScaLAPACKĀ“s upgrade and resolve conflict between cblas and openblas.
Approved by: yuri (maintainer)
Diffstat (limited to 'science')
-rw-r--r--science/bagel/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/science/bagel/Makefile b/science/bagel/Makefile
index f0b0182369d3..0d3b503303ef 100644
--- a/science/bagel/Makefile
+++ b/science/bagel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= bagel
DISTVERSIONPREFIX= v
DISTVERSION= 1.2.2
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= science
MAINTAINER= yuri@FreeBSD.org
@@ -14,10 +14,9 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_i386= error: static_assert failed "size_t is assumed to be the same size as unsigned long long"
-LIB_DEPENDS= libboost_serialization.so:devel/boost-libs \
- libcblas.so:math/cblas
+LIB_DEPENDS= libboost_serialization.so:devel/boost-libs
-USES= autoreconf compiler:c++11-lang fortran gmake libtool localbase python:build
+USES= autoreconf blaslapack:openblas compiler:c++11-lang fortran gmake libtool localbase python:build
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --datarootdir=${DATADIR}
USE_GITHUB= yes
@@ -38,11 +37,9 @@ LIBXC_LIB_DEPENDS= libxc.so:science/libxc
SCALAPACK_DESC= Use ScaLapack library for parallelized linear algebra
SCALAPACK_CONFIGURE_ENABLE= scalapack
-SCALAPACK_VARS= LDFLAGS+="-lcblas -lscalapack"
-SCALAPACK_VARS_OFF= LDFLAGS+="-lcblas -llapack -lblas" # -llapack -lblas are a replacement of libscalapack
+SCALAPACK_VARS= LDFLAGS+="-lscalapack"
+SCALAPACK_VARS_OFF= LDFLAGS+="${BLASLIB} ${LAPACKLIB}" # -llapack -lblas are a replacement of libscalapack
SCALAPACK_LIB_DEPENDS= libscalapack.so:math/scalapack
-SCALAPACK_LIB_DEPENDS_OFF= liblapack.so:math/lapack \
- libblas.so:math/blas
SCALAPACK_IMPLIES= MPI
SMITH_DESC= Compile SMITH generated code