aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2017-12-20 23:25:16 +0800
committerbapt <bapt@FreeBSD.org>2017-12-20 23:25:16 +0800
commitdad2229a153e750090a3bea79c27c9fb40325187 (patch)
tree7dc551494b4bd6c87f3c3fbf6869a212dfb53646 /science
parent933f2d4736fc1ed1a2fb09be1e5346d7b0deca81 (diff)
downloadfreebsd-ports-gnome-dad2229a153e750090a3bea79c27c9fb40325187.tar.gz
freebsd-ports-gnome-dad2229a153e750090a3bea79c27c9fb40325187.tar.zst
freebsd-ports-gnome-dad2229a153e750090a3bea79c27c9fb40325187.zip
Remove dependency on swig
I can't find any direct call to the swig binary in the code meaning having swig as a run time dependency should not be a requirement
Diffstat (limited to 'science')
-rw-r--r--science/py-scipy/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/science/py-scipy/Makefile b/science/py-scipy/Makefile
index 8c2d7fe381b4..22f457561efa 100644
--- a/science/py-scipy/Makefile
+++ b/science/py-scipy/Makefile
@@ -3,7 +3,7 @@
PORTNAME= scipy
PORTVERSION= 0.19.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= science python
MASTER_SITES= http://docs.scipy.org/doc/${DISTNAME}/:doc \
CHEESESHOP:source \
@@ -20,8 +20,7 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
BUILD_DEPENDS= ${PYNUMPY}
-RUN_DEPENDS= ${PYNUMPY} \
- swig:devel/swig13
+RUN_DEPENDS= ${PYNUMPY}
USES= fortran python zip
USE_PYTHON= autoplist concurrent distutils