aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-02-19 00:20:02 +0800
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-02-19 00:20:02 +0800
commitdd1b0bfeb6952522b2cd479785391adee3e292eb (patch)
tree229bf4e2f6c86dffc6b89f16d1260e8d4d84a6a8 /science
parentb1163294a84a55e0c02f914bc38747789d2a356a (diff)
downloadfreebsd-ports-gnome-dd1b0bfeb6952522b2cd479785391adee3e292eb.tar.gz
freebsd-ports-gnome-dd1b0bfeb6952522b2cd479785391adee3e292eb.tar.zst
freebsd-ports-gnome-dd1b0bfeb6952522b2cd479785391adee3e292eb.zip
- Update to 4.3.3
- Use LIBS instead of LDFLAGS Changes: http://www.unidata.ucar.edu/software/netcdf/docs/release_notes.html
Diffstat (limited to 'science')
-rw-r--r--science/netcdf/Makefile29
-rw-r--r--science/netcdf/distinfo4
-rw-r--r--science/netcdf/pkg-plist9
3 files changed, 18 insertions, 24 deletions
diff --git a/science/netcdf/Makefile b/science/netcdf/Makefile
index f2c94b282d12..948f58c3c7df 100644
--- a/science/netcdf/Makefile
+++ b/science/netcdf/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= netcdf
-PORTVERSION= 4.3.2
-PORTREVISION= 1
+PORTVERSION= 4.3.3
CATEGORIES= science
MASTER_SITES= http://www.unidata.ucar.edu/downloads/netcdf/ftp/ \
ftp://ftp.unidata.ucar.edu/pub/netcdf/ \
@@ -22,24 +21,21 @@ OPTIONS_DEFAULT=DAP SZIP
DAP_DESC= Build DAP client and remote testing
SZIP_DESC= SZIP support (required if HDF5 was built with SZIP)
-CFLAGS+= -I${WRKSRC}/include -I${LOCALBASE}/include -fPIC -DPIC
-CMAKE_ARGS= -DHDF5_INCLUDE_DIRS=${LOCALBASE} -DUSE_HDF5=ON -DZLIB_INCLUDE_DIRS=/usr
-LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS= --enable-netcdf-4
+CPPFLAGS+= -I${WRKSRC}/include -I${LOCALBASE}/include -fPIC -DPIC
+GNU_CONFIGURE= yes
+LIBS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
-USES= cmake pathfix
+USES= libtool pathfix
-PLIST_SUB= PORTVERSION=${PORTVERSION}
-
-DAP_CMAKE_OFF= -DENABLE_DAP=OFF -DENABLE_DAP_REMOTE_TESTS=OFF
-DAP_CMAKE_ON= -DCURL_INCLUDE_DIRS=${LOCALBASE} -DENABLE_DAP=ON
+DAP_CONFIGURE_OFF= --disable-dap
+DAP_CONFIGURE_ON= --enable-dap
DAP_LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
DOXYGEN_BUILD_DEPENDS= ${LOCALBASE}/bin/doxygen:${PORTSDIR}/devel/doxygen
-DOXYGEN_CMAKE_OFF= -DENABLE_DOXYGEN=OFF
-DOXYGEN_CMAKE_ON= -DENABLE_DOXYGEN=ON
-SZIP_CMAKE_OFF= -DUSE_SZIP=OFF
-SZIP_CMAKE_ON= -DSZIP_DIR=${LOCALBASE} -DSZIP_INCLUDE_DIRS=${LOCALBASE} -DUSE_SZIP=ON
-SZIP_LDFLAGS= -lsz
+DOXYGEN_CONFIGURE_OFF= --disable-doxygen
+DOXYGEN_CONFIGURE_ON= --enable-doxygen
SZIP_LIB_DEPENDS= libsz.so:${PORTSDIR}/science/szip
+SZIP_LIBS= -lsz
.include <bsd.port.options.mk>
@@ -48,8 +44,7 @@ PORTDOCS= *
.endif
post-patch:
- @${REINPLACE_CMD} -e '/man4/d; s|share/cmake|&/Modules|; s|$${CMAKE_INSTALL_LIBDIR}/pkgconfig|libdata/pkgconfig|' ${WRKSRC}/CMakeLists.txt
- @${REINPLACE_CMD} -e 's|share/man|man|' ${WRKSRC}/libsrc/CMakeLists.txt ${WRKSRC}/ncdump/CMakeLists.txt ${WRKSRC}/ncgen/CMakeLists.txt ${WRKSRC}/ncgen3/CMakeLists.txt
+ @${REINPLACE_CMD} -e 's|-ldl ||g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|mmap|_&|g' ${WRKSRC}/nc_test/tst_diskless.c ${WRKSRC}/nc_test/tst_diskless3.c
post-build:
diff --git a/science/netcdf/distinfo b/science/netcdf/distinfo
index 71fc034f6aa7..d98ed2a974e4 100644
--- a/science/netcdf/distinfo
+++ b/science/netcdf/distinfo
@@ -1,2 +1,2 @@
-SHA256 (netcdf-4.3.2.tar.gz) = 57086b4383ce9232f05aad70761c2a6034b1a0c040260577d369b3bbfe6d248e
-SIZE (netcdf-4.3.2.tar.gz) = 5013938
+SHA256 (netcdf-4.3.3.tar.gz) = 83223ed74423c685a10f6c3cfa15c2d6bf7dc84b46af1e95b9fa862016aaa27e
+SIZE (netcdf-4.3.3.tar.gz) = 5039341
diff --git a/science/netcdf/pkg-plist b/science/netcdf/pkg-plist
index b8e726238c74..137ded2094f6 100644
--- a/science/netcdf/pkg-plist
+++ b/science/netcdf/pkg-plist
@@ -4,8 +4,11 @@ bin/ncdump
bin/ncgen
bin/ncgen3
include/netcdf.h
+include/netcdf_meta.h
+lib/libnetcdf.a
+lib/libnetcdf.settings
lib/libnetcdf.so
-lib/libnetcdf.so.%%PORTVERSION%%
+lib/libnetcdf.so.7
lib/libnetcdf.so.7.2.0
libdata/pkgconfig/netcdf.pc
man/man1/nccopy.1.gz
@@ -13,7 +16,3 @@ man/man1/ncdump.1.gz
man/man1/ncgen.1.gz
man/man1/ncgen3.1.gz
man/man3/netcdf.3.gz
-share/cmake/Modules/netcdf-config-version.cmake
-share/cmake/Modules/netcdf-config.cmake
-share/cmake/Modules/netcdf-targets-%%CMAKE_BUILD_TYPE%%.cmake
-share/cmake/Modules/netcdf-targets.cmake