aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-08-26 12:49:15 +0800
committerMark Linimon <linimon@FreeBSD.org>2019-08-26 12:49:15 +0800
commiteb4f437917897fd6c74bd272b6ee4b21dac2c97d (patch)
tree05f17dcd4c27b48e108aa3510a0ba89fc4979e07 /science
parent295b365b850e9d49c09049d2abcb12cae7d8751e (diff)
downloadfreebsd-ports-gnome-eb4f437917897fd6c74bd272b6ee4b21dac2c97d.tar.gz
freebsd-ports-gnome-eb4f437917897fd6c74bd272b6ee4b21dac2c97d.tar.zst
freebsd-ports-gnome-eb4f437917897fd6c74bd272b6ee4b21dac2c97d.zip
Temporarily mark this as broken on powerpc64 until I can investigate
further. The full error message is: pkg-static: Unable to access file /wrkdirs/usr/ports/science/InsightToolkit/work/stage/usr/local/include/ITK-5.0/compilers/ITK_COMPILER_INFO_Clang_CXX.h:No such file or directory I am taking this unusual step because this port takes 21 hours on the build cluster just to get to this point. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'science')
-rw-r--r--science/InsightToolkit/Makefile2
-rw-r--r--science/InsightToolkit/files/patch-Modules_ThirdParty_VNL_src_vxl_vcl_vcl__compiler.h12
2 files changed, 14 insertions, 0 deletions
diff --git a/science/InsightToolkit/Makefile b/science/InsightToolkit/Makefile
index fb95f0f7b654..0b51aa8a4e68 100644
--- a/science/InsightToolkit/Makefile
+++ b/science/InsightToolkit/Makefile
@@ -13,6 +13,8 @@ COMMENT= Insight Toolkit
LICENSE= APACHE20
+BROKEN_powerpc64= fails to package: ITK_COMPILER_INFO_Clang_CXX.h:No such file or directory
+
BUILD_DEPENDS= googletest>=0:devel/googletest
LIB_DEPENDS= libgdcmCommon.so:devel/gdcm \
libexpat.so:textproc/expat2 \
diff --git a/science/InsightToolkit/files/patch-Modules_ThirdParty_VNL_src_vxl_vcl_vcl__compiler.h b/science/InsightToolkit/files/patch-Modules_ThirdParty_VNL_src_vxl_vcl_vcl__compiler.h
new file mode 100644
index 000000000000..de61b6cb0a19
--- /dev/null
+++ b/science/InsightToolkit/files/patch-Modules_ThirdParty_VNL_src_vxl_vcl_vcl__compiler.h
@@ -0,0 +1,12 @@
+--- Modules/ThirdParty/VNL/src/vxl/vcl/vcl_compiler.h.orig 2018-12-16 00:16:56 UTC
++++ Modules/ThirdParty/VNL/src/vxl/vcl/vcl_compiler.h
+@@ -86,6 +86,9 @@
+ # else
+ # define VCL_GCC_70
+ # endif
++# elif (__GNUC__==8) || (__GNUC__==9)
++# define VCL_GCC_7
++# define VCL_GCC_73
+ # else
+ # error "Dunno about this gcc"
+ # endif