aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-07-28 06:08:21 +0800
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-07-28 06:08:21 +0800
commitf87e4c2ecb1a963189767040239a4eda363c9394 (patch)
tree154f5f486857308f8db7c40385be9c53bd589228 /science
parent1bd2632a50ec9deb12a15644b63e23376d46664b (diff)
downloadfreebsd-ports-gnome-f87e4c2ecb1a963189767040239a4eda363c9394.tar.gz
freebsd-ports-gnome-f87e4c2ecb1a963189767040239a4eda363c9394.tar.zst
freebsd-ports-gnome-f87e4c2ecb1a963189767040239a4eda363c9394.zip
science/ncnn: fix build with GCC-based architectures
This adds USES=compiler:c11 because of: /usr/local/poudriere/ports/default/science/ncnn/work/ncnn-20190611-40-gd3be711/src/layer/convolutiondepthwise.cpp:450: error: expected '#pragma omp' clause before 'collapse' It's detected that our base compiler supports OpenMP and new OpenMP features are then used. That's why we need new GCC. USES=compiler:openmp would work but it uses a base compiler. Since this port builds also without OpenMP, no further modifications are needed. Approved by: mentors (implicit approval)
Diffstat (limited to 'science')
-rw-r--r--science/ncnn/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/science/ncnn/Makefile b/science/ncnn/Makefile
index ecef44602acc..c271555b1ad0 100644
--- a/science/ncnn/Makefile
+++ b/science/ncnn/Makefile
@@ -11,7 +11,7 @@ COMMENT= High-performance neural network inference framework
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-USES= cmake
+USES= cmake compiler:c11
USE_GITHUB= yes
GH_ACCOUNT= Tencent