aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-01-01 09:47:21 +0800
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-01-01 09:47:21 +0800
commitf94c4248392d693bbd7c80a0b77c337636bbccad (patch)
treef92c313c51e7f26d2fef7d9764a1c0111cab6d42 /science
parent60b4f2bd0ef6b3cc0843ae84195e10f9433c60dc (diff)
downloadfreebsd-ports-gnome-f94c4248392d693bbd7c80a0b77c337636bbccad.tar.gz
freebsd-ports-gnome-f94c4248392d693bbd7c80a0b77c337636bbccad.tar.zst
freebsd-ports-gnome-f94c4248392d693bbd7c80a0b77c337636bbccad.zip
Add libaec 1.0.0
Libaec provides fast lossless compression of 1 up to 32 bit wide signed or unsigned integers (samples). The library achieves best results for low entropy data as often encountered in space imaging instrument data or numerical model output from weather or climate simulations. While floating point representations are not directly supported, they can also be efficiently coded by grouping exponents and mantissa. Libaec implements Golomb-Rice coding as defined in the Space Data System Standard documents 121.0-B-2 and 120.0-G-2. Libaec includes a free drop-in replacement for the SZIP library. Just replace SZIP's shared library libsz.so* with libaec.so* and libsz.so* from libaec. Code which is dynamically linked with SZIP such as HDF5 should continue to work with libaec. No re-compilation required. HDF5 files which contain SZIP encoded data can be decoded by HDF5 using libaec and vice versa. WWW: https://gitlab.dkrz.de/k202009/libaec
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/libaec/Makefile26
-rw-r--r--science/libaec/distinfo3
-rw-r--r--science/libaec/pkg-descr17
-rw-r--r--science/libaec/pkg-plist11
-rw-r--r--science/szip/Makefile2
6 files changed, 60 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 84d70d679553..9468c16b376e 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -68,6 +68,7 @@
SUBDIR += kalzium
SUBDIR += kst2
SUBDIR += lamprop
+ SUBDIR += libaec
SUBDIR += libctl
SUBDIR += libghemical
SUBDIR += libint
diff --git a/science/libaec/Makefile b/science/libaec/Makefile
new file mode 100644
index 000000000000..ee84a8224364
--- /dev/null
+++ b/science/libaec/Makefile
@@ -0,0 +1,26 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libaec
+PORTVERSION= 1.0.0
+CATEGORIES= science
+MASTER_SITES= https://gitlab.dkrz.de/k202009/libaec/repository/archive.tar.bz2?ref=v${PORTVERSION}&dummy=/ \
+ LOCAL/sunpoet
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Adaptive entropy coding library
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+CONFLICTS_INSTALL= hdf-szip-
+
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+USE_LDCONFIG= yes
+USES= autoreconf libtool tar:bz2
+
+GL_TAGNAME= 351b61ebdfd2a3c02c7227df4a13d106d79418f8
+WRKSRC= ${WRKDIR}/${PORTNAME}-v${PORTVERSION}-${GL_TAGNAME}
+
+.include <bsd.port.mk>
diff --git a/science/libaec/distinfo b/science/libaec/distinfo
new file mode 100644
index 000000000000..39874ffa4c0f
--- /dev/null
+++ b/science/libaec/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1483205683
+SHA256 (libaec-1.0.0.tar.bz2) = 9b4e1bc2f1d531b9b0f7dbb49caaa5e6e6119c50d412bf8cb49be60ae25289b5
+SIZE (libaec-1.0.0.tar.bz2) = 776442
diff --git a/science/libaec/pkg-descr b/science/libaec/pkg-descr
new file mode 100644
index 000000000000..a06d40384bef
--- /dev/null
+++ b/science/libaec/pkg-descr
@@ -0,0 +1,17 @@
+Libaec provides fast lossless compression of 1 up to 32 bit wide signed or
+unsigned integers (samples). The library achieves best results for low entropy
+data as often encountered in space imaging instrument data or numerical model
+output from weather or climate simulations. While floating point representations
+are not directly supported, they can also be efficiently coded by grouping
+exponents and mantissa.
+
+Libaec implements Golomb-Rice coding as defined in the Space Data System
+Standard documents 121.0-B-2 and 120.0-G-2.
+
+Libaec includes a free drop-in replacement for the SZIP library. Just replace
+SZIP's shared library libsz.so* with libaec.so* and libsz.so* from libaec. Code
+which is dynamically linked with SZIP such as HDF5 should continue to work with
+libaec. No re-compilation required. HDF5 files which contain SZIP encoded data
+can be decoded by HDF5 using libaec and vice versa.
+
+WWW: https://gitlab.dkrz.de/k202009/libaec
diff --git a/science/libaec/pkg-plist b/science/libaec/pkg-plist
new file mode 100644
index 000000000000..5997eb12d284
--- /dev/null
+++ b/science/libaec/pkg-plist
@@ -0,0 +1,11 @@
+bin/aec
+include/libaec.h
+include/szlib.h
+lib/libaec.a
+lib/libaec.so
+lib/libaec.so.0
+lib/libaec.so.0.0.6
+lib/libsz.a
+lib/libsz.so
+lib/libsz.so.2
+lib/libsz.so.2.0.1
diff --git a/science/szip/Makefile b/science/szip/Makefile
index 79971d7ee0b7..5aa06afe7881 100644
--- a/science/szip/Makefile
+++ b/science/szip/Makefile
@@ -16,6 +16,8 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Lossless compression library for scientific data
+CONFLICTS_INSTALL= libaec-
+
OPTIONS_DEFINE= DOCS
GNU_CONFIGURE= yes