aboutsummaryrefslogtreecommitdiffstats
path: root/security/IMHear/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-10-06 20:12:37 +0800
committeredwin <edwin@FreeBSD.org>2003-10-06 20:12:37 +0800
commit80ec6775957ce781eabf988da4e4fae3e85c0ee4 (patch)
treebfa39318732f0c9651feba89cb1a05ccbe70e586 /security/IMHear/Makefile
parent67a67cb1e6f31151fcaf9d6b2c3e86090086f982 (diff)
downloadfreebsd-ports-gnome-80ec6775957ce781eabf988da4e4fae3e85c0ee4.tar.gz
freebsd-ports-gnome-80ec6775957ce781eabf988da4e4fae3e85c0ee4.tar.zst
freebsd-ports-gnome-80ec6775957ce781eabf988da4e4fae3e85c0ee4.zip
New port: An MSN Messenger event/message sniffer
An MSN Messenger event/message sniffer based on the pcap library PR: ports/55262 Submitted by: Nicolas Gieczewski <nick@n0sp4m.nixsoftware.com>
Diffstat (limited to 'security/IMHear/Makefile')
-rw-r--r--security/IMHear/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/security/IMHear/Makefile b/security/IMHear/Makefile
new file mode 100644
index 000000000000..bb7a52e04b6c
--- /dev/null
+++ b/security/IMHear/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: IMHear
+# Date created: 04 August 2003
+# Whom: Nicolas Gieczewski
+#
+# $FreeBSD$
+#
+
+PORTNAME= IMHear
+PORTVERSION= 1.0
+CATEGORIES= security
+MASTER_SITES= http://repository.nixsoftware.com/ports/
+
+MAINTAINER= ports@nixsoftware.com
+COMMENT= An MSN Messenger event/message sniffer
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+NO_INSTALL_MANPAGES=yes
+
+pre-install:
+ @${SED} -e 's,%%PREFIX%%,${PREFIX},g' ${PKGDIR}/pkg-message.in > ${PKGMESSAGE}
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/hear ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/msn_protocol_10.html ${PREFIX}/share/doc/${PORTNAME}
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>