aboutsummaryrefslogtreecommitdiffstats
path: root/security/Makefile
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2016-11-03 23:55:46 +0800
committerfeld <feld@FreeBSD.org>2016-11-03 23:55:46 +0800
commitbe1996ec8c233907dcf6552baa7c4b0426d5e729 (patch)
tree7970e03ec0760b76f7163e2a9d12d8f17f229e5c /security/Makefile
parent3f63ea2648ea6a2c3decc2f049f44a10f9f0d320 (diff)
downloadfreebsd-ports-gnome-be1996ec8c233907dcf6552baa7c4b0426d5e729.tar.gz
freebsd-ports-gnome-be1996ec8c233907dcf6552baa7c4b0426d5e729.tar.zst
freebsd-ports-gnome-be1996ec8c233907dcf6552baa7c4b0426d5e729.zip
BearSSL is an implementation of the SSL/TLS protocol (RFC 5246) written
in C. It aims at offering the following features: - Be correct and secure. In particular, insecure protocol versions and choices of algorithms are not supported, by design; cryptographic algorithm implementations are constant-time by default. - Be small, both in RAM and code footprint. For instance, a minimal server implementation may fit in about 20 kilobytes of compiled code and 25 kilobytes of RAM. - Be highly portable. BearSSL targets not only "big" operating systems like Linux and Windows, but also small embedded systems and even special contexts like bootstrap code. - Be feature-rich and extensible. SSL/TLS has many defined cipher suites and extensions; BearSSL should implement most of them, and allow extra algorithm implementations to be added afterwards, possibly from third parties. WWW: https://bearssl.org/
Diffstat (limited to 'security/Makefile')
-rw-r--r--security/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index c71893e1853c..15f046412e73 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -36,6 +36,7 @@
SUBDIR += bcrypt
SUBDIR += bcwipe
SUBDIR += bdc
+ SUBDIR += bearssl
SUBDIR += beecrypt
SUBDIR += belier
SUBDIR += bfbtester