aboutsummaryrefslogtreecommitdiffstats
path: root/security/aespipe/Makefile
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-02-01 00:25:43 +0800
committeryuri <yuri@FreeBSD.org>2018-02-01 00:25:43 +0800
commit95f2def235c735413f3903e8710c17a04ee98c3a (patch)
tree8d1abfd77486db7a18a3f50df9ff6901a67b208e /security/aespipe/Makefile
parent3a7e1118d294ed3d4f902df2be896c8419aa88ee (diff)
downloadfreebsd-ports-gnome-95f2def235c735413f3903e8710c17a04ee98c3a.tar.gz
freebsd-ports-gnome-95f2def235c735413f3903e8710c17a04ee98c3a.tar.zst
freebsd-ports-gnome-95f2def235c735413f3903e8710c17a04ee98c3a.zip
security/aespipe: Update to 2.4e
Additional port changes: * Disabled build-time x86/amd64/padlock/intelaes auto-detection which may produce broken binaries * Added explicit ASM, INTEL and PADLOCK options instead PR: 225283 Submitted by: Dmitri Goutnik <dg@syrec.org> Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D14110
Diffstat (limited to 'security/aespipe/Makefile')
-rw-r--r--security/aespipe/Makefile17
1 files changed, 15 insertions, 2 deletions
diff --git a/security/aespipe/Makefile b/security/aespipe/Makefile
index 740bcd6dff52..8427d44d8940 100644
--- a/security/aespipe/Makefile
+++ b/security/aespipe/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= aespipe
-PORTVERSION= 2.4d
+PORTVERSION= 2.4e
DISTVERSIONPREFIX= v
CATEGORIES= security
MASTER_SITES= http://loop-aes.sourceforge.net/${PORTNAME}/ \
@@ -16,12 +16,25 @@ LICENSE= GPLv2
RUN_DEPENDS= gpg:security/gnupg
USES= tar:bzip2
-
GNU_CONFIGURE= yes
TEST_TARGET= tests
PLIST_FILES= bin/aespipe man/man1/aespipe.1.gz
+OPTIONS_DEFINE_amd64= ASM INTEL PADLOCK
+OPTIONS_DEFINE_i386= ASM INTEL PADLOCK
+
+INTEL_DESC= Support Intel hardware AES
+PADLOCK_DESC= Support VIA Padlock hardware AES
+
+ASM_CONFIGURE_ENABLE= asm=${ARCH:S/i386/x86/}
+
+INTEL_CONFIGURE_ENABLE= intelaes
+INTEL_IMPLIES= ASM
+
+PADLOCK_CONFIGURE_ENABLE= padlock
+PADLOCK_IMPLIES= ASM
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1