aboutsummaryrefslogtreecommitdiffstats
path: root/security/boringssl
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2019-06-29 11:51:13 +0800
committertobik <tobik@FreeBSD.org>2019-06-29 11:51:13 +0800
commit01937667a99ad7ce0fe80e148aef97dd7683f94c (patch)
tree8c7c440762c72012824110ba9cdd44c8c1765017 /security/boringssl
parent388b5eef103bfb24dd783b7f2c5dd9f7cf45e08a (diff)
downloadfreebsd-ports-gnome-01937667a99ad7ce0fe80e148aef97dd7683f94c.tar.gz
freebsd-ports-gnome-01937667a99ad7ce0fe80e148aef97dd7683f94c.tar.zst
freebsd-ports-gnome-01937667a99ad7ce0fe80e148aef97dd7683f94c.zip
Convert all Go ports to USES=go
This allows for port testing with lang/go-devel via GO_PORT, setting up the Go build environment in a single place, and is step one in simplifying Go ports that often define too complicated do-build targets themselves. USES=go gains new arguments 'run' to add lang/go to RUN_DEPENDS and 'no_targets' for ports with composite builds that call 'go' themselves and do not need the do-build/do-install targets of USES=go. PR: 238849 Submitted by: dg@syrec.org (also D20745) Reviewed by: mat, tobik Exp-run by: antoine Differential Revision: https://reviews.freebsd.org/D20746
Diffstat (limited to 'security/boringssl')
-rw-r--r--security/boringssl/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/security/boringssl/Makefile b/security/boringssl/Makefile
index 2ebaa7a3e9ac..f7fe460d1847 100644
--- a/security/boringssl/Makefile
+++ b/security/boringssl/Makefile
@@ -7,12 +7,10 @@ CATEGORIES= security
MAINTAINER= swills@FreeBSD.org
COMMENT= Fork of OpenSSL
-BUILD_DEPENDS= go:lang/go
-
USE_GITHUB= yes
GH_ACCOUNT= google
GH_TAGNAME= 144d924
-USES= cmake:insource localbase perl5
+USES= cmake:insource go:no_targets localbase perl5
CMAKE_ARGS+= -DCMAKE_BUILD_TYPE=Release -DBUILD_SHARED_LIBS=1
USE_LDCONFIG= yes
LDFLAGS+= -Wl,-rpath,${PREFIX}/lib