aboutsummaryrefslogtreecommitdiffstats
path: root/security/bugs
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-10-29 17:30:14 +0800
committermat <mat@FreeBSD.org>2016-10-29 17:30:14 +0800
commit2534dcae9401a97fe13103fd6c5ada5a75e88837 (patch)
tree206391c49d2d2e1ae3b991e829e691c2a24541ce /security/bugs
parentb2a7583055493029a7d0154e0d0238e135d2c59f (diff)
downloadfreebsd-ports-gnome-2534dcae9401a97fe13103fd6c5ada5a75e88837.tar.gz
freebsd-ports-gnome-2534dcae9401a97fe13103fd6c5ada5a75e88837.tar.zst
freebsd-ports-gnome-2534dcae9401a97fe13103fd6c5ada5a75e88837.zip
Fix file modes after extracting.
Some port's archives contains files modes that are a bit too restrictive for some usage. For example: BUILD_DEPENDS= ${NONEXISTENT}:foo/bar:configure When building as a regular user, dependencies are installed/built as root, so if the archive contains files that have a mode of, say, 600, they will not be readable by the port requesting the dependency. This will also fix broken distribution files where directories don't have the executable bit on. OSVERSION 1100077 is after base r283997: Change directory permissions in pre-order. In this order, it won't try to recurse into a directory for which it doesn't have permission, before changing that permission. This follows an existing behavior in other BSDs, linux, OS X. PR: 213574 Submitted by: mat Exp-run by: antoine Sponsored by: Absolight
Diffstat (limited to 'security/bugs')
-rw-r--r--security/bugs/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/security/bugs/Makefile b/security/bugs/Makefile
index 2835ae8e129f..bbbe19f014dc 100644
--- a/security/bugs/Makefile
+++ b/security/bugs/Makefile
@@ -55,4 +55,11 @@ post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 1100077
+post-extract:
+ ${CHMOD} +x ${WRKSRC}/lib/unix ${WRKSRC}/lib/windows
+.endif
+
+.include <bsd.port.post.mk>