aboutsummaryrefslogtreecommitdiffstats
path: root/security/clamav
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-03-25 16:30:27 +0800
committermarino <marino@FreeBSD.org>2015-03-25 16:30:27 +0800
commit12a3d18ba54eb521226a4ec0ed2aecfbcfcb24a8 (patch)
tree123ddeae4f07536b3d89acc6409ce124aa06d373 /security/clamav
parente59c5e2e130d16dc7ae04b960115c07010eaed3a (diff)
downloadfreebsd-ports-gnome-12a3d18ba54eb521226a4ec0ed2aecfbcfcb24a8.tar.gz
freebsd-ports-gnome-12a3d18ba54eb521226a4ec0ed2aecfbcfcb24a8.tar.zst
freebsd-ports-gnome-12a3d18ba54eb521226a4ec0ed2aecfbcfcb24a8.zip
security category: Remove $PTHREAD_LIBS
approved by: PTHREAD blanket
Diffstat (limited to 'security/clamav')
-rw-r--r--security/clamav/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index 604443ee352a..31133674d897 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -76,14 +76,11 @@ CONFIGURE_ARGS= --libdir=${PREFIX}/lib \
--enable-gethostbyname_r \
--disable-dependency-tracking \
--enable-clamdtop
-CPPFLAGS+= -I${LOCALBASE}/include \
- ${PTHREAD_CFLAGS}
-LDFLAGS+= -L${LOCALBASE}/lib \
- ${PTHREAD_LIBS}
+CPPFLAGS+= -I${LOCALBASE}/include
# This port has a problem with -pthread,
# force to use -lthr until it's not fixed.
-PTHREAD_LIBS= -lthr
+LDFLAGS+= -lthr -L${LOCALBASE}/lib
CONFLICTS?= clamav-milter-[0-9]*
@@ -167,7 +164,7 @@ CFLAGS+= -march=i486
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|g' \
+ @${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|-lthr|g' \
-e 's|LC_REVISION=22|LC_REVISION=24|' \
${WRKSRC}/${CONFIGURE_SCRIPT}
@${REINPLACE_CMD} -e 's,^\(pkgconfigdir = \).*$$,\1$$\(prefix\)/libdata/pkgconfig,g' \