aboutsummaryrefslogtreecommitdiffstats
path: root/security/clamav
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2010-08-16 19:38:12 +0800
committergarga <garga@FreeBSD.org>2010-08-16 19:38:12 +0800
commit1c8be74710f95111b63742fc650de3f147296652 (patch)
treec27239efa856f983b1e92f813cefc28f7b319fb4 /security/clamav
parent014fd1e1b47436e0bcf168744f1ce9f08e673a34 (diff)
downloadfreebsd-ports-gnome-1c8be74710f95111b63742fc650de3f147296652.tar.gz
freebsd-ports-gnome-1c8be74710f95111b63742fc650de3f147296652.tar.zst
freebsd-ports-gnome-1c8be74710f95111b63742fc650de3f147296652.zip
- Fix CPU assumptions for amd64
- Bump PORTREVISION PR: ports/149637 Submitted by: Michael Scheidell <scheidell@secnap.net> Obtained from: https://wwws.clamav.net/bugzilla/show_bug.cgi?id=2201
Diffstat (limited to 'security/clamav')
-rw-r--r--security/clamav/Makefile1
-rw-r--r--security/clamav/files/patch-libclamav__bytecode_detect.c10
2 files changed, 11 insertions, 0 deletions
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index 8de107e88e9c..e4ec05cfb399 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -7,6 +7,7 @@
PORTNAME= clamav
DISTVERSION= 0.96.2
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= SF
diff --git a/security/clamav/files/patch-libclamav__bytecode_detect.c b/security/clamav/files/patch-libclamav__bytecode_detect.c
new file mode 100644
index 000000000000..fd260f0441cd
--- /dev/null
+++ b/security/clamav/files/patch-libclamav__bytecode_detect.c
@@ -0,0 +1,10 @@
+--- libclamav/bytecode_detect.c.orig 2010-08-16 08:30:31.000000000 -0300
++++ libclamav/bytecode_detect.c 2010-08-16 08:29:48.000000000 -0300
+@@ -185,6 +185,7 @@
+ /* -- Detect arch -- */
+ CHECK_ARCH(i386);
+ else CHECK_ARCH(x86_64);
++ else if (!strcmp(TARGET_ARCH_TYPE,"amd64")) env->arch = arch_x86_64;
+ else if (!strcmp(TARGET_ARCH_TYPE,"ppc")) env->arch = arch_ppc32;/* llvm will fix ppc64 */
+ else CHECK_ARCH(arm);
+ else CHECK_ARCH(sparc);