aboutsummaryrefslogtreecommitdiffstats
path: root/security/clamav
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2011-02-23 23:14:35 +0800
committerRenato Botelho <garga@FreeBSD.org>2011-02-23 23:14:35 +0800
commit3254e6b9172793ef0382534d4adc36b4c504324f (patch)
tree0588748c673aeae6b04f1008409855469ea7e088 /security/clamav
parenta916393e3a3237aac0076d98a1852c055a59be7b (diff)
downloadfreebsd-ports-gnome-3254e6b9172793ef0382534d4adc36b4c504324f.tar.gz
freebsd-ports-gnome-3254e6b9172793ef0382534d4adc36b4c504324f.tar.zst
freebsd-ports-gnome-3254e6b9172793ef0382534d4adc36b4c504324f.zip
Add a new option to build JIT bytecode compiler using llvm installed from ports
instead of build clamav's own llvm. The option is off by default, so, no PORTREVISION bum is required PR: ports/154900 Submitted by: Denny Lin <dennylin93@hs.ntnu.edu.tw>
Diffstat (limited to 'security/clamav')
-rw-r--r--security/clamav/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index 679600536ad3..1fca015f926a 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -18,7 +18,8 @@ OPTIONS= ARC "Enable arch archives support" On \
LHA "Enable lha archives support" On \
UNZOO "Enable zoo archives support" On \
UNRAR "Enable rar archives support" On \
- LLVM "Enable JIT Bytecode compiler" On \
+ LLVM "Enable JIT Bytecode compiler (bundled LLVM)" On \
+ LLVM_PORTS "Enable JIT Bytecode compiler (from Ports)" Off \
TESTS "Run compile-time tests (req. python)" On \
MILTER "Compile the milter interface" Off \
LDAP "libmilter was built with LDAP" Off \
@@ -139,9 +140,16 @@ USE_ICONV= yes
CONFIGURE_ARGS+=--without-iconv
.endif
-.if defined(WITH_LLVM) && ( ${ARCH} == "i386" || ${ARCH} == "amd64" )
+.if (defined(WITH_LLVM) || defined(WITH_LLVM_PORTS)) && ( ${ARCH} == "i386" || ${ARCH} == "amd64" )
CONFIGURE_ARGS+=--enable-llvm
USE_GMAKE= yes
+. if defined(WITH_LLVM_PORTS)
+BUILD_DEPENDS+= ${LOCALBASE}/bin/llvm-config:${PORTSDIR}/devel/llvm
+CONFIGURE_ARGS+=-with-system-llvm=${LOCALBASE}/bin/llvm-config
+. endif
+. if defined(WITH_LLVM) && defined(WITH_LLVM_PORTS)
+IGNORE=Select only one LLVM
+. endif
. if defined(WITH_TESTS)
USE_PYTHON_BUILD= yes
. endif
@@ -203,7 +211,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|0x100000000|0x100000000ULL|g' \
${WRKSRC}/libclamunrar/unrar.c
-.if defined(WITH_LLVM) && defined(WITH_TESTS)
+.if (defined(WITH_LLVM) || defined(WITH_LLVM_PORTS)) && defined(WITH_TESTS)
pre-configure:
@if ! ${PYTHON_CMD} -c "import thread" >/dev/null 2>&1; then \
${ECHO_MSG} ""; \