aboutsummaryrefslogtreecommitdiffstats
path: root/security/clamav
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2007-02-16 19:20:24 +0800
committerRenato Botelho <garga@FreeBSD.org>2007-02-16 19:20:24 +0800
commit972fce1047c7daca417850a7f35b00561a710042 (patch)
treefe64cf96de7c8e298dcd31b75fa9360675aed13a /security/clamav
parente14ba30eaa699cf1cdb3231735338a8cbff9700a (diff)
downloadfreebsd-ports-gnome-972fce1047c7daca417850a7f35b00561a710042.tar.gz
freebsd-ports-gnome-972fce1047c7daca417850a7f35b00561a710042.tar.zst
freebsd-ports-gnome-972fce1047c7daca417850a7f35b00561a710042.zip
- Fix sed used on (clamd|freshclam).conf to new format
- Add LDAP as an OPTION - Bump PORTREVISION Spoted by: ache@
Diffstat (limited to 'security/clamav')
-rw-r--r--security/clamav/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index d988232397f0..bb14cc818574 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -7,6 +7,7 @@
PORTNAME= clamav
PORTVERSION= 0.90
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= SF
@@ -20,6 +21,7 @@ RUN_DEPENDS= lha:${PORTSDIR}/archivers/lha \
arc:${PORTSDIR}/archivers/arc
OPTIONS= MILTER "Compile the milter interface" Off \
+ LDAP "libmilter was built with LDAP" Off \
CURL "Support URL downloading" Off \
STDERR "Print logs to stderr instead of stdout" Off
@@ -85,11 +87,11 @@ SED_CONF= -E -e 's|^\#?(Example)$$|\#\1|' \
-e 's|^\#?(PidFile) .*/([a-z]+\.pid)$$|\1 ${RUNDIR}/\2|' \
-e 's|^\#?(LocalSocket) .*$$|\1 ${CLAMAV_CLAMD_SOCKET}|' \
-e 's|^\#?(User) .*$$|\1 ${CLAMAVUSER}|' \
- -e 's|^\#?(AllowSupplementaryGroups)$$|\1|' \
- -e 's|^\#?(ScanMail)$$|\1|' \
+ -e 's|^\#?(AllowSupplementaryGroups).*$$|\1 yes|' \
+ -e 's|^\#?(ScanMail).*$$|\1 yes|' \
-e 's|^\#?(DatabaseDirectory) .*$$|\1 ${DBDIR}|' \
-e 's|^\#?(DatabaseOwner) .*$$|\1 ${CLAMAVUSER}|' \
- -e 's|^\#?(FixStaleSocket)$$|\1|' \
+ -e 's|^\#?(FixStaleSocket).*$$|\1 yes|' \
-e 's|^\#?(NotifyClamd) .*$$|\1 ${PREFIX}/etc/clamd.conf|'
PLIST_SUB+= CLAMAVUSER=${CLAMAVUSER} \
@@ -103,7 +105,7 @@ PTHREAD_LIBS= -pthread
.if defined(WITH_MILTER)
USE_RC_SUBR+= clamav-milter
-.if !defined(WITHOUT_LDAP) && exists(${LOCALBASE}/lib/libldap.so)
+.if defined(WITH_LDAP) && exists(${LOCALBASE}/lib/libldap.so)
USE_OPENLDAP= yes
LDFLAGS+= -lldap
.endif