aboutsummaryrefslogtreecommitdiffstats
path: root/security/cyrus-sasl2/Makefile
diff options
context:
space:
mode:
authorume <ume@FreeBSD.org>2006-05-20 04:45:37 +0800
committerume <ume@FreeBSD.org>2006-05-20 04:45:37 +0800
commit7f56facc8db9e9cd9210bb0e883dbaa89226d4e6 (patch)
treea4407aec04380c8e140b5fb1f147db1eaf63a5c4 /security/cyrus-sasl2/Makefile
parentba5cb6121b1f8929ef005cfea82f50b40091ba54 (diff)
downloadfreebsd-ports-gnome-7f56facc8db9e9cd9210bb0e883dbaa89226d4e6.tar.gz
freebsd-ports-gnome-7f56facc8db9e9cd9210bb0e883dbaa89226d4e6.tar.zst
freebsd-ports-gnome-7f56facc8db9e9cd9210bb0e883dbaa89226d4e6.zip
Update to 2.1.22.
Diffstat (limited to 'security/cyrus-sasl2/Makefile')
-rw-r--r--security/cyrus-sasl2/Makefile27
1 files changed, 16 insertions, 11 deletions
diff --git a/security/cyrus-sasl2/Makefile b/security/cyrus-sasl2/Makefile
index 33fa10f9063b..f443a56dbad5 100644
--- a/security/cyrus-sasl2/Makefile
+++ b/security/cyrus-sasl2/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= cyrus-sasl
-PORTVERSION= 2.1.21
-PORTREVISION= 2
+PORTVERSION= 2.1.22
+PORTREVISION= 0
CATEGORIES= security ipv6
MASTER_SITES= ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/%SUBDIR%/ \
ftp://ftp.westbend.net/pub/cyrus-mail/%SUBDIR%/ \
@@ -30,20 +30,21 @@ MAN3= sasl.3 sasl_authorize_t.3 sasl_auxprop.3 \
sasl_client_init.3 sasl_client_new.3 sasl_client_start.3 \
sasl_client_step.3 sasl_decode.3 sasl_dispose.3 sasl_done.3 \
sasl_encode.3 sasl_encodev.3 sasl_errdetail.3 sasl_errors.3 \
- sasl_errstring.3 sasl_getopt_t.3 sasl_getpath_t.3 \
- sasl_getprop.3 sasl_getrealm_t.3 sasl_getsecret_t.3 \
- sasl_getsimple_t.3 sasl_global_listmech.3 \
+ sasl_errstring.3 sasl_getconfpath_t.3 sasl_getopt_t.3 \
+ sasl_getpath_t.3 sasl_getprop.3 sasl_getrealm_t.3 \
+ sasl_getsecret_t.3 sasl_getsimple_t.3 sasl_global_listmech.3 \
sasl_idle.3 sasl_listmech.3 sasl_log_t.3 \
sasl_server_init.3 sasl_server_new.3 sasl_server_start.3 \
sasl_server_step.3 sasl_server_userdb_checkpass_t.3 \
sasl_server_userdb_setpass_t.3 sasl_setpass.3 sasl_setprop.3 \
sasl_user_exists.3 sasl_verifyfile_t.3
-MAN8= sasldblistusers2.8 saslpasswd2.8
+MAN8= pluginviewer.8 sasldblistusers2.8 saslpasswd2.8
USE_OPENSSL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
+ --with-configdir=${PREFIX}/lib/sasl2:${PREFIX}/etc/sasl2 \
--with-plugindir=${PREFIX}/lib/sasl2 \
--with-dbpath=${PREFIX}/etc/sasldb2 \
--includedir=${PREFIX}/include \
@@ -103,10 +104,6 @@ CONFIGURE_ARGS+=--enable-sql
SQL= "@comment "
.endif
-.if defined(WITH_AUTHDAEMON)
-CONFIGURE_ARGS+=--with-authdaemond
-.endif
-
.if defined(WITH_DEV_URANDOM)
CONFIGURE_ARGS+=--with-devrandom=/dev/urandom
.endif
@@ -115,6 +112,14 @@ CONFIGURE_ARGS+=--with-devrandom=/dev/urandom
CONFIGURE_ARGS+=--enable-alwaystrue
.endif
+.if defined(WITH_KEEP_DB_OPEN)
+CONFIGURE_ARGS+=--enable-keep-db-open
+.endif
+
+.if defined(WITHOUT_AUTHDAEMOND)
+CONFIGURE_ARGS+=--with-authdaemond=no
+.endif
+
.if defined(WITHOUT_LOGIN)
LOGIN= "@comment "
.else
@@ -191,7 +196,7 @@ SASLAUTHD_RUNPATH?= /var/run/saslauthd
CYRUS_USER?= cyrus
CYRUS_GROUP?= cyrus
-DOCS= AUTHORS COPYING ChangeLog INSTALL NEWS README
+DOCS= AUTHORS COPYING ChangeLog INSTALL INSTALL.TXT NEWS README
DOC2= ONEWS TODO draft-burdis-cat-srp-sasl-xx.txt \
draft-ietf-sasl-anon-xx.txt draft-ietf-sasl-crammd5-xx.txt \