aboutsummaryrefslogtreecommitdiffstats
path: root/security/doorman
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-07-08 19:26:51 +0800
committerpawel <pawel@FreeBSD.org>2014-07-08 19:26:51 +0800
commit08557fd45af19f7564a9880544bbafbdcd64bed6 (patch)
tree22d4dcb83d1564a253c5864a951ab86b95edde27 /security/doorman
parent3d959b60d70e01cb4c949b2d05cd38fc97c6e022 (diff)
downloadfreebsd-ports-gnome-08557fd45af19f7564a9880544bbafbdcd64bed6.tar.gz
freebsd-ports-gnome-08557fd45af19f7564a9880544bbafbdcd64bed6.tar.zst
freebsd-ports-gnome-08557fd45af19f7564a9880544bbafbdcd64bed6.zip
- Add staging support
- Remove author tag from pkg-descr
Diffstat (limited to 'security/doorman')
-rw-r--r--security/doorman/Makefile34
-rw-r--r--security/doorman/pkg-descr1
-rw-r--r--security/doorman/pkg-plist5
3 files changed, 16 insertions, 24 deletions
diff --git a/security/doorman/Makefile b/security/doorman/Makefile
index 69dc3bae03c2..c9b2a6355c6b 100644
--- a/security/doorman/Makefile
+++ b/security/doorman/Makefile
@@ -8,45 +8,33 @@ CATEGORIES= security
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
EXTRACT_SUFX= .tgz
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Port knocking implementation, both daemon and client
BUILD_DEPENDS= lsof:${PORTSDIR}/sysutils/lsof
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PKGMESSAGE= ${WRKDIR}/pkg-message
PATCH_STRIP= -p1
+GNU_CONFIGURE= yes
INSTALL_TARGET= installdirs install-exec install-data
-MAN1= knock.1
-MAN5= knockcf.5 doormand.cf.5 guestlist.5
-MAN8= doormand.8
-
-GNU_CONFIGURE= yes
SUB_FILES= pkg-message doormand.cf.EXAMPLE
USE_RC_SUBR= doorman
-NO_STAGE= yes
pre-patch:
@${REINPLACE_CMD} -e 's/[[:cntrl:]]*$$//' \
${WRKSRC}/doormand.c
post-install:
- ${RM} -f ${PREFIX}/etc/doormand/ipf_add
- ${INSTALL_SCRIPT} ${FILESDIR}/ipf_add.atend ${PREFIX}/etc/doormand/ipf_add.atend
- ${INSTALL_SCRIPT} ${FILESDIR}/ipf_add.before_block ${PREFIX}/etc/doormand/ipf_add.before_block
- ${INSTALL_SCRIPT} ${FILESDIR}/ipf_delete ${PREFIX}/etc/doormand/ipf_delete
- ${INSTALL_DATA} ${WRKDIR}/doormand.cf.EXAMPLE ${PREFIX}/etc/doormand/doormand.cf.EXAMPLE
- @for man in ${MAN1}; do \
- ${INSTALL_MAN} -C ${WRKSRC}/$$man ${PREFIX}/man/man1; \
- done
- @for man in ${MAN5}; do \
- ${INSTALL_MAN} -C ${WRKSRC}/$$man ${PREFIX}/man/man5; \
- done
- @for man in ${MAN8}; do \
- ${INSTALL_MAN} -C ${WRKSRC}/$$man ${PREFIX}/man/man8; \
- done
- @${CAT} ${PKGMESSAGE}
+ ${RM} -f ${STAGEDIR}${PREFIX}/etc/doormand/ipf_add
+ (cd ${FILESDIR} && ${INSTALL_SCRIPT} ipf_add.atend ipf_delete \
+ ipf_add.before_block ${STAGEDIR}${PREFIX}/etc/doormand)
+ ${INSTALL_DATA} ${WRKDIR}/doormand.cf.EXAMPLE \
+ ${STAGEDIR}${PREFIX}/etc/doormand
+ ${INSTALL_MAN} -C ${WRKSRC}/knock.1 ${STAGEDIR}${PREFIX}/man/man1
+ (cd ${WRKSRC} && ${INSTALL_MAN} -C knockcf.5 doormand.cf.5 guestlist.5 \
+ ${STAGEDIR}${PREFIX}/man/man5)
+ ${INSTALL_MAN} -C ${WRKSRC}/doormand.8 ${STAGEDIR}${PREFIX}/man/man8
.include <bsd.port.mk>
diff --git a/security/doorman/pkg-descr b/security/doorman/pkg-descr
index f93e8bd627cd..0ab428b93339 100644
--- a/security/doorman/pkg-descr
+++ b/security/doorman/pkg-descr
@@ -2,5 +2,4 @@ Doorman is a port knocking implementation which allows a server to run
silently, invisibly, with all TCP ports closed except to those who know...
the secret knock!
-Author: Bruce Ward <bward2@users.sourceforge.net>
WWW: http://doorman.sourceforge.net/
diff --git a/security/doorman/pkg-plist b/security/doorman/pkg-plist
index 65bc32edc5f3..01186e29c9be 100644
--- a/security/doorman/pkg-plist
+++ b/security/doorman/pkg-plist
@@ -12,5 +12,10 @@ etc/doormand/iptables_add
etc/doormand/iptables_delete
etc/doormand/pfctl_add
etc/doormand/pfctl_delete
+man/man1/knock.1.gz
+man/man5/knockcf.5.gz
+man/man5/doormand.cf.5.gz
+man/man5/guestlist.5.gz
+man/man8/doormand.8.gz
sbin/doormand
@dirrmtry etc/doormand