aboutsummaryrefslogtreecommitdiffstats
path: root/security/drweb-sendmail
diff options
context:
space:
mode:
authorache <ache@FreeBSD.org>2001-10-04 02:46:24 +0800
committerache <ache@FreeBSD.org>2001-10-04 02:46:24 +0800
commit59cde9d931084ae04876f168f621d939c75de822 (patch)
treef8380b4fcb91ecdb51a950edfd3b9bc611f24519 /security/drweb-sendmail
parentbfe312c6fb17524aba7c00651091f589e45b724a (diff)
downloadfreebsd-ports-gnome-59cde9d931084ae04876f168f621d939c75de822.tar.gz
freebsd-ports-gnome-59cde9d931084ae04876f168f621d939c75de822.tar.zst
freebsd-ports-gnome-59cde9d931084ae04876f168f621d939c75de822.zip
Fix socket permissions and startup race condition
Diffstat (limited to 'security/drweb-sendmail')
-rw-r--r--security/drweb-sendmail/Makefile2
-rw-r--r--security/drweb-sendmail/files/patch-af22
2 files changed, 23 insertions, 1 deletions
diff --git a/security/drweb-sendmail/Makefile b/security/drweb-sendmail/Makefile
index 1030fe022a36..3537fa6a54dd 100644
--- a/security/drweb-sendmail/Makefile
+++ b/security/drweb-sendmail/Makefile
@@ -7,7 +7,7 @@
PORTNAME= drweb_sendmail
PORTVERSION= 4.26
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= security mail
MASTER_SITES= http://www.drweb.ru/ftp/web_pub/
DISTNAME= drwebd-${PORTVERSION}-freebsd4
diff --git a/security/drweb-sendmail/files/patch-af b/security/drweb-sendmail/files/patch-af
new file mode 100644
index 000000000000..5cd3304133c4
--- /dev/null
+++ b/security/drweb-sendmail/files/patch-af
@@ -0,0 +1,22 @@
+--- ../sendmail/template.initscript.orig Wed Sep 26 01:02:29 2001
++++ ../sendmail/template.initscript Wed Oct 3 22:36:07 2001
+@@ -13,7 +13,7 @@
+ # Use these if cannot found functions
+ dw_daemon() {
+ ulimit -c 0
+- $* &
++ $*
+ return $?
+ }
+
+@@ -105,9 +105,7 @@
+ RETVAL=$?
+ if [ $RETVAL -eq 0 ] ; then
+ [ $FILTER_UNIX = "yes" ] && rm -f $FILTER_SOCKET
+- if [ "x$DAEMON_PID" != "x" ] ; then
+- sleep 1
+- fi
++ [ $DAEMON_UNIX = "yes" ] && chmod 660 $DAEMON_SOCKET
+ $PROC_DAEMON $FILTER_CMD
+ RETVAL=$?
+ fi