aboutsummaryrefslogtreecommitdiffstats
path: root/security/drweb-sendmail
diff options
context:
space:
mode:
authorache <ache@FreeBSD.org>2001-08-30 04:30:48 +0800
committerache <ache@FreeBSD.org>2001-08-30 04:30:48 +0800
commitb6d829facd3e28a7157beede994850e6025bd0b0 (patch)
treef61dbc7bd76a948a2fb13fda6915d8a5533ca93b /security/drweb-sendmail
parent454877d52c22667adec6307f30a9cd536b89ee79 (diff)
downloadfreebsd-ports-gnome-b6d829facd3e28a7157beede994850e6025bd0b0.tar.gz
freebsd-ports-gnome-b6d829facd3e28a7157beede994850e6025bd0b0.tar.zst
freebsd-ports-gnome-b6d829facd3e28a7157beede994850e6025bd0b0.zip
Don't attempt to notify empty <> sender
Diffstat (limited to 'security/drweb-sendmail')
-rw-r--r--security/drweb-sendmail/Makefile1
-rw-r--r--security/drweb-sendmail/files/patch-ab13
2 files changed, 12 insertions, 2 deletions
diff --git a/security/drweb-sendmail/Makefile b/security/drweb-sendmail/Makefile
index 6c1c7a23e751..1899e59e1f11 100644
--- a/security/drweb-sendmail/Makefile
+++ b/security/drweb-sendmail/Makefile
@@ -7,6 +7,7 @@
PORTNAME= drweb_sendmail
PORTVERSION= 4.25
+PORTREVISION= 1
CATEGORIES= security mail
MASTER_SITES= http://www.drweb.ru/ftp/web_pub/
DISTNAME= drwebd-${PORTVERSION}-freebsd4
diff --git a/security/drweb-sendmail/files/patch-ab b/security/drweb-sendmail/files/patch-ab
index 219193c9bd1a..1e7cf1fd9f43 100644
--- a/security/drweb-sendmail/files/patch-ab
+++ b/security/drweb-sendmail/files/patch-ab
@@ -1,5 +1,14 @@
---- dw_filter.c.bak Mon Jul 30 05:12:02 2001
-+++ dw_filter.c Sat Aug 25 15:27:15 2001
+--- dw_filter.c.orig Mon Jul 30 05:12:02 2001
++++ dw_filter.c Thu Aug 30 00:23:31 2001
+@@ -549,7 +549,7 @@
+ syslog( LOG_MAIL | LOG_DEBUG, "can not replace message" );
+ FAIL_EXIT( context, priv );
+ }
+- if( bSenderNotify && priv->from && (strlen(priv->from) > 0) )
++ if( bSenderNotify && priv->from && *(priv->from) && strcmp(priv->from, "<>") != 0)
+ {
+ if( smfi_addrcpt( context, priv->from ) != MI_SUCCESS )
+ {
@@ -585,7 +585,7 @@
syslog( LOG_MAIL | LOG_ERR, "daemon return error (%s) - possible problem with daemon", getDaemonCode( status ) );
FAIL_EXIT( context, priv );