aboutsummaryrefslogtreecommitdiffstats
path: root/security/f-prot-sig
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2004-02-23 09:45:55 +0800
committerlinimon <linimon@FreeBSD.org>2004-02-23 09:45:55 +0800
commitaaadb5e5a91730b4bcb2ba064b398c04aaa63f9f (patch)
treeb96199b3231cfa3d6c926ec0677a73a7de9ed8a1 /security/f-prot-sig
parentfafaea85d0f6c745ee9c979a093eba48940073d7 (diff)
downloadfreebsd-ports-gnome-aaadb5e5a91730b4bcb2ba064b398c04aaa63f9f.tar.gz
freebsd-ports-gnome-aaadb5e5a91730b4bcb2ba064b398c04aaa63f9f.tar.zst
freebsd-ports-gnome-aaadb5e5a91730b4bcb2ba064b398c04aaa63f9f.zip
Refactor f-prot into f-prot (for the code) and f-prot-sig (for the
signature definitions). This allows the definitions to be updated seperately as and when required. PR: ports/62917, 62918 Submitted by: Tim Bishop <tim@bishnet.net> (maintainer)
Diffstat (limited to 'security/f-prot-sig')
-rw-r--r--security/f-prot-sig/Makefile41
-rw-r--r--security/f-prot-sig/pkg-descr14
-rw-r--r--security/f-prot-sig/pkg-message19
-rw-r--r--security/f-prot-sig/pkg-plist7
4 files changed, 81 insertions, 0 deletions
diff --git a/security/f-prot-sig/Makefile b/security/f-prot-sig/Makefile
new file mode 100644
index 000000000000..94a827ba62cc
--- /dev/null
+++ b/security/f-prot-sig/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: f-prot-sig
+# Date created: 11 Feb 2004
+# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= f-prot-sig
+PORTVERSION= 20040216
+CATEGORIES= security
+MASTER_SITES= ftp://ftp.f-prot.com/pub/
+
+DISTFILES= fp-def.zip \
+ macrdef2.zip
+
+MAINTAINER= tim@bishnet.net
+COMMENT= F-Prot Antivirus Signatures
+
+# F-Prot does not version their .DEF files so the port always pulls the latest.
+NO_CHECKSUM= yes
+
+NO_PACKAGE= Free for personal use only
+NO_CDROM= Free for personal use only
+RESTRICTED= Free for personal use only
+
+NO_BUILD= YES
+NO_WRKSUBDIR= YES
+USE_ZIP= YES
+
+post-extract:
+.for fetched in ${DISTFILES}
+ ${MV} ${DISTDIR}/${fetched} ${DISTDIR}/${fetched}-${PORTVERSION}.zip
+.endfor
+
+do-install:
+ ${MKDIR} ${PREFIX}/f-prot
+ ${INSTALL_DATA} ${WRKSRC}/* ${PREFIX}/f-prot
+
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/security/f-prot-sig/pkg-descr b/security/f-prot-sig/pkg-descr
new file mode 100644
index 000000000000..207bded05cf3
--- /dev/null
+++ b/security/f-prot-sig/pkg-descr
@@ -0,0 +1,14 @@
+F-Prot Antivirus for BSD Workstations utilizes the renowned F-Prot
+Antivirus scanning engine for primary scan but has in addition to
+that a system of internal heuristics devised to search for unknown
+viruses.
+
+This port contains the virus signature files for use with F-Prot
+Antivirus which can be found in ports under security/f-prot .
+
+Please note that the license explicitly permits that F-Prot Antivirus
+for BSD Workstations is free for personal users on personal
+workstations. For any other use please consult their website for
+licensing information.
+
+WWW: http://www.f-prot.com/
diff --git a/security/f-prot-sig/pkg-message b/security/f-prot-sig/pkg-message
new file mode 100644
index 000000000000..1db0dd808cf9
--- /dev/null
+++ b/security/f-prot-sig/pkg-message
@@ -0,0 +1,19 @@
+***************************************************************************
+
+This is a port of the virus signature files for F-Prot Antivirus.
+You will need to install the port security/f-prot to make use of them.
+
+The port disables verifying the checksum of the distfiles due to their
+frequency of change. If you wish to verify the files yourself you may use
+the PGP signature files that have been installed in:
+
+${PREFIX}/f-prot/
+
+The F-RISK public PGP key is located at:
+
+http://www.f-prot.com/company/KEY.ASC
+
+NOTE: The script check-updates.pl is all ready included with the f-prot
+port and can be used as a secondary means of updating virus signature files.
+
+***************************************************************************
diff --git a/security/f-prot-sig/pkg-plist b/security/f-prot-sig/pkg-plist
new file mode 100644
index 000000000000..0da4dc90885a
--- /dev/null
+++ b/security/f-prot-sig/pkg-plist
@@ -0,0 +1,7 @@
+f-prot/SIGN.ASC
+f-prot/SIGN.DEF
+f-prot/SIGN2.ASC
+f-prot/SIGN2.DEF
+f-prot/MACRO.DEF
+f-prot/MACRO.ASC
+@unexec rmdir f-prot 2> /dev/null || true