aboutsummaryrefslogtreecommitdiffstats
path: root/security/fakeroot
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-03-25 16:30:27 +0800
committermarino <marino@FreeBSD.org>2015-03-25 16:30:27 +0800
commit12a3d18ba54eb521226a4ec0ed2aecfbcfcb24a8 (patch)
tree123ddeae4f07536b3d89acc6409ce124aa06d373 /security/fakeroot
parente59c5e2e130d16dc7ae04b960115c07010eaed3a (diff)
downloadfreebsd-ports-gnome-12a3d18ba54eb521226a4ec0ed2aecfbcfcb24a8.tar.gz
freebsd-ports-gnome-12a3d18ba54eb521226a4ec0ed2aecfbcfcb24a8.tar.zst
freebsd-ports-gnome-12a3d18ba54eb521226a4ec0ed2aecfbcfcb24a8.zip
security category: Remove $PTHREAD_LIBS
approved by: PTHREAD blanket
Diffstat (limited to 'security/fakeroot')
-rw-r--r--security/fakeroot/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/security/fakeroot/Makefile b/security/fakeroot/Makefile
index 975acbcade1d..f96e03e5ca98 100644
--- a/security/fakeroot/Makefile
+++ b/security/fakeroot/Makefile
@@ -21,12 +21,10 @@ USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-pre-configure:
- @${REINPLACE_CMD} -e '/LIBS=.*-lpthread/s/-lpthread/${PTHREAD_LIBS}/g' \
- ${WRKSRC}/${CONFIGURE_SCRIPT}
-
post-install:
- @${MV} ${STAGEDIR}${PREFIX}/lib/libfakeroot-0.so ${STAGEDIR}${PREFIX}/lib/libfakeroot.so.0
- @${LN} -sf ${PREFIX}/lib/libfakeroot.so.0 ${STAGEDIR}${PREFIX}/lib/libfakeroot-0.so
+ ${MV} ${STAGEDIR}${PREFIX}/lib/libfakeroot-0.so \
+ ${STAGEDIR}${PREFIX}/lib/libfakeroot.so.0
+ ${LN} -sf ${PREFIX}/lib/libfakeroot.so.0 \
+ ${STAGEDIR}${PREFIX}/lib/libfakeroot-0.so
.include <bsd.port.mk>