aboutsummaryrefslogtreecommitdiffstats
path: root/security/fpc-openssl
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2007-09-18 14:39:28 +0800
committeracm <acm@FreeBSD.org>2007-09-18 14:39:28 +0800
commitdb11d201a0626af81794d3ac34bbe724a7b70117 (patch)
treeece343fa3df712c35270f437af516a15d6d855c4 /security/fpc-openssl
parent7950f9ff4207eb6e28d12acaf31c3cdbb3749832 (diff)
downloadfreebsd-ports-gnome-db11d201a0626af81794d3ac34bbe724a7b70117.tar.gz
freebsd-ports-gnome-db11d201a0626af81794d3ac34bbe724a7b70117.tar.zst
freebsd-ports-gnome-db11d201a0626af81794d3ac34bbe724a7b70117.zip
- New port: security/fpc-openssl
Free Pascal unit for OpenSSL
Diffstat (limited to 'security/fpc-openssl')
-rw-r--r--security/fpc-openssl/Makefile23
-rw-r--r--security/fpc-openssl/pkg-plist9
2 files changed, 32 insertions, 0 deletions
diff --git a/security/fpc-openssl/Makefile b/security/fpc-openssl/Makefile
new file mode 100644
index 000000000000..92bf661fb7ed
--- /dev/null
+++ b/security/fpc-openssl/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: fpc-openssl
+# Date created: 2007-09-11
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+CATEGORIES= security lang
+PKGNAMESUFFIX= -openssl
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Free Pascal unit for OpenSSL
+
+BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc
+
+MASTERDIR= ${.CURDIR}/../../lang/fpc
+WRKUNITDIR= ${FPCSRCDIR}/packages/extra/${PKGNAMESUFFIX:S/-//}
+EXTRACTUNITDIR+= ${WRKUNITDIR}
+
+OPTIONS= OPENSSL "Install SSL and crypto library" on
+
+.include "${MASTERDIR}/Makefile"
diff --git a/security/fpc-openssl/pkg-plist b/security/fpc-openssl/pkg-plist
new file mode 100644
index 000000000000..92d1473ae6ae
--- /dev/null
+++ b/security/fpc-openssl/pkg-plist
@@ -0,0 +1,9 @@
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/openssl/Package.fpc
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/openssl/openssl.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/openssl/openssl.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/openssl/libpopenssl.a
+@dirrm lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/openssl
+@dirrmtry lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%
+@dirrmtry lib/fpc/%%PORTVERSION%%/units
+@dirrmtry lib/fpc/%%PORTVERSION%%
+@dirrmtry lib/fpc